SparkyLinux 3.5.1 E19

SparkyLinux 3.5.1 „Annagerman” Enlightenment 19 został wydany.

Nie tak dawno, jak trzy lata temu rozpocząłem swoją przygodę z Enlightenment i Ubuntu.
Na początku system nosił nazwę ue17r (Ubuntu E17 Remix) i miał niewiele wspólnego z obecnym SparkyLinux.
ue17r był pewnego rodzaju eksperymentem edycyjnym, dzięki któremu chciałem dowieść tezy, iż człowiek taki jak ja, nie będący programistą, jest w stanie zrobić coś o czym teoretycznie nie ma pojęcia.

Niestety (może stety) projekt na tyle mocno mnie wciągnął, iż trwa do dnia dzisiejszego.

ue17r oraz pierwsza wersja SparkyLinux 1.0 (Enlightenment, Fluxbox i Window Maker) były systemami mocno jeszcze niedopracowanymi, więc postanowiłem usunąć wszystkie ich kopie z serwera, aby nie raziły w oczy.

Sparky 2 posunął moje wyobrażenie o systemie mocno do przodu, dając mi sporą dawkę nowego doświadczenia.
Sparky 3, pomimo drobnych niedoskonałości jest wersją, z której jestem już zadowolony.

Sparky 3.5.1 E19 powstał dzięki sumie analizy poprzednich wydań i kumulacji doświadczenia zebranego na przestrzeni ostatnich lat. Jest pewnego rodzaju kamieniem milowym, który oferuję Wam dziś.
Wiele elementów/funkcji nie zostałoby dołączonych/zrealizowanych bez pomocy członków naszego małego zespołu oraz społeczności, za co oczywiście dziękuję.

Miej na uwadze, iż SparkyLinux nigdy nie był idealnym systemem i prawdopodobnie nigdy takim nie będzie. To od każdego z Was z osobna zależy, czy odnajdziecie w SparkyLinux więcej cech pozytywnych niż negatywnych, a używanie SparkyLinux sprawi Wam radość i satysfakcję.

Co posiada SparkyLinux 3.5.1 Enlightenment 19 „pod maską”?

Obraz iso SparkyLinux 3.5.1 E19 Live/Install dostarcza aktualizację pakietów z repozytorium Debiana testing oraz aktualizację Enlightenment z repozytorium git.
Pakiety Enlightenment zostały zaktualizowane do wersji 0.19.19.18964.
System działa na jądrze Linux 3.16 w towarzystwie systemd 215-5.

Wydanie 3.5.1 E19 dołączyło do grupy Base Edition.
Co to oznacza?
Obraz iso zawiera system bazowy, serwer grafiki, Enlightenment i minimalny zestaw narzędzi.
Tak więc masz wolną rękę i możesz dostosować system według uznania, instalując ulubione aplikacje za pomocą Synaptic, Sparky-APTus, Sparky-APTus-Extra lub APT.

SparkyLinux 3.5.1 E19 wyposażony jest w dwa motywy do wyboru.
1. RadianceE19-Sparky – zmodyfikowany motyw RadianceE19. Motyw ten został dopasowany do domyślnego motywu SparkyLinux ‚Sparky3-theme’ oraz domyślnego zestawu ikon ‚NoirCrystal’.
Tapeta została wykonana przez LiquidSky64.

RadianceE19-Sparky

2. Default (domyślny motyw Enlightenment) + motyw DeLorean-Dark dla integracji z aplikacjami GTK.

Dark theme

SparkyLinux jest dystrybucją ciągłą, więc nie musisz przeinstalowywać posiadanej wersji swojego systemu.
Jedyne, co musisz zrobić, to opuścić pulpit Enlightenment i wykonać aktualizację.

Użytkownicy E17:
apt-get remove e17 && apt-get autoremove
apt-get update
apt-get install e19 dolorean-dark

Użytkownicy E18:
apt-get remove enlightenment && apt-get autoremove
apt-get update
apt-get install e19 dolorean-dark

Użytkownicy Sparky 3.5 E19-dev (rekomendowane):
apt-get remove e19 && apt-get autoremove
apt-get update
apt-get install e19 dolorean-dark

lub (nie usuwa automatycznie poprzednich zależności ‚dev’):
apt-get apt-get update
apt-get dist-upgrade
apt-get install dolorean-dark

Sprawdź, czy aktualizacja nie spowodowała błędów:
apt-get install -f

 

Tapety przygotowane przez LiquidSky64 + dwie moje modyfikacje (green i gray):

enlightenmentgoldenradianceSparky    enlightenmentgoldenradianceSparky-green    enlightenmentgoldenradianceSparky-gray

CoffeeBreakSparkylinux    8mmb

 

Motywy Enlightenment można pobrać z sourceforge:
http://sourceforge.net/projects/sparkylinux/files/files/themes/
Nowe obrazy iso SparkyLinux można pobrać ze strony download_sparky

Znane błędy:
– w wersji 32 bitowej moduł ‚cpufreq’ został wyłączony z powodu błędu z uprawnieniami, pomimo zastosowania właściwych uprawnień i przyporządkowania go do użytkownika root
– moduł ‚systray’ wciąż nie działa poprawnie, więc również jest nieaktywny. Tacka systemowa jest dostępna za pośrednictwem dodatkowego, zminimalizowanego panelu LXDE ‚lxpanel’
– libglib2.0 2.40.0-5 i jego zależności nie zostały zaktualizowane do najnowszej wersji 2.42.0-1 z powodu błędu – poczekaj z jego aktualizacją do nowszej wersji

 
Release notes in English -> https://sparkylinux.org/sparkylinux-3-5-1-e19

 

Wsparcie

Wesprzyj Linuxiarze.pl i SparkyLinux

 

3 thoughts on “SparkyLinux 3.5.1 E19

  • 15/10/2014 at 5:18 pm
    Permalink

    Moim skromnym zdaniem wyszło super

    Reply
  • 15/10/2014 at 2:30 pm
    Permalink

    Wielkie dzięki.
    Trochę obawiałem się efektu końcowego. Jest to pierwsza edycja Enlightenment, którą kompilowałem ze źródeł oraz pierwszy motyw, który również sam przebudowałem. Chyba jednak wyszło całkiem dobrze :0

    Reply
  • 15/10/2014 at 2:17 pm
    Permalink

    pavroo , uwazam ze wykonaliscie ogrom dobrej roboty , system dziala plynnie , szybko i to na nie najmlodszym sprzecie , tak ze nie bede sie tu rozpisywal , wielka 5+ , aby tak dalej a sukces gwarantowany , pozdrawiam caly Wasz zespol , zachecam wszystkich do zapoznania sie ze Sparkylinux-em ,

    Reply

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *