SparkyLinux LXDE + systemd

Reklama na Linuxiarze.pl

 

Wczorajsza aktualizacja systemu powoduje problem.
Jeśli używasz ‚network-manager-gnome’ jako domyślnego menadżera sieci, to aktualizacja tego pakietu spowoduje problem w pulpicie Sparky LXDE.

‘network-manager-gnome’ jako jedną z zależności zainstaluje ‘systemd’.

Nie powoduje to problemu w żadnej wersji SparkyLinux, oprócz LXDE.
Sytuacja ta powoduje problem w narzędziu ‘lxsession-logout’, który działa poprawnie ze starym systemem startowym ‘sysvinit’.

Po instalacji ‚systemd’ w systemie z pulpitem LXDE nie można zamknąć lub restartować systemu używając standardowego narzędzia do wylogowania.
Usunięcie ‘systemd’ spowoduje również usunięcie pakietu ‘network-manager’.

Aby to naprawić, wykonaj pełną aktualizację wszystkich pakietów (wrzuciłem do repozytorium Sparka dodatkowe pakiety) oraz doinstaluj jeden dodatkowy pakiet:
apt-get update && apt-get dist-upgrade
apt-get install systemd-sysv

Następnie uruchom ponownie komputer wydając polecenie w terminalu:
reboot
lub
halt

Po tym zabiegu ‘sysvinit’ nie będzie już potrzebny.

 

 

Opublikowane: 10 / 04 / 2014 ,

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

Strefa Linuxiarzy