Sparky APTus 0.1.4

Reklama na Linuxiarze.pl

 

Dostępna jest aktualizacja Sparky APTus 0.1.4.

Zanim napiszę o nowych funkcjach, chciałbym zamieścić dwa słowa wprowadzenia.
Nawiążę w ten sposób do wypowiedzi Sajmona dotyczącej poprzedniej wersji APTus-a.

„apt-get upgrade” – polecenie to bezpiecznie zaktualizuje pakiety. Sprawdza się idealnie w Debianie z gałęzi stabilnej. W tym wydaniu nie ma mowy o „poważnych” zmianach w strukturze systemu. Większość zmian ogranicza się do aktualizacji bezpieczeństwa istniejących pakietów. W Debianie stabilnym celowym jest użycie „dist-upgrade” tylko w przypadku aktualizacji całego systemu do nowszej wersji stabilnej.

„apt-get dist-upgrade” – w Debianie z gałęzi testowej, na której bazuje Sparky nie ma mowy o „idealnie poukładanym” systemie – jest to „żywy organizm”. Tutaj deweloperzy Debiana wprowadzają nowe wersje istniejących pakietów oraz dostarczają zupełnie nowe pakiety. Czasami powoduje to pewne „zawirowania”, jednak jest to akceptowalne. Można aktualizować Sparka poleceniem „apt-get upgrade”, lecz według mnie ograniczy to dostęp do wielu nowości.
„dist-upgrade” może usunąć niektóre pakiety, przynależne do poprzedniej wersji Debiana i zasąpić je innymi, które będą kszałtowały wydanie testowe i co za tym idzie – następne wydanie stabilne. Jest to ofiara, którą można przełknąć, w zamian za dostarczane nowości.

Aby wilk był syty i owca cała, APTus 0.1.4 posiada teraz obydwie powyższe opcje do wyboru.

Dodane funkcje w Sparky APTus 0.1.4 :
– Upgrade – wykona tylko „apt-get upgrade”
– Dist_Upgrade – nie trzeba przedstawiać (poprzednio „Upgrade”) – zalecana metoda aktualizacji SparkyLinux
– Quick_Install – zainstaluje wybrany pakiet/pakiety po wpisaniu jego/ich nazwy w pole wyboru
– Quick_Install_DEB – zainstaluje wybraną paczkę „.deb” z dysku lokalnego wraz z zależnościami
– Quick_Remove – usunie wybrany pakiet/pakiety wraz z zależnościami
– Old_Kernel_Remove – usunie starą, nieaktywną wersję jądra wraz z jego nagłówkami

APTus

 

Zobacz podobne

Opublikowane: 15 / 09 / 2013 ,

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

Strefa Linuxiarzy