Sparky 5.0

Reklama na Linuxiarze.pl

 

Dostępne są nowe nośniki iso live/install SparkyLinux 5.0 o nazwie kodowej „Nibiru”.
Sparky 5 bazuje na Debianie z gałęzi testowej „Buster” i jest wydaniem ciągłym.

Z Wikipedii:

W babilońskich tekstach mitologicznych i astrologicznych słowo nēberu używane jest jako określenie poświęconego bogu Mardukowi ciała niebieskiego, często zwanego też „gwiazdą Marduka” (akad. kakkab Marduk)…
…Analiza tekstów pozwoliła uczonym zidentyfikować nēberu z dwoma różnymi ciałami niebieskimi: gwiazdą (Gwiazda Polarna) i planetą (Jowisz).

Sparky edycji „Home” dostarcza w pełni wyposażony system operacyjny z lekkimi pulpitami do wyboru: LXQt, MATE i Xfce.

Sparky MinimalGUI (Openbox) i MinimalCLI (tryb tekstowy) dostarcza system podstawowy z minimalną ilością programów oraz instalatorem Sparky Advanced Installer, który umożliwia zainstalowanie jednego z ponad 20 różnych pulpitów.

Zmiany pomiędzy wersjami 4.5 i 5.0:
– aktualizacja całego systemu z repozytoriów Debiana testowego „Buster” z dnia 14.07.2017
– jądro Linux 4.11.6 (4.12.x dostępne w repo Sparky „unstable”)
– nowy motyw „Sparky5”
– nowy motyw w edycji LXQt
– nowa domyślna tapeta, wykonana przez członka naszej społeczności „barti”
– nowy zestaw tapet z kategorii Natura, z wybranymi polskimi widokami, naszego autorstwa
– Calamares 3.1.1 jako domyślny instalator systemu
– nowe narzędzie do sprawdzania dostępności aktualizacji i wyświetlania info na pulpicie: Update Checker & Notifier

Pozostałe zmiany:
– dodane dodatkowe repozytoria: wine-staging.com
– klient poczty Icedove zastąpiony przez Thunderbird
– zmieniony protokół http na https oficjalnych repozytoriów; aktualizacja pakietu ‚sparky-apt’ zrobi to automatycznie
– nowe dwie opcje startowe systemu live:
1. toram – umożliwia załadowanie całego systemu live do pamięci RAM i usunięcie z portu nośnika USB lub płyty CD/DVD
2. text mode – w razie problemów systemu live uruchomionego w normalnym trybie graficznym lub bezpiecznym (safemode), ten tryb uruchamia system live w trybie tekstowym i umożliwia zainstalowanie systemu za pośrednictwem Advanced Installer (polecenie: sudo sparkylinux-installer)

Wydanie bazujące na Openbox (MinimalGUI) otrzymało 3 skróty klawiszowe:
– Super+t -> terminal emulator
– Super+r -> gexec
– Super+q -> logout window

Reinstalacja systemu nie jest wymagana.

Jeśli posiadasz starszą wersję SparkyLinux z linii 4 (do wersji 4.5), wykonaj pełną aktualizację wszystkich pakietów.

Aktualizacja ze starszej wersji SparkyLinux poleceniami:
sudo apt-get update
sudo apt-get dist-upgrade

W przypadku problemów:
sudo dpkg --configure -a
sudo apt-get install -f

Nowe nośniki iso można pobrać ze strony download_sparky

SparkyLinux LXQt

 

 

Opublikowane: 16 / 07 / 2017 ,

One comment on “Sparky 5.0
  1. Witam
    Gratulacje dla zespołu pracującym nad systemem Sparky !!! 64bit Mate
    Na dzień dzisiejszy jak dla mnie , dla zwykłego szaraczka nie informatyka ale po prostu użytkownika , jest to jedyny strawny system linux , który spełnia po trochu moje oczekiwania.
    Mianowicie chciałbym aby system linux zapewnił mi takie podstawowe funkcjonowanie i poprawne uruchamianie następujących programów : internet , Kodi 17.1 , Kaffeine (odbiór TV naziemnej z DVBT-usb) oraz Kmid2 ( odtwarzanie plików *.mid i karaoke *.kar)
    Do tej pory używałem linuxa minta cynamon albo mate, lecz tak około kwietnia 2017 komuś odbiła palma i porobił jakieś hocki-klocki , wszystko działało piknie w wersji Mint 17.3 cinnamon 64 bit i nagle w kwietniu po aktualizacji zaczął się wywracać kodi. To zaczęły się poszukiwania systemu który by spełnił moje oczekiwania. Juz myślałem , ze znalazłem klona Ubuntu – Mate 17,04 Kodi działa ale tylko na kablu, bo Wi-Fi to za diabła nie się połączyć. No to krzyżyk na ubuntu i pochodnych. Wpadłem na szalony pomysł , może tak spróbować Fedory 25. Jakież miłe pierwsze wrażenie , wszystko bzyka a program do karaoke to sam się konfiguruje mam dźwięk z midów i to całkiem dobrej jakości , szczęście było ogromne do czasu oczywiście. Po aktualizacji Fedora przestała widzieć moją kartę Wi-FI na USB , no to sru do kosza system. Już kilka razy wcześniej próbowałem Sparky , lecz zawsze było coś co dyskryminowało ten system. Zawsze używałem programu Rufus do sprawdzania dystrybucji Linux za pomocą pendrive. Jak pamiętam ostatnia dystrybucja Sparky 4.coś tam to nawet nie chciała się odpalać z takiego pena. Sparky nie miał nawet podstawowej szansy na sprawdzenie.
    A tu widzę jest jakaś nowa wersja typoszereg zaczynający się od 5.
    Co tam szkodzi zobaczyć , to włączenie windowsa , Rufusa załadować obraz Sparky 5,0 Mate 64 bity i jazda. Odpala bez pudła !! , no to na „lajfie” instaluje Kodi i znowu działa. Wziąłem się i mówię , trza to zainstalować na twardzielu na którym miałem zainstalowany ubuntu Mate po modyfikacjach tak aby mógł łączyć się z netem , masa szukania po forach aby to w końcu zadziałało /kulawo ale zawsze to coś/.
    Odpalam Sparky z USB chcę instalować na dysku , a tutaj każą mi wybierać zaawansowany czy zwykły instalator, na miłość boską skąd mam wiedzieć ? Wybieram zwykły instalator , i tutaj miła niespodzianka widok znajomy z instalatora Minta, od razu poczułem się lepiej, nie muszę od nowa się uczyć , za chwile znowu coś miłego w instalatorze Sparky pojawiło się małe okienko do zaptaszkowania z podpisem autologin i to samo hasło do roota i administratora ( mniejsza upierdliwość później podczas uruchamiania) , następnie wybieram ręczne partycjonowanie i ustawiam part. Boot – ext4 – formatowanie
    part. / – ext4 – formatowanie
    part. Swap – pozostawiam nienaruszoną
    part. Home – ext4 – formatowanie
    zaczyna się instalacja , udało się !!!!!
    Restart , aktualizacja i instalowanie Kodi 17,3 jest w repozytoriach – super – działała
    Kaffeine jest repozytoriach – działała
    teraz karaoke Kmid2 i timidity++ nie ma w repo – szkoda
    miałem pliczek Kmid2.deb może wejdzie – wszedł, program się zainstalował , lecz z playerkiem midi już są kłopoty timidity++ nie ma w repo , a starsza wersja do ubuntu 16,04 nie działa bo jakiś pierdółek brakuje w repo. Twórcy Fedory 25 potrafili to umieścić w repozytoriach rpm
    w końcu sobie poradziłem , tymczasowo zainstalowałem inny playerek midi fluidsynth co prawda było masa problemów , lecz już kiedyś z tym walczyłem i coś mi się tam kleciło , w sumie gra i buczy.
    Przystępuje do normalnego użytkowania systemu. Instaluje ulubione dodatki do Kodi , działają no to super. Jak to zwykle z Linuxami bywa szczęście trwało krótko. Włączam sobie z dodatku wizja tv jakiś program telewizyjny np. eurosport a tu dźwięk wyje niemiłosiernie , no to ściszam na glośniczku na dole z prawej strony – można oglądać .. hurrra . Przełączam kanał i znowu to samo dźwięk wyje i znowu ściszanie zapewne brakuje jakiegoś pamiętnika w systemie 🙁
    teraz włączam Kaffeine , skanuje kanały telewizyjne – wszystko działa pięknie , ale już się boję co będzie gdy włączę jakiś kanał , moje obawy były uzasadnione , dźwięk znowu wyje na maxa.
    Lubię wiedzieć so się dzieje z komputerem , więc dodaje do paska szybkiego uruchamiana monitor systemu. Otwieram i ustawiam zakładkę ‘ zasoby ‘ , sprawdzam ile pamięci jak bzyka procesor i co mi komp ciągnie z netu. Wyłączam i ponownie włączam , ustawiona zakładka ‘zasoby’ nie została zapamiętana znowu trzeba na nią najechać i ustawić znowu brak pamiętnika. To wszystko da się jakoś przeżyć tym użytkownikom którzy są zawzięci a co z nerwusami ?
    No to przyszedł czas na zainstalowanie programu do sprawdzanie sieci WI-Fi
    LinSSID jest w repo 🙂 instaluje idzie ładnie , tylko ze jest jedna poważna wada nie da się uruchomić programu po instalacji 🙁
    Posiadałem stary pliczek IWscannner.deb , jakież moje zdziwienie – działa bez pudła
    No to jeszcze Macchanger-gtk buuu 🙁 nie ma w repozytoriach, a do tego aby korzystać z terminalowej wersji nie mam zdrowia 🙁
    Wavemon jest w repo i działa , jakiś cud, lecz wifite nie ma w repo i nie da się uruchomić starszej wersji bo znowu brakuje jakiś pierdółek w systemie i brak tych cudeniek w repo.
    Trochę powalczyłem z systemem i mówię sobie trza zrobić restart
    Tutaj kolejna niespodzianka , podczas uruchamiania systemu pojawiła się linia każąca mi czekać dodatkowe 1min 30 sec , no szlag by trafił mówię sobie ciągle coś. W końcu uruchomił się system , włączam monitor systemu i nagle zauważam ze partycja swap nie współpracuje , zapewne dlatego iż podczas instalacji nie formatowałem tej partycji , choć zawsze tak robiłem przy innych systemach i zawsze działało a Sparky powiedział nie, musisz chłopie sformatować tą partycje. Zainstalowałem Gparted i partycji Swap nadałem nowy UUID bez formatowania, po czym zmodyfikowałem plik fstab
    i restart . Uff już nie liczy tego 1min 30sec a partycja swap współpracuje.
    I to było by na tyle co się rzuciło tak od razu po instalacji systemu Sparky 5,0
    Moja ocena zwykłego użytkownika systemu jest w skali szkolnej 4+
    Zaznaczę iż jest na dzień dzisiejszy to jedyny system Linux spełniający moje oczekiwania , bije na głowę Minta , który był do tej pory najbardziej przyjaznym systemem Linux jak dla mnie.
    Dopracowując szczególiki Sparky może się stać poważnym konkurentem dla innych systemów linuxowych używanych przez normalnych ludzi nie będącymi informatykami.
    PS
    Zapomniał bym o jednym bajerze , który widziałem podczas testowania innych linuxów
    Któraś dystrybucja Knoppixa posiadała takie pływające okna podczas przesuwania a podczas uruchamiania okna koziołkowały , wartałoby dołączyć takie opcja w zakładce konfiguracji systemu
    Zawsze to jakiś szpan dla tych co z linuxami nie mieli nic wspólnego
    Brakuje pulpitu cinnamon , bo mate już jest 🙂
    Pozdrawiam i życzę sukcesów zespołowi Sparky
    Jacek
    Soundforge

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

Strefa Linuxiarzy


Wolna strefa


linia

linia