Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: Niepoprawny lub uszkodzony pakiet  (Przeczytany 4926 razy)

Offline Grzegorz

  • Full Member
  • ***
  • Wiadomości: 160
  • Inżynier to pewien stan umysłu , a nie tytuł.
Niepoprawny lub uszkodzony pakiet
« dnia: Czerwiec 13, 2015, 07:48:12 am »
Dzień dobry
Mam problem z aktualizacją systemu.Mój system to :
System: Host: manjaro Kernel: 3.16.7.8-1-MANJARO x86_64 (64 bit gcc: 4.9.2)
Desktop: Xfce 4.12.0-MANJARO (Gtk 2.24.27)
Distro: ManjaroLinux 0.8.12 Ascella

System: Host: manjaro Kernel: 3.16.7.8-1-MANJARO x86_64 (64 bit gcc: 4.9.2)
Pulpit: Xfce 4.12.0-MANJARO (Gtk 24.02.27)
Dystrybucja: ManjaroLinux 0.8.12 Ascella

Tak wygląda błąd wyrzucony podczas aktualizacji.


(113/113) sprawdzanie kluczy w bazie               [######################] 100%
(113/113) sprawdzanie spójności pakietów           [######################] 100%
błąd:  hunspell-pl: signature from "Johannes Löthberg <johannes@kyriasis.com>" is unknown trust
:: Plik /var/cache/pacman/pkg/hunspell-pl-20150428-2-any.pkg.tar.xz jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] T
błąd:  nie udało się dokonać transakcji (Niepoprawny lub uszkodzony pakiet)
Wystąpiły błędy, nie zaktualizowano żadnego pakietu.
[grzegorz@manjaro ~]$
Grzegorz

Offline Grzegorz

  • Full Member
  • ***
  • Wiadomości: 160
  • Inżynier to pewien stan umysłu , a nie tytuł.
Odp: Niepoprawny lub uszkodzony pakiet
« Odpowiedź #1 dnia: Czerwiec 13, 2015, 04:39:06 pm »
Z tego co się dowiedziałem to jedyne co można zrobić, to czekać na ich aktualizacji pakietu kluczy ArchLinux..
Jest inny sposób na rozwiązanie problemu?
gdzie można zgłosić błąd?
Grzegorz

Offline Grzegorz

  • Full Member
  • ***
  • Wiadomości: 160
  • Inżynier to pewien stan umysłu , a nie tytuł.
Odp: Niepoprawny lub uszkodzony pakiet
« Odpowiedź #2 dnia: Sierpień 17, 2015, 08:56:16 am »
Dzień dobry
Wykonałem  dziś 17 sierpień aktualizacje , zaskoczenie bo w niej dużo błędów. Czy to błędy ważne , mające wpływ na pracę systemu?
 :: Kontynuować instalację? [T/n] T
:: Pobieranie pakietów…
błąd:  nie udało się pobrać pliku 'linux-api-headers-4.1.4-1-x86_64.pkg.tar.xz' z ftp.halifax.rwth-aachen.de : The requested URL returned error: 404
 linux-api-headers-4...   766,5 KiB  1111K/s 00:01 [######################] 100%
błąd:  nie udało się pobrać pliku 'tzdata-2015f-1-any.pkg.tar.xz' z ftp.halifax.rwth-aachen.de : The requested URL returned error: 404
 tzdata-2015f-1-any       214,2 KiB  1210K/s 00:00 [######################] 100%
błąd:  nie udało się pobrać pliku 'glibc-2.22-1-x86_64.pkg.tar.xz' z ftp.halifax.rwth-aachen.de : The requested URL returned error: 404
 glibc-2.22-1-x86_64        8,1 MiB  1237K/s 00:07 [######################] 100%
błąd:  nie udało się pobrać pliku 'binutils-2.25.1-2-x86_64.pkg.tar.xz' z ftp.halifax.rwth-aachen.de : The requested URL returned error: 404
 binutils-2.25.1-2-x...     4,4 MiB  1295K/s 00:04 [######################] 100%
błąd:  nie udało się pobrać pliku 'gettext-0.19.5-1-x86_64.pkg.tar.xz' z ftp.halifax.rwth-aachen.de : The requested URL returned error: 404
 gettext-0.19.5-1-x86_64    2,1 MiB  1291K/s 00:02 [######################] 100%
błąd:  nie udało się pobrać pliku 'libassuan-2.2.1-1-x86_64.pkg.tar.xz' z ftp.halifax.rwth-aachen.de : The requested URL returned error: 404
 libassuan-2.2.1-1-x...    80,7 KiB  1344K/s 00:00 [######################] 100%
błąd:  nie udało się pobrać pliku 'pinentry-0.9.5-1-x86_64.pkg.tar.xz' z ftp.halifax.rwth-aachen.de : The requested URL returned error: 404
 pinentry-0.9.5-1-x86_64  113,4 KiB  89,5K/s 00:01 [######################] 100%
błąd:  nie udało się pobrać pliku 'gnupg-2.1.7-1-x86_64.pkg.tar.xz' z ftp.halifax.rwth-aachen.de : The requested URL returned error: 404
 gnupg-2.1.7-1-x86_64    1889,5 KiB  1059K/s 00:02 [######################] 100%
błąd:  nie udało się pobrać pliku 'gpgme-1.5.5-1-x86_64.pkg.tar.xz' z ftp.halifax.rwth-aachen.de : The requested URL returned error: 404
 gpgme-1.5.5-1-x86_64     231,3 KiB  1033K/s 00:00 [######################] 100%
błąd:  nie udało się pobrać pliku 'hdparm-9.48-1-x86_64.pkg.tar.xz' z ftp.halifax.rwth-aachen.de : The requested URL returned error: 404
 hdparm-9.48-1-x86_64      70,3 KiB  1256K/s 00:00 [######################] 100%
błąd:  nie udało się pobrać pliku 'libnl-3.2.26-1-x86_64.pkg.tar.xz' z ftp.halifax.rwth-aachen.de : The requested URL returned error: 404
 libnl-3.2.26-1-x86_64    323,4 KiB  1293K/s 00:00 [######################] 100%
błąd:  nie udało się pobrać pliku 'iw-4.1-1-x86_64.pkg.tar.xz' z ftp.halifax.rwth-aachen.de : The requested URL returned error: 404
 iw-4.1-1-x86_64           56,1 KiB  1403K/s 00:00 [######################] 100%
błąd:  nie udało się pobrać pliku 'pam-1.2.1-1-x86_64.pkg.tar.xz' z ftp.halifax.rwth-aachen.de : The requested URL returned error: 404
 pam-1.2.1-1-x86_64       606,4 KiB  1271K/s 00:00 [######################] 100%
błąd:  nie udało się pobrać pliku 'kbd-2.0.3-1-x86_64.pkg.tar.xz' z ftp.halifax.rwth-aachen.de : The requested URL returned error: 404
 kbd-2.0.3-1-x86_64      1121,9 KiB  1122K/s 00:01 [######################] 100%
błąd:  nie udało się pobrać pliku 'libseccomp-2.2.3-1-x86_64.pkg.tar.xz' z ftp.halifax.rwth-aachen.de : The requested URL returned error: 404
 libseccomp-2.2.3-1-...    56,0 KiB  1399K/s 00:00 [######################] 100%
błąd:  nie udało się pobrać pliku 'libpcap-1.7.4-1-x86_64.pkg.tar.xz' z ftp.halifax.rwth-aachen.de : The requested URL returned error: 404
 libpcap-1.7.4-1-x86_64   217,4 KiB  1163K/s 00:00 [######################] 100%
błąd:  nie udało się pobrać pliku 'man-pages-4.02-1-any.pkg.tar.xz' z ftp.halifax.rwth-aachen.de : The requested URL returned error: 404
 man-pages-4.02-1-any       5,4 MiB  1286K/s 00:04 [######################] 100%
błąd:  nie udało się pobrać pliku 'pacman-4.2.1-3-x86_64.pkg.tar.xz' z ftp.halifax.rwth-aachen.de : The requested URL returned error: 404
 pacman-4.2.1-3-x86_64    666,4 KiB  1155K/s 00:01 [######################] 100%
błąd:  nie udało się pobrać pliku 'ppp-2.4.7-2-x86_64.pkg.tar.xz' z ftp.halifax.rwth-aachen.de : The requested URL returned error: 404
 ppp-2.4.7-2-x86_64       282,9 KiB  1230K/s 00:00 [######################] 100%
błąd:  nie udało się pobrać pliku 'sqlite-3.8.11.1-2-x86_64.pkg.tar.xz' z ftp.halifax.rwth-aachen.de : The requested URL returned error: 404
 sqlite-3.8.11.1-2-x...   761,8 KiB  1278K/s 00:01 [######################] 100%
błąd:  nie udało się pobrać pliku 'xfsprogs-3.2.3-1-x86_64.pkg.tar.xz' z ftp.halifax.rwth-aachen.de : The requested URL returned error: 404
Grzegorz

Offline Albedo 0.64

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 593
Odp: Niepoprawny lub uszkodzony pakiet
« Odpowiedź #3 dnia: Sierpień 18, 2015, 07:27:05 pm »
Witaj. Wygląda na to, że masz coś nie tak z repozytoriami, jesli nie udało się pacmanowi pobrać plików, to nie było instalacji/aktualizacji i nic nie powinno się zmienić w systemie. W tej sytuacji spróbowałbym naprawić wpisy w pliku mirrorlist. Sprawdź tu: http://linuxiarze.pl/repozytoria_arch/
Linux Mint Debian
Linux registered user 556565

Offline Grzegorz

  • Full Member
  • ***
  • Wiadomości: 160
  • Inżynier to pewien stan umysłu , a nie tytuł.
Odp: Niepoprawny lub uszkodzony pakiet
« Odpowiedź #4 dnia: Sierpień 23, 2015, 10:33:48 am »
Witam
Sprzątałem dziś system, sprawdziłem aktualizacje  i otrzymałem taki komunikat:


Katalog bazy danych: /var/lib/pacman/
:: Czy chcesz usunąć nieużywane repozytoria? [T/n] T
usuwanie nieużywanych repozytoriów…
[grzegorz@manjaro ~]$ sudo pacman -Syyu
:: Synchronizowanie baz danych z pakietami…
 core                     134,1 KiB   771K/s 00:00 [######################] 100%
 extra                   1880,2 KiB  1264K/s 00:01 [######################] 100%
 community                  3,0 MiB  1266K/s 00:02 [######################] 100%
ostrzeżenie: brakująca blokada pliku /var/lib/pacman/db.lck
 multilib                 167,1 KiB  1316K/s 00:00 [######################] 100%
:: Rozpoczynanie pełnej aktualizacji systemu…
 nie ma nic do zrobienia
ostrzeżenie: brakująca blokada pliku /var/lib/pacman/db.lck
Grzegorz

Offline Grzegorz

  • Full Member
  • ***
  • Wiadomości: 160
  • Inżynier to pewien stan umysłu , a nie tytuł.
Odp: Niepoprawny lub uszkodzony pakiet
« Odpowiedź #5 dnia: Sierpień 23, 2015, 10:49:38 am »
Chyba udało mi się naprawić  lub usunąć uszkodzony pakiet:

[grzegorz@manjaro ~]$ sudo pacman -Syy
[sudo] hasło użytkownika grzegorz:
:: Synchronizowanie baz danych z pakietami…
 core                     134,1 KiB   758K/s 00:00 [######################] 100%
 extra                   1880,2 KiB  1282K/s 00:01 [######################] 100%
 community                  3,0 MiB  1288K/s 00:02 [######################] 100%
 multilib                 167,1 KiB  1228K/s 00:00 [######################] 100%
[grzegorz@manjaro ~]$ sudo pacman -Sc
Pakiety do zachowania:
  Lokalnie zainstalowane pakiety

Katalog pamięci podręcznej : /var/cache/pacman/pkg/
:: Czy chcesz usunąć odinstalowane pakiety z pamięci podręcznej? [T/n]
usuwanie starych pakietów z pamięci podręcznej…

Katalog bazy danych: /var/lib/pacman/
:: Czy chcesz usunąć nieużywane repozytoria? [T/n]
usuwanie nieużywanych repozytoriów…
[grzegorz@manjaro ~]$
Grzegorz

Offline Albedo 0.64

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 593
Odp: Niepoprawny lub uszkodzony pakiet
« Odpowiedź #6 dnia: Sierpień 24, 2015, 06:18:34 pm »
Brawo! Teraz wygląda dobrze. Jeszcze trochę a będziesz ekspertem w Manjaro.
Linux Mint Debian
Linux registered user 556565