Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: Elementary os Luna  (Przeczytany 3384 razy)

Offline skoczek5001

  • Newbie
  • *
  • Wiadomości: 5
Elementary os Luna
« dnia: Maj 05, 2015, 11:18:47 am »
Witam mam problem. Na swojej Lunie mam zainstalowany program Spotify. Wszystko działało do pewnego momentu. Nie pamiętam chyba był to dzień aktualizacji systemu.
Od tamtej pory naciskam na ikonę spotify by włączyć program a progam się nie włącza. Ikona nawet podskakuje w typowym stylu dla elementary jednak dalej nic się nie dzieje. Korzystam teraz ze spotify webplayer, jednak nie ukrywam, że program był dużo wygodniejszy.

Pyt: Co się stało? Co muszę zrobić aby naprawić ten problem?

Pozdrawiam i dziękuję za pomoc.

Piotr

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1524
Odp: Elementary os Luna
« Odpowiedź #1 dnia: Maj 05, 2015, 01:03:03 pm »
Witaj
Spróbuj uruchomić program w konsoli tekstowej, poleceniem:
spotifyi sprawdź wynik błędu, który zostanie wyświetlony.
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline skoczek5001

  • Newbie
  • *
  • Wiadomości: 5
Odp: Elementary os Luna
« Odpowiedź #2 dnia: Maj 06, 2015, 08:24:03 am »
piotr@piotr-ThinkPad-X61:~$ spotify
spotify: error while loading shared libraries: libudev.so.1: cannot open shared object file: No such file or directory
piotr@piotr-ThinkPad-X61:~$

Offline skoczek5001

  • Newbie
  • *
  • Wiadomości: 5
Odp: Elementary os Luna
« Odpowiedź #3 dnia: Maj 06, 2015, 08:43:35 am »
>Przeinstalowywałem go już kilka razy. Co teraz zrobić?

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1524
Odp: Elementary os Luna
« Odpowiedź #4 dnia: Maj 06, 2015, 12:55:03 pm »
Przeinstalowanie nic nie zmieni.
Trzeba skoncentrować się na błędzie.
Jeśli posiadasz system w wersji 64 bitowej, to w pierwszej kolejności doinstaluj pakiet libudev0 32 bitowy:
sudo apt-get update
sudo apt-get install libudev0:i386
Jeśli wciąż będzie problem to utwórz dodatkowe dowiązanie symboliczne (jeśli system 64 bitowy!):
cd /lib/x86_64-linux-gnu/
sudo ln -sf libudev.so.1 libudev.so.0
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline skoczek5001

  • Newbie
  • *
  • Wiadomości: 5
Odp: Elementary os Luna
« Odpowiedź #5 dnia: Maj 07, 2015, 11:06:58 am »
Jestem naprawde zły. Wpisałem tą komendę i komputer nagle przestał sie włączać dochodzi do momentu gdzie ładuje sie logo ,,e" a następnie pojawia się błąd. Proszę pomóżcie mam tam ważne pliki.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1524
Odp: Elementary os Luna
« Odpowiedź #6 dnia: Maj 07, 2015, 12:40:35 pm »
W takim wypadku uruchom system w trybie ratunkowym, zaloguj sie na konto admina (root) i usuń pakiet, który zainstalowałeś.
apt-get remove libudev0:i386
apt-get autoremove
reboot
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline skoczek5001

  • Newbie
  • *
  • Wiadomości: 5
Odp: Elementary os Luna
« Odpowiedź #7 dnia: Maj 07, 2015, 03:04:34 pm »
No to słodko, bo już zrobiłem formata. i oczywiście straciłem Całe ostatnie godziny pracy.

Dzisiaj jest mój zły dzień.