Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: problem z flashem  (Przeczytany 2884 razy)

Offline despo

  • Newbie
  • *
  • Wiadomości: 16
problem z flashem
« dnia: Styczeń 31, 2015, 04:02:21 pm »
witam
posiadam lubuntu 14.10 i mam problem z flashem
na mozilli chodzi a na chromium nie, zainstalowałem pepperflashplugin i wyskakuje teraz że: Shockowave flash has crashed.
coś da się z tym zrobić?
z góry dziękuje za odp
pozdrawiam

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1523
Odp: problem z flashem
« Odpowiedź #1 dnia: Styczeń 31, 2015, 09:19:41 pm »
Instalacja pepper wygląda następująco:
sudo apt-get install pepperflashplugin-nonfreeNastępnie:
sudo update-pepperflashplugin-nonfree --installMożesz sprawdzić czy wtyczka została poprawnie zainstalowana:
sudo update-pepperflashplugin-nonfree --status
Czy Twoja instalacja uwzględniła dwa pierwsze polecenia?
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline despo

  • Newbie
  • *
  • Wiadomości: 16
Odp: problem z flashem
« Odpowiedź #2 dnia: Luty 01, 2015, 09:13:22 am »
Tak dwa pierwsze zrobiłem przy czym po wpisaniu drugiego polecenia nic nie wyświetliło (pojawiła się nazwa komputera, konta ta sama co na początku gdy się włącza terminał)
Na chromie jest to samo czyli wyświetla się żółty pasek z tą samą informacją (tak samo jak w chromium)

Offline Maromann

  • Jr. Member
  • **
  • Wiadomości: 61
Odp: problem z flashem
« Odpowiedź #3 dnia: Luty 01, 2015, 11:46:20 am »
można przecież zainstalować googleowego chrome'a. ściągasz ze strony odpowiednią wersję i instalujesz za pomocą np. gdebi (znajduje zależności). wpis do repozytorium sam się doda automatycznie.

pzdr.

Offline despo

  • Newbie
  • *
  • Wiadomości: 16
Odp: problem z flashem
« Odpowiedź #4 dnia: Luty 01, 2015, 06:28:29 pm »
Miałem zainstalowanego google chrome ściągniętego z internetu (z głównej strony chrome) wyskakiwało to samo co napisałem w pierwszym poście

Offline Maromann

  • Jr. Member
  • **
  • Wiadomości: 61
Odp: problem z flashem
« Odpowiedź #5 dnia: Luty 01, 2015, 06:40:14 pm »
co to znaczy zainstalowanego? instalując za pomocą dpkg brakuje zależości (albo trzeba to naprawić apt-getem, albo poprawnie zainstalować gdebi). to może powodować błąd.
jeżeli chrome był zainstalowany poprawnie (chrome plus u mnie siedem dodatkowych pakietów), a nie działa i jest to sprawa kluczowa, to trzeba zmienić dystrybucję. na prostym, stabilnym choć lekko backportowanym  debianie nie było żadnych problemów. miałem zarówno chromium + peppermint flash jak i chrome'a

pzdr.

Offline despo

  • Newbie
  • *
  • Wiadomości: 16
Odp: problem z flashem
« Odpowiedź #6 dnia: Luty 01, 2015, 08:25:32 pm »
to może mi kolega napisać jak to poprawnie zainstalować chrome?
bardziej mi zależy żeby chromium mi otwarzał flasha poprawnie ponieważ jest lżejszy

Offline darekradzan

  • Sr. Member
  • ****
  • Wiadomości: 264
Odp: problem z flashem
« Odpowiedź #7 dnia: Luty 02, 2015, 06:37:20 am »
@despo
Jaka wersja tego lubuntu , 32 czy 64 bit?
Dla 32 bit
wget https://dl.google.com/linux/direct/google-chrome-stable_current_i386.debnastepnie
sudo dpkg -i google-chrome-stable_current_i386.deb
dla 64
wget https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.debpotem
sudo dpkg -i google-chrome-stable_current_amd64.debMozesz tez przez PPA
najpierw pobierz i zainstaluj klucz , czyli

wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add -teraz dodaj repozytoria google , czyli
sudo sh -c 'echo "deb http://dl.google.com/linux/chrome/deb/ stable main" >> /etc/apt/sources.list.d/google-chrome.list'i juz prawie koniec , zaktualizuj repozytoria
sudo apt-get updateno i zainstaluj google-chrome
sudo apt-get install google-chromePamietaj ze w linux bardzo wazne sa podczas wpisywania komend wszelkie znaki , mala/duza litera , wszystkie znaki interpunkcyjne , tak ze najlepiej kopiuj/wklejaj te polecenia , ktore Ci podalem , albo bardzo dokladnie przepisuj
Pozdrawiam , milego dzionka

Offline Maromann

  • Jr. Member
  • **
  • Wiadomości: 61
Odp: problem z flashem
« Odpowiedź #8 dnia: Luty 02, 2015, 06:52:53 am »
niby po angielsku, ale są obrazki
http://www.cyberciti.biz/faq/how-to-install-google-chrome-in-ubuntu-linux-12-xx-13-xx/

@darekradzan zabraknie chyba zależności (sudo apt-get -f install). ponadto, instalator sam doda repozytorium google'a (przynajmniej u mnie dodał). instalowanie za poocą gdebi package installera jest chyba najmniej bolesne.

Offline despo

  • Newbie
  • *
  • Wiadomości: 16
Odp: problem z flashem
« Odpowiedź #9 dnia: Luty 02, 2015, 03:04:57 pm »
zainstalowałem według poleceń kolegi darekradzam i dalej mi wyskakuje że Shockwave Flash has crashed
po odświerzeniu wyskakuje to samo
czy jest na to lekarstwo?

Offline darekradzan

  • Sr. Member
  • ****
  • Wiadomości: 264
Odp: problem z flashem
« Odpowiedź #10 dnia: Luty 02, 2015, 03:18:42 pm »
zobacz tutaj masz odpowiedz/rozwiazanie
http://www.pcadvisor.co.uk/how-to/internet/3332967/how-stop-shockwave-flash-crashing-in-google-chrome/

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1523
Odp: problem z flashem
« Odpowiedź #11 dnia: Luty 02, 2015, 03:18:42 pm »
Jeśli zainstalowałeś google-chrome z oficjalnej paczki od producena i flash nie działa, to najlepiej zgłosić to na forum producenta/developera programu.
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline darekradzan

  • Sr. Member
  • ****
  • Wiadomości: 264
Odp: problem z flashem
« Odpowiedź #12 dnia: Luty 02, 2015, 03:28:00 pm »
Jeszcze raz sie wtrace, pavroo ma swieta racje , ale nie wiem despo , czy logujac sie do google , nie pociagnales jakis wlasnie bledow dotyczacych wtyczek/rozszerzen
a wpisz , tam gdzie wpisuje sie adres w przegladarce
chrome:pluginsi podaj jaki masz numerek przy
Cytuj
Adobe Flash Player - Wersja:
Shockwave Flash

P.s teraz jeszcze gdzies tam doczytalem , ze moze to byc wina akceleracji sprzetowej , i ze warto wtedy przeinstalowac kodeki (jest taki temat na angielskim forum Minta)
« Ostatnia zmiana: Luty 02, 2015, 03:43:36 pm wysłana przez darekradzan »

Offline despo

  • Newbie
  • *
  • Wiadomości: 16
Odp: problem z flashem
« Odpowiedź #13 dnia: Luty 02, 2015, 08:19:42 pm »
proszę

Adobe Flash Player - Wersja: 16.0.0.296
Shockwave Flash 16.0 r0

Offline darekradzan

  • Sr. Member
  • ****
  • Wiadomości: 264
Odp: problem z flashem
« Odpowiedź #14 dnia: Luty 03, 2015, 06:23:50 am »
Czyli masz najnowsze wersje ,to i dobrze , a moze sprobowac calkowicie odinstalowac flasha , a nastepnie ponownie go zainstalowac.
Nie pamietam jak dokladnie nazywa sie ta paczka w lubuntu , ale wpisz w konsoli
apt-cache search flash ,
powinno wyswietlic Ci jak ten flashplugin ktory masz zainstalowany sie nazywa , bedzie to chyba cos takiego jak
Cytuj
adobe-flashplugin
, ale sprawdz dokladnie , nstepnie w konsoli
sudo apt-get purge adobe-flashpluginmoze jeszcze bedzie potrzebna komenda
dpkg --purge adobe-flashpluginPo calkowitym odinstalowaniu , wyczysc system
sudo apt-get clean potem pobierz ze strony producenta paczke flasha odpowiednia dla swojego systemu
http://get.adobe.com/pl/flashplayer/?no_redirect
i ja zainstaluj (chyba najprosciej przez gdebi , prawy klik na pobrana paczke i "otworz za pomoca gdebi", jesli system nie ma zainstalowanego gdebi do doinstaluj
sudo apt-get install gdebi ). Jak i to nie pomoze , to nie wiem , chyba najlatwiej zmienic przegladarke
pozdrawiam