Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: Repozytoria nie czyta ?  (Przeczytany 1408 razy)

Offline ptr91

  • Wiadomości: 9
Repozytoria nie czyta ?
« dnia: Marzec 30, 2014, 09:52:35 pm »
Witam, na wstępie dodam, że linuxem bawie sie od kilku godzin. Wersja testowa, jessie, amd64. Mam problem z Repozytoriami. W pliku soruces.list mam je wpisane tak:

Code:

deb http://ftp.pl.debian.org/debian/ testing main contrib non-free
deb-src http://ftp.pl.debian.org/debian/ testing main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free




Po zapisaniu i zrobieniu update komendą aptitude albo apt_get wyskakuje mi tak:

Code:

Ign cdrom://[Debian GNU/Linux testing _Jessie_ - Official Snapshot amd64 gnome-CD Binary-1 20140324-06:22] jessie InRelease
Ign cdrom://[Debian GNU/Linux testing _Jessie_ - Official Snapshot amd64 gnome-CD Binary-1 20140324-06:22] jessie Release.gpg
Ign cdrom://[Debian GNU/Linux testing _Jessie_ - Official Snapshot amd64 gnome-CD Binary-1 20140324-06:22] jessie Release
Ign cdrom://[Debian GNU/Linux testing _Jessie_ - Official Snapshot amd64 gnome-CD Binary-1 20140324-06:22] jessie/main amd64 Packages/DiffIndex




Robiac upgrade:

Code:

Reading package lists... Done
Building dependency tree      
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


Nie znam sie na tym ale według mnie nie czyta mi moich repozytoriow. Pisze o tym gdyz chcialem wgrac mc i z czasem dodawac rozne programy.



Dodam jeszcze, że miałem problem przy instalacji gdyż zawieszał mi sie instalator na karcie bezprzewodowej, Dopiero gdy ją wyłączyłem moglem przejsc dalej. Niestety nie znalazłem rozwiązania na ten problem. Gdy po zainstalowanym debianie chce w biosie ponownie ją włączyć system zatrzymuje sie zaraz za logowaniem. Obecnie jade na kablu. Pozdrawiam i z góry dziekuje za zainteresowanie.





« Ostatnia zmiana: Marzec 30, 2014, 09:52:35 pm wysłana przez 1014 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1527
Odp: Repozytoria nie czyta ?
« Odpowiedź #1 dnia: Marzec 30, 2014, 10:11:33 pm »
System korzysta z repozytoriów, które użyte były podczas instalacji Debiana.

W ich skład wchodzi również płyta instalacyjna.

Masz dwa wyjścia:

1. Przed aktualizacja listy pakietów wsadź do napędu i zamontuj w/w płytę.

2. Żeby tego nie robić za każdym razem przy aktualizacji lub instalacji pakietów, edytuj listę repozytoriów:

Code:

su
nano /etc/apt/sources.list


i usuń wpis dotyczący płyty z listy repozytoriów, który widnieje na górze listy:

Code:

cdrom://[Debian GNU/Linux testing _Jessie_ - Official Snapshot amd64 gnome-CD Binary-1 20140324-06:22]


Aby rozwiązać kwestię karty wifi, podaj wynik poleceń:

Code:

lspci | grep Wireless
lsusb


« Ostatnia zmiana: Marzec 30, 2014, 10:11:33 pm wysłana przez 2 »
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline ptr91

  • Wiadomości: 9
Odp: Repozytoria nie czyta ?
« Odpowiedź #2 dnia: Marzec 30, 2014, 10:20:30 pm »
1. Płyta w napędzie mi nic nie daje.

2. NIe mam żadnego wpisu dotyczacego plyty, w tej liscie jak pisałem mam tylko wpisane to co podałem.

Dlatego sie głowie już z tym bo czytam kilka godzin i nic nie moge znalezc.

Code:

Bus 004 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 004: ID 0bda:0139 Realtek Semiconductor Corp. RTS5139 Card Reader Controller
Bus 003 Device 003: ID 1d57:ad03 Xenta
Bus 003 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 04f2:b2e1 Chicony Electronics Co., Ltd
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub




« Ostatnia zmiana: Marzec 30, 2014, 10:20:30 pm wysłana przez 1014 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1527
Odp: Repozytoria nie czyta ?
« Odpowiedź #3 dnia: Marzec 30, 2014, 10:33:45 pm »
Czy to jest cały wpis w pliku source.list?

Code:

deb http://ftp.pl.debian.org/debian/ testing main contrib non-free
deb-src http://ftp.pl.debian.org/debian/ testing main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free


Po pierwsze jest za krótki, po drugie, standardowo powinno być 'jessie' zamiast 'testing'.

Według mnie lista jest niekompletna, usuń wszystko co tam jest i wklej:

Code:

deb http://ftp.pl.debian.org/debian/ jessie main contrib non-free
deb-src http://ftp.pl.debian.org/debian/ jessie main contrib non-free
deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free
deb http://www.deb-multimedia.org/ jessie main non-free
# jessie-updates, previously known as 'volatile'
deb http://ftp.pl.debian.org/debian/ jessie-updates main contrib non-free
deb-src http://ftp.pl.debian.org/debian/ jessie-updates non-free contrib main


Poza tym nie podałeś mi wyniku polecenia 'lspci'.
« Ostatnia zmiana: Marzec 30, 2014, 10:33:45 pm wysłana przez 2 »
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline ptr91

  • Wiadomości: 9
Odp: Repozytoria nie czyta ?
« Odpowiedź #4 dnia: Marzec 30, 2014, 10:42:58 pm »


Code:

00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM76 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 635M] (rev a1)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 05)




Zmienilem, zapisalem, update, upgrade i bez zmian.



« Ostatnia zmiana: Marzec 30, 2014, 10:42:58 pm wysłana przez 1014 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1527
Odp: Repozytoria nie czyta ?
« Odpowiedź #5 dnia: Marzec 30, 2014, 10:50:28 pm »
1. Spróbuj coś zainstalować (np. mc) i podaj cały wynik operacji:

Code:

apt-get update
apt-get install mc


2. Lspci nie wykazał żadnego urządzania wifi, czy to polecenie wydałeś z podłączonym/włączonym wifi?

Jest to urządzenie USB czy wbudowane, jeśli wbudowane to czy nie masz włącznika?

« Ostatnia zmiana: Marzec 30, 2014, 10:50:28 pm wysłana przez 2 »
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline ptr91

  • Wiadomości: 9
Odp: Repozytoria nie czyta ?
« Odpowiedź #6 dnia: Marzec 30, 2014, 10:54:24 pm »
update

Code:

Ign cdrom://[Debian GNU/Linux testing _Jessie_ - Official Snapshot amd64 gnome-CD Binary-1 20140324-06:22] jessie InRelease
Ign cdrom://[Debian GNU/Linux testing _Jessie_ - Official Snapshot amd64 gnome-CD Binary-1 20140324-06:22] jessie Release.gpg
Ign cdrom://[Debian GNU/Linux testing _Jessie_ - Official Snapshot amd64 gnome-CD Binary-1 20140324-06:22] jessie Release
Ign cdrom://[Debian GNU/Linux testing _Jessie_ - Official Snapshot amd64 gnome-CD Binary-1 20140324-06:22] jessie/main amd64 Packages/DiffIndex
Reading package lists... Done


mc

Code:

Reading package lists... Done
Building dependency tree      
Reading state information... Done
E: Unable to locate package mc


2. Co do karty to tak jak pisałem na początku mam wyłączone w biosie bo gdy włącze i podam login i haslo do mojego konta na debianie to nie laduje sie nic. Przy instalacji tez musiałem wyłączyć bo nie chciało pójsc z instalacji graficznej jak i normalnej.
« Ostatnia zmiana: Marzec 30, 2014, 10:54:24 pm wysłana przez 1014 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1527
Odp: Repozytoria nie czyta ?
« Odpowiedź #7 dnia: Marzec 31, 2014, 12:26:16 am »
Proponuję abyś zainstalował Debiana ponownie, z wyłączonym wifi lecz z podłączonym eth i bez żadnych kombinacji.

Możesz również (przed instalacją) wypróbować SparkyLinux, np. wersję Base. Sprawdź czy zadziała wifi w Live i czy załaduje się grafika (przy włączonym wifi w bios). Sparky w pełni bazuje na Debianie testowym.

Jeśli grafika załaduje się w Live z włączonym wifi, zapisz wynik polecenia lspci.

Jeśli się nie załaduje, uruchom live w trybie ratunkowym i zapisz wynik lspci.

Aby zmniejszyć ilość danych z tego polecenia, uruchom go z dodatkową opcją:

Code:

lspci | grep Wireless


Poza tym poszukaj informacji o wifi w specyfikacji producenta komputera, tj. nazwę, model, numer, chipset, etc.
« Ostatnia zmiana: Marzec 31, 2014, 12:26:16 am wysłana przez 2 »
Nic nie jest tak proste, jak się wydaje.
Danielle Steel