Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: MX 17 do 18.2  (Przeczytany 3111 razy)

Offline TataPingu

  • Hero Member
  • *****
  • Wiadomości: 1319
Odp: MX 17 do 18.2
« Odpowiedź #45 dnia: Kwiecień 29, 2019, 08:41:51 pm »
Nie wiem czy to ma znaczenie ale antixa mam zainstalowanego -NO Pae (mam 3 giga ramu)

A co mówi komenda:
free
ewentualnie:
free -m

Offline stefan1980

  • Full Member
  • ***
  • Wiadomości: 122
Odp: MX 17 do 18.2
« Odpowiedź #46 dnia: Kwiecień 29, 2019, 08:53:16 pm »
$ free
              total        used        free      shared  buff/cache   available
Mem:        3093728      583044     1780156       54876      730528     2348168
Swap:             0           0           0
stefan1980@filon1980:~
$ free -m
              total        used        free      shared  buff/cache   available
Mem:           3021         540        1773          53         707        2322
Swap:             0           0           0
Dodam jeszcze że jeżeli uruchomię kernel-systemd to dużo szybciej mi się ładuje system i wyłacza.
« Ostatnia zmiana: Kwiecień 29, 2019, 08:57:34 pm wysłana przez stefan1980 »

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 1330
Odp: MX 17 do 18.2
« Odpowiedź #47 dnia: Kwiecień 29, 2019, 09:02:04 pm »
Ja pierdzu... po cholerę Ci tyle kerneli.
4.9 działa. Wyrzucasz wszystkie oprócz najnowszego (cyfry po drugiej kropce muszą być jak największe). Nie wiem jaki masz procesor, ale prawdopodobnie możesz wyrzucić również wszystkie z 486 w nazwie (to procesor z lat 90, myślę, że Twój obsługuje już 686). PAE jest dla RAM > 3GB, stąd też jest Ci obojętny. Sprawdź, który lepiej działa: pae - czy "nie-pae". 4.13 możesz również wyrzucić. 4.19 - u Ciebie działa źle - wyrzuć. 4.14 jest ok. Ma długie jeszcze wsparcie. Sprawdź. 5.0? Spróbuj. Nikt Ci nie powie, czy to dobry kernel w Twoim przypadku.

Offline TataPingu

  • Hero Member
  • *****
  • Wiadomości: 1319
Odp: MX 17 do 18.2
« Odpowiedź #48 dnia: Kwiecień 29, 2019, 09:09:38 pm »
Dodam jeszcze że jeżeli uruchomię kernel-systemd to dużo szybciej mi się ładuje system i wyłacza.

- więc używaj systemd, a pae nie musisz mieć, ram jest w pełni wykorzystany...

Offline Fibogacci

  • Jr. Member
  • **
  • Wiadomości: 88
Odp: MX 17 do 18.2
« Odpowiedź #49 dnia: Kwiecień 29, 2019, 09:16:14 pm »
No dobra a 4.13 moge usunac z gruba i zainstalowac np 5.09 jak pisał fibo?
wynik z cli-aptix

Nie wiem czy to już pisałem, ale możesz wszystko, to Twój system i Twój komputer ;)

Zasada skutecznego działania (nie tylko w instalacji kernela/systemu) jest prosta: 1. Wykonaj czynność 2. Obserwuj efekty 3. Jeśli są zadowalające, to po robocie 4. Jeśli nie są zadowalające, zmodyfikuj/zmień czynność i wykonaj ponownie 5. Obserwuj efekty itd. Do osiągnięcia celu.

To może być czasochłonne czasami, ale ogólnie działa. Próby i błędy. Wnioski. Czysta nauka.

Spróbuj 5tki, a jak nie będzie ok to spróbuj 4.9.170

Jak z systemd szybciej, to startuj z systemd - liczy się efekt, bo o efekt Ci chodzi - sprawny komputer.
« Ostatnia zmiana: Kwiecień 29, 2019, 09:24:18 pm wysłana przez Fibogacci »

Offline TataPingu

  • Hero Member
  • *****
  • Wiadomości: 1319
Odp: MX 17 do 18.2
« Odpowiedź #50 dnia: Kwiecień 29, 2019, 09:16:59 pm »
Ja pierdzu... po cholerę Ci tyle kerneli.

Nie Pawle, on ich nie ma zainstalowanych, to jest tylko lista kerneli, które może zainstalować...
- cli-aptiX mu to wylistował (narzędzie MXa)

Offline Fibogacci

  • Jr. Member
  • **
  • Wiadomości: 88
Odp: MX 17 do 18.2
« Odpowiedź #51 dnia: Kwiecień 29, 2019, 09:19:16 pm »
Ja pierdzu... po cholerę Ci tyle kerneli.

Nie Pawle, on ich nie ma zainstalowanych, to jest tylko lista kerneli, które może zainstalować...
- cli-aptiX mu to wylistował (narzędzie MXa)

I to zapewne tylko jej kawałek, bo u mnie ich wyskakuje 54 sztuki ;)

Edit: a niedokładnie napisałem, wszystkich (z antiXami) mam 54, samych antiXów tylko 8 (przy 64bitowej wersji systemu)
« Ostatnia zmiana: Kwiecień 29, 2019, 09:22:03 pm wysłana przez Fibogacci »

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 1330
Odp: MX 17 do 18.2
« Odpowiedź #52 dnia: Kwiecień 29, 2019, 09:45:22 pm »
Nie Pawle, on ich nie ma zainstalowanych, to jest tylko lista kerneli, które może zainstalować...
- cli-aptiX mu to wylistował (narzędzie MXa)
No fakt. Mea culpa. Reszta pozostaje. Ma mieć kernel 4.9.x (najlepiej ostatni z możliwych) - bo działa prawidłowo, PAE nie jest konieczne.
Każdy inny z listy wspieranych kerneli jest ok. Oczywiście nie mój system - nie moje pchły, a zatem można użyć dowolnego. Jeśli działa nieprawidłowo, to w pierwszej kolejności należy zastanowić się dlaczego (bo mi działały kernele od 2.x po obecny 5.0.10 bez problemów), albo po prostu skupić się na działających.
Więcej niż 2 - zbytek łaski.
SystemD zasadniczo musi działać szybciej niż tradycyjny, a zatem tu wszystko ok.
Przy okazji - w przypadku Stefana pogoń za najnowszymi wersjami kernela chyba nie ma sensu. Toż to system z dość odległych czasów. Wystarczą po prostu dwa działające z różnych linii (np. 4.9 i 4.14, czy 4.4). Lista wspieranych kerneli przez upstream (za przeproszeniem guzik mnie obchodzą zapewnienia jakiejś dystrybucji, ale znów - nie mój system) jest tu: https://www.kernel.org/ a okres wsparcia tu: https://www.kernel.org/category/releases.html Kernele, które nie są oznaczone jako longterm (obecnie 5.0 i prawdopodobnie przyszły 5.1 również) są wspierane kilka miesięcy. O ile pamiętam - standardowo dwa. W przypadku Stefana - wg mnie bez sensu. Lepiej się skupić na LTS (longterm) i skupiłbym się właśnie na tych wspieranych przez kernel.org a nie zapewnieniach opiekunów dystrybucji różnych o cudownej ich opiece na kernelami, które umarły. Jednak jak wspomniałem - nie mój system.

Offline stefan1980

  • Full Member
  • ***
  • Wiadomości: 122
Odp: MX 17 do 18.2
« Odpowiedź #53 dnia: Kwiecień 29, 2019, 10:00:29 pm »
Wypróbowałem już wersje 5.0.9 antix. Muł przy starcie systemu. Pavbaranov dobrze tu pisze że trzeba bedzię zostać przy wersji 4.9 tylko spojrzeć na LTS bo powyżej tego to za długo startuje system. 4.14 powtórka z rozrywki czyli kaszanka na starcie.Mogę sie jescze tutaj pobawić ale  chyba nie będzie większego sensu. Tutaj lista kerneli z cli-aptix
     1) (I) linux-image-4.13.0-1-686-pae - Linux 4.13 for modern PCs
     2) linux-image-4.13.0-1-686 - Linux 4.13 for older PCs
     3) linux-image-4.14.0-0.bpo.3-686-pae - Linux 4.14 for modern PCs
     4) linux-image-4.14.0-0.bpo.3-686 - Linux 4.14 for older PCs
     5) linux-image-4.14.0-0.bpo.3-rt-686-pae - Linux 4.14 for modern PCs, PREEMPT_RT
     6) linux-image-4.14.0-3-686-pae - Linux 4.14 for modern PCs
     7) (I) linux-image-4.14.0-3-686 - Linux 4.14 for older PCs
     8) linux-image-4.14.0-3-rt-686-pae - Linux 4.14 for modern PCs, PREEMPT_RT
     9) linux-image-4.14.12-antix.1-686-smp-pae - Linux kernel, version 4.14.12-antix.1-686-smp-pae
    10) linux-image-4.14.12-gnu-antix.1-686-smp-pae - Linux kernel, version 4.14.12-gnu-antix.1-686-
    11) linux-image-4.14.14-antix.1-686-smp-pae - Linux kernel, version 4.14.14-antix.1-686-smp-pae
    12) linux-image-4.15.0-1-686-pae - Linux 4.15 for modern PCs
    13) linux-image-4.15.0-1-686 - Linux 4.15 for older PCs
    14) linux-image-4.18.0-2-686-pae - Linux 4.18 for modern PCs
    15) linux-image-4.18.0-2-686 - Linux 4.18 for older PCs
    16) linux-image-4.18.0-2-rt-686-pae - Linux 4.18 for modern PCs, PREEMPT_RT
    17) linux-image-4.19.0-1-686-pae-unsigned - Linux 4.19 for modern PCs
    18) (I) linux-image-4.19.0-1-686-unsigned - Linux 4.19 for older PCs
    19) linux-image-4.19.0-1-rt-686-pae-unsigned - Linux 4.19 for modern PCs, PREEMPT_RT
    20) linux-image-4.19.25-antix.1-486-smp - Linux kernel, version 4.19.25-antix.1-486-smp
    21) linux-image-4.19.25-antix.1-686-smp-pae - Linux kernel, version 4.19.25-antix.1-686-smp-pae
    22) linux-image-4.19.36-antix.1-486-smp - Linux kernel, version 4.19.36-antix.1-486-smp
    23) linux-image-4.19.36-antix.1-686-smp-pae - Linux kernel, version 4.19.36-antix.1-686-smp-pae
    24) linux-image-4.20.12-antix.1-486-smp - Linux kernel, version 4.20.12-antix.1-486-smp
    25) linux-image-4.20.12-antix.1-686-smp-pae - Linux kernel, version 4.20.12-antix.1-686-smp-pae
    26) linux-image-4.9.0-3-686-dbg - Debug symbols for linux-image-4.9.0-3-686
    27) linux-image-4.9.0-3-686-pae-dbg - Debug symbols for linux-image-4.9.0-3-686-pae
    28) linux-image-4.9.0-3-686-pae - Linux 4.9 for modern PCs
    29) linux-image-4.9.0-3-686 - Linux 4.9 for older PCs
    30) linux-image-4.9.0-3-rt-686-pae-dbg - Debug symbols for linux-image-4.9.0-3-rt-686-pae
    31) linux-image-4.9.0-3-rt-686-pae - Linux 4.9 for modern PCs, PREEMPT_RT
    32) linux-image-4.9.0-4-686-dbg - Debug symbols for linux-image-4.9.0-4-686
    33) linux-image-4.9.0-4-686-pae-dbg - Debug symbols for linux-image-4.9.0-4-686-pae
    34) linux-image-4.9.0-4-686-pae - Linux 4.9 for modern PCs
    35) linux-image-4.9.0-4-686 - Linux 4.9 for older PCs
    36) linux-image-4.9.0-4-rt-686-pae-dbg - Debug symbols for linux-image-4.9.0-4-rt-686-pae
    37) linux-image-4.9.0-4-rt-686-pae - Linux 4.9 for modern PCs, PREEMPT_RT
    38) linux-image-4.9.0-5-686-dbg - Debug symbols for linux-image-4.9.0-5-686
    39) linux-image-4.9.0-5-686-pae-dbg - Debug symbols for linux-image-4.9.0-5-686-pae
    40) linux-image-4.9.0-5-686-pae - Linux 4.9 for modern PCs
    41) linux-image-4.9.0-5-686 - Linux 4.9 for older PCs
    42) linux-image-4.9.0-5-rt-686-pae-dbg - Debug symbols for linux-image-4.9.0-5-rt-686-pae
    43) linux-image-4.9.0-5-rt-686-pae - Linux 4.9 for modern PCs, PREEMPT_RT
    44) linux-image-4.9.0-6-686-dbg - Debug symbols for linux-image-4.9.0-6-686
    45) linux-image-4.9.0-6-686-pae-dbg - Debug symbols for linux-image-4.9.0-6-686-pae
    46) linux-image-4.9.0-6-686-pae - Linux 4.9 for modern PCs
    47) linux-image-4.9.0-6-686 - Linux 4.9 for older PCs
    48) linux-image-4.9.0-6-rt-686-pae-dbg - Debug symbols for linux-image-4.9.0-6-rt-686-pae
    49) linux-image-4.9.0-6-rt-686-pae - Linux 4.9 for modern PCs, PREEMPT_RT
    50) linux-image-4.9.0-7-686-dbg - Debug symbols for linux-image-4.9.0-7-686
    51) linux-image-4.9.0-7-686-pae-dbg - Debug symbols for linux-image-4.9.0-7-686-pae
    52) linux-image-4.9.0-7-686-pae - Linux 4.9 for modern PCs
    53) linux-image-4.9.0-7-686 - Linux 4.9 for older PCs
    54) linux-image-4.9.0-7-rt-686-pae-dbg - Debug symbols for linux-image-4.9.0-7-rt-686-pae
    50) linux-image-4.9.0-7-686-dbg - Debug symbols for linux-image-4.9.0-7-686
    51) linux-image-4.9.0-7-686-pae-dbg - Debug symbols for linux-image-4.9.0-7-686-pae
    52) linux-image-4.9.0-7-686-pae - Linux 4.9 for modern PCs
    53) linux-image-4.9.0-7-686 - Linux 4.9 for older PCs
    54) linux-image-4.9.0-7-rt-686-pae-dbg - Debug symbols for linux-image-4.9.0-7-rt-686-pae
    55) linux-image-4.9.0-7-rt-686-pae - Linux 4.9 for modern PCs, PREEMPT_RT
    56) linux-image-4.9.0-8-686-dbg - Debug symbols for linux-image-4.9.0-8-686
    57) linux-image-4.9.0-8-686-pae-dbg - Debug symbols for linux-image-4.9.0-8-686-pae
    58) linux-image-4.9.0-8-686-pae - Linux 4.9 for modern PCs
    59) linux-image-4.9.0-8-686 - Linux 4.9 for older PCs
    60) linux-image-4.9.0-8-rt-686-pae-dbg - Debug symbols for linux-image-4.9.0-8-rt-686-pae
    61) linux-image-4.9.0-8-rt-686-pae - Linux 4.9 for modern PCs, PREEMPT_RT
    62) linux-image-4.9.0-9-686-dbg - Debug symbols for linux-image-4.9.0-9-686
    63) linux-image-4.9.0-9-686-pae-dbg - Debug symbols for linux-image-4.9.0-9-686-pae
    64) linux-image-4.9.0-9-686-pae - Linux 4.9 for modern PCs
    65) linux-image-4.9.0-9-686 - Linux 4.9 for older PCs
    66) linux-image-4.9.0-9-rt-686-pae-dbg - Debug symbols for linux-image-4.9.0-9-rt-686-pae
    67) linux-image-4.9.0-9-rt-686-pae - Linux 4.9 for modern PCs, PREEMPT_RT
    68) linux-image-4.9.160-antix.1-486-smp - Linux kernel, version 4.9.160-antix.1-486-smp
    69) linux-image-4.9.160-antix.1-686-smp-pae - Linux kernel, version 4.9.160-antix.1-686-smp-pae
    70) (I) linux-image-4.9.160-antix.2-486-smp - Linux kernel, version 4.9.160-antix.2-486-smp
    71) linux-image-4.9.170-antix.1-486-smp - Linux kernel, version 4.9.170-antix.1-486-smp
    72) linux-image-4.9.170-antix.1-686-smp-pae - Linux kernel, version 4.9.170-antix.1-686-smp-pae
    73) linux-image-5.0.9-antix.1-486-smp - Linux kernel, version 5.0.9-antix.1-486-smp
    74) (I) linux-image-5.0.9-antix.1-686-smp-pae - Linux kernel, version 5.0.9-antix.1-686-smp-pae
    75) linux-image-586 - Jądro Linux do starszych komputerów (pakiet atrapa)
    76) linux-image-686-dbg - Debugging symbols for Linux 686 configuration (meta-package)
    77) linux-image-686-pae-dbg - Debugging symbols for Linux 686-pae configuration (meta-package)
    78) linux-image-686-pae - Jądro Linux do nowoczesnych pecetów (metapakiet)
    79) linux-image-686 - Linux for older PCs (meta-package)
    80) linux-image-rt-686-pae-dbg - Debugging symbols for Linux rt-686-pae configuration (meta-pack
    81) linux-image-rt-686-pae - Linux for modern PCs (meta-package), PREEMPT_RT

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 1330
Odp: MX 17 do 18.2
« Odpowiedź #54 dnia: Kwiecień 29, 2019, 10:05:22 pm »
Gwoli ścisłości. Długi start systemu na 99% jest związany z jakąś wadliwą konfiguracją. Niemniej jednak - nic na siłę. Gdzieś tam masz swój wątek o 4.19 - po prostu wróć do niego, a używaj jako podstawowy ten, który Ci pasuje, czyli 4.9.
PS: 4.9 jest LTS/longterm. Masz w poprzednim wątku i oznaczenia i wspieranie i do kiedy. LTS=longterm