Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: MX 17 do 18.2 [ROZWIĄZANY]  (Przeczytany 3427 razy)

Offline stefan1980

  • Full Member
  • ***
  • Wiadomości: 136
Odp: MX 17 do 18.2
« Odpowiedź #30 dnia: Kwiecień 28, 2019, 08:45:49 pm »
dobra poszedl w ruch grub customizer i wywalilem z rozruchu 4.19 i zostala wersja 4.13. Z ciekawosci zainstalowalem jadro antixa 4.9 i uruchamia sie dosc szybko. Zobaczę jeszcze inne kernele bo widzialem tam jeszcze oprocz antixa parę kerneli debiana. Jeżeli  nie bedzie cos dzialac to najwyzej skonczy sie ponowna instalacja systemu

Offline PomPom

  • Hero Member
  • *****
  • Wiadomości: 1485
  • Nienawistnik Debiana; Dumny użytkownik Windows 10
Odp: MX 17 do 18.2
« Odpowiedź #31 dnia: Kwiecień 28, 2019, 08:51:16 pm »
Już lepiej 4.9 niż 4.13, bo ten pierwszy chociaż LTS i łatany. A wynik 6 minut to piękna oznaka problemu, którym może warto się zainteresować.
Mam nadzieję, że przejdzie ta ustawa, że Linuxa będą mogli używać tylko ludzie w wieku 240 lat.

Offline Fibogacci

  • Jr. Member
  • **
  • Wiadomości: 98
Odp: MX 17 do 18.2
« Odpowiedź #32 dnia: Kwiecień 28, 2019, 09:25:58 pm »
dobra poszedl w ruch grub customizer i wywalilem z rozruchu 4.19 i zostala wersja 4.13. Z ciekawosci zainstalowalem jadro antixa 4.9 i uruchamia sie dosc szybko. Zobaczę jeszcze inne kernele bo widzialem tam jeszcze oprocz antixa parę kerneli debiana. Jeżeli  nie bedzie cos dzialac to najwyzej skonczy sie ponowna instalacja systemu

Są różne wersje 4.9, antix ma nawet 4.9.170

https://i.ibb.co/K01gg4J/kernels.png


Dosyć wygodnym (jak dla mnie) sposobem szukania i instalowania kernelów w MX/antiX w terminalu jest program cli-aptiX. Między innymi kernelów, bo to wygodne narzędzie do instalacji wszystkich programów/pakietów - tylko w terminalu. Też po polsku już.

$ sudo cli-aptiX

Kolejne narzędzie, które sprawia przyjemność ułatwiając życie ;)

Jak widać na screenie, jest już dostępny kernel 5.0 dla antiX.

A jeżeli coś nie będzie działać po zmianach kernela, nie musisz od razu ponownie instalować systemu (ech, te nawyki z innych systemów ;) ), trzeba tylko uruchamiać system wskazując mu inny kernel do rozruchu.
« Ostatnia zmiana: Kwiecień 28, 2019, 09:32:44 pm wysłana przez Fibogacci »

Offline TataPingu

  • Hero Member
  • *****
  • Wiadomości: 1319
Odp: MX 17 do 18.2
« Odpowiedź #33 dnia: Kwiecień 29, 2019, 08:30:10 am »
dobra poszedl w ruch grub customizer i wywalilem z rozruchu 4.19 i zostala wersja 4.13. Z ciekawosci zainstalowalem jadro antixa 4.9 i uruchamia sie dosc szybko. Zobaczę jeszcze inne kernele bo widzialem tam jeszcze oprocz antixa parę kerneli debiana. Jeżeli  nie bedzie cos dzialac to najwyzej skonczy sie ponowna instalacja systemu

"Zabawa" z kernelami może być (ale nie musi, zależy od wstępnego przygotowania narzędzi, w MX wygląda to raczej OK) niebezpieczna dla systemu...
- tak, czy owak, za każdym razem, po takiej zmianie dobrze jest jeszcze zrobić:
sudo apt-get autoremove
i dodatkowo, co teoretycznie jest zbędne, ale w praktyce występuje, uruchomić Synaptica i zlikwidować tam tzw "zbędne pozostałości" (nie wiem jak to brzmi w j. polskim)

Dopiero po tych "zabiegach" system ("debianowce") jest "czysty"...

Offline Fibogacci

  • Jr. Member
  • **
  • Wiadomości: 98
Odp: MX 17 do 18.2
« Odpowiedź #34 dnia: Kwiecień 29, 2019, 02:05:19 pm »

"Zabawa" z kernelami może być (ale nie musi, zależy od wstępnego przygotowania narzędzi, w MX wygląda to raczej OK) niebezpieczna dla systemu...
- tak, czy owak, za każdym razem, po takiej zmianie dobrze jest jeszcze zrobić:
sudo apt-get autoremove
i dodatkowo, co teoretycznie jest zbędne, ale w praktyce występuje, uruchomić Synaptica i zlikwidować tam tzw "zbędne pozostałości" (nie wiem jak to brzmi w j. polskim)

Dopiero po tych "zabiegach" system ("debianowce") jest "czysty"...

Może być, chociaż w MX i antiX robiłem już upgrade/instalacje i odinstalowanie/cofanie kernelów kilka razy na różnych komputerach i bez problemu zawsze wszystko gra i buczy. I niech tak zostanie ;)

Co do czyszczenia, to ja z nawyku raz na jakiś czas robię w terminalu:

$ sudo apt-get autoremove
$ sudo apt-get clean
$ sudo apt-get autoclean

w różnej, bywa, kolejności.

Ja osobiście bardzo rzadko uruchamiam Synaptica, nauczyło mnie doświadczenie (i porady innych), że w MX lepiej i skuteczniej działa dedykowany MX Instalator pakietów. Synaptic czasem robił jakiś problem przy instalacji.

Ogólnie deweloperzy MX zalecają używanie MXIP - wtedy nie ma problemów w większości przypadków.

No i jest wygodniejszy, ale to kwestia przyzwyczajenia.

Z ciekawostek, istnieje jeszcze np. taka opcja/narzędzie, jak aktualizacja kernela w Live-USB, chociaż jeszcze tego nie testowałem. Kiedyś się pobawię.
« Ostatnia zmiana: Kwiecień 29, 2019, 02:07:05 pm wysłana przez Fibogacci »

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 1338
Odp: MX 17 do 18.2
« Odpowiedź #35 dnia: Kwiecień 29, 2019, 02:22:08 pm »
Może być, chociaż w MX i antiX robiłem już upgrade/instalacje i odinstalowanie/cofanie kernelów kilka razy na różnych komputerach i bez problemu zawsze wszystko gra i buczy. I niech tak zostanie ;)
Różnie to bywa (choć jakichś problemów nie doświadczam prawie wcale), stąd też dobra rada starego człowieka: zawsze dobrze mieć jest co najmniej dwa kernele, nawet jeśli oba działają sprawnie. Jeśli coś się wydarzy - np. po aktualizacji kernela (głównie) z jednym, to najczęściej system można uruchomić z drugiego i doprowadzić go do działania. Alternatywą jest dostęp do systemu przez chroot, ale ilu użytkowników tu obecnych tego próbowało, ilu w ogóle wie o co chodzi?
Przyczyny, dla których system może odmówić współpracy po aktualizacji kernela jest mnóstwo. Od jakichś regresji w kodzie, poprzez wadliwą kompilację, czy paczkowanie (już choćby z punktu widzenia konkretnego użytkownika), po jakiś błąd podczas aktualizacji. Stąd rozsądne minimum: dwa wspierane kernele (chyba, że EOLa nie dopuszczamy w ogóle do internetu).

Offline Fibogacci

  • Jr. Member
  • **
  • Wiadomości: 98
Odp: MX 17 do 18.2
« Odpowiedź #36 dnia: Kwiecień 29, 2019, 02:50:39 pm »
Może być, chociaż w MX i antiX robiłem już upgrade/instalacje i odinstalowanie/cofanie kernelów kilka razy na różnych komputerach i bez problemu zawsze wszystko gra i buczy. I niech tak zostanie ;)
Różnie to bywa (choć jakichś problemów nie doświadczam prawie wcale), stąd też dobra rada starego człowieka: zawsze dobrze mieć jest co najmniej dwa kernele, nawet jeśli oba działają sprawnie.

No ja miałem przez cały długi czas 3 wersje na głównym komputerze (u mnie zasady "BHP" są bardzo wyśrubowane generalnie w różnych dziedzinach, nie tylko komputerowych ;)), ale ostatnio odinstalowałem najstarszy, dla zwolnienia miejsca.

Dwa to minimum, chociaż to takie minimalne minimum (jak dla mnie).

Rada bardzo słuszna.

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 1338
Odp: MX 17 do 18.2
« Odpowiedź #37 dnia: Kwiecień 29, 2019, 03:04:12 pm »
To skoro jeszcze sobie tak "radzimy" - @stefan1980 używa 4.13, bowiem z jakiejś przyczyny 4.19 mu się długo uruchamia. Zgodnie z https://www.kernel.org linia 4.13 już dawno poszła spać. Używanie tej linii kerneli na jakimkolwiek komputerze, który ma dostęp do netu jest proszeniem się o kłopoty, a ogólnie - bez sensu. Wybór jest spory, bo upstream obecnie wspiera 6 linii. Spośród tych o zagwarantowanej długowieczności, to lepiej zainstalować 4.9 czy 4.14, ba nawet 4.4, skoro 4.19 nie pasuje.

Offline Fibogacci

  • Jr. Member
  • **
  • Wiadomości: 98
Odp: MX 17 do 18.2
« Odpowiedź #38 dnia: Kwiecień 29, 2019, 03:10:55 pm »
To skoro jeszcze sobie tak "radzimy" - @stefan1980 używa 4.13, bowiem z jakiejś przyczyny 4.19 mu się długo uruchamia. Zgodnie z https://www.kernel.org linia 4.13 już dawno poszła spać. Używanie tej linii kerneli na jakimkolwiek komputerze, który ma dostęp do netu jest proszeniem się o kłopoty, a ogólnie - bez sensu. Wybór jest spory, bo upstream obecnie wspiera 6 linii. Spośród tych o zagwarantowanej długowieczności, to lepiej zainstalować 4.9 czy 4.14, ba nawet 4.4, skoro 4.19 nie pasuje.

Dlatego może dobrą propozycją byłby antiXowy 4.9.170 albo 4.15 (też już spatchowany dla Meltdown i Spectre) - tylko ja teraz patrzę z 64 bitowej wersji - nie mam pod ręką 32 bitowej instalacji i nie wiem, co jest tam do wyboru. Może być mniejszy wybór.

Ale to musi sam Stefan popatrzeć ;)

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 1338
Odp: MX 17 do 18.2
« Odpowiedź #39 dnia: Kwiecień 29, 2019, 03:19:11 pm »
Tu nie chodzi o spatchowanie ma spectre i meltdown, bo te dwie dziury, to chyba głównie właścicieli serwerów interesują, a o wsparcie - 4.15 również EOL, ale - teoretycznie - nadal jest "wspierany" w Ubuntu. Jeśli się wierzy tego rodzaju wsparciu - można korzystać, czemu nie. Ja w tej materii jestem gorzej niż niewierny Tomasz :)

Offline Fibogacci

  • Jr. Member
  • **
  • Wiadomości: 98
Odp: MX 17 do 18.2
« Odpowiedź #40 dnia: Kwiecień 29, 2019, 03:24:26 pm »
Tu nie chodzi o spatchowanie ma spectre i meltdown, bo te dwie dziury, to chyba głównie właścicieli serwerów interesują, a o wsparcie - 4.15 również EOL, ale - teoretycznie - nadal jest "wspierany" w Ubuntu. Jeśli się wierzy tego rodzaju wsparciu - można korzystać, czemu nie. Ja w tej materii jestem gorzej niż niewierny Tomasz :)

Jak mówi prawo jakieś tam: Ufaj ludziom, ale tasuj karty

Offline TataPingu

  • Hero Member
  • *****
  • Wiadomości: 1319
Odp: MX 17 do 18.2
« Odpowiedź #41 dnia: Kwiecień 29, 2019, 03:47:45 pm »
a więc po aktualizacji kernela do wersji 4.19 laptop znów uruchamiał się 6 min.

A startowałeś system w trybie SysVinit, czy systemd ?

Offline stefan1980

  • Full Member
  • ***
  • Wiadomości: 136
Odp: MX 17 do 18.2
« Odpowiedź #42 dnia: Kwiecień 29, 2019, 08:01:26 pm »
Próbowałem obu czyli smp i systemd.Na obu muliło -wersja4.19. Na kernelu 4.14 to samo. Dopiero starsze wersje się uruchamiają. Mam teraz antixa 4.9. Są w grubie smp i systemd.Uruchamia się z smp bo jest ustawiony jako pierwszy. Nie wiem czy to ma znaczenie ale antixa mam zainstalowanego -NO Pae (mam 3 giga ramu).Pytanie czy usunąć wersję 4.13 i zaistalować dodatkowo antix 4.20?

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 1338
Odp: MX 17 do 18.2
« Odpowiedź #43 dnia: Kwiecień 29, 2019, 08:20:25 pm »
Jak Ci dobrze z 4.9, to siedź na nim i zapomnij o wszystkim ("dobrze" oznacza, że wszystko działa; kernel ma wsparcie upstreamu do stycznia 2023 r. - myślę, że wystarczy :)).
Inne - możesz sobie kombinować, a ten ustaw jako podstawowy.

Offline stefan1980

  • Full Member
  • ***
  • Wiadomości: 136
Odp: MX 17 do 18.2
« Odpowiedź #44 dnia: Kwiecień 29, 2019, 08:30:42 pm »
No dobra a 4.13 moge usunac z gruba i zainstalowac np 5.09 jak pisał fibo?
wynik z cli-aptix
Press <Enter> to select the highlighted entry                                                     
Use 'h' for help, 'r' to redraw, 'q' to wróć do menu głównego                                     
     1) linux-image-4.14.12-antix.1-686-smp-pae - Linux kernel, version 4.14.12-antix.1-686-smp-pae
     2) linux-image-4.14.12-gnu-antix.1-686-smp-pae - Linux kernel, version 4.14.12-gnu-antix.1-686-
     3) linux-image-4.14.14-antix.1-686-smp-pae - Linux kernel, version 4.14.14-antix.1-686-smp-pae
     4) linux-image-4.19.25-antix.1-486-smp - Linux kernel, version 4.19.25-antix.1-486-smp
     5) linux-image-4.19.25-antix.1-686-smp-pae - Linux kernel, version 4.19.25-antix.1-686-smp-pae
     6) linux-image-4.19.36-antix.1-486-smp - Linux kernel, version 4.19.36-antix.1-486-smp
     7) linux-image-4.19.36-antix.1-686-smp-pae - Linux kernel, version 4.19.36-antix.1-686-smp-pae
     8) linux-image-4.20.12-antix.1-486-smp - Linux kernel, version 4.20.12-antix.1-486-smp
     9) linux-image-4.20.12-antix.1-686-smp-pae - Linux kernel, version 4.20.12-antix.1-686-smp-pae
    10) linux-image-4.9.160-antix.1-486-smp - Linux kernel, version 4.9.160-antix.1-486-smp
    11) linux-image-4.9.160-antix.1-686-smp-pae - Linux kernel, version 4.9.160-antix.1-686-smp-pae
    12) (I) linux-image-4.9.160-antix.2-486-smp - Linux kernel, version 4.9.160-antix.2-486-smp
    13) linux-image-4.9.170-antix.1-486-smp - Linux kernel, version 4.9.170-antix.1-486-smp
    14) linux-image-4.9.170-antix.1-686-smp-pae - Linux kernel, version 4.9.170-antix.1-686-smp-pae
    15) linux-image-5.0.9-antix.1-486-smp - Linux kernel, version 5.0.9-antix.1-486-smp
    16) linux-image-5.0.9-antix.1-686-smp-pae - Linux kernel, version 5.0.9-antix.1-686-smp-pae