Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: [ROZWIĄZANY] MX długo się uruchamia  (Przeczytany 4473 razy)

Offline stefan1980

  • Full Member
  • ***
  • Wiadomości: 136
Odp: MX długo się uruchamia
« Odpowiedź #60 dnia: Marzec 20, 2019, 08:34:50 pm »
spróbuje ale nie wiem czy dam rade hehe

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 1335
Odp: MX długo się uruchamia
« Odpowiedź #61 dnia: Marzec 20, 2019, 08:37:43 pm »
Na pewno dasz. Poszukaj w podręczniku, który wcześniej podałem nt. synchronizacji czasu.

Offline stefan1980

  • Full Member
  • ***
  • Wiadomości: 136
Odp: MX długo się uruchamia
« Odpowiedź #62 dnia: Marzec 20, 2019, 08:41:07 pm »
znalazłem w necie coś takiego
https://expertlinux.eu/2016/03/23/jak-prosto-skonfigurowac-ntp/
https://mxlinux.org/wiki/system/time-settings/

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 1335
Odp: MX długo się uruchamia
« Odpowiedź #63 dnia: Marzec 20, 2019, 09:07:42 pm »
Na 99% to drugie.

Offline robson75

  • Hero Member
  • *****
  • Wiadomości: 1116
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: MX długo się uruchamia
« Odpowiedź #64 dnia: Marzec 20, 2019, 11:15:46 pm »
Do konfiguracji prawidłowego czasu najlepszy jest systemd-timesyncd.
Trzeba go tylko aktywować:
systemctl enable systemd-timesyncd.serviceoraz
systemctl start systemd-timesyncd.serviceOczywiście te polecenia na prawach root-a.
Następnie reboot systemu.

A jeżeli chodzi o zatrzymanie usługi NTP, to trzeba:
systemctl stop ntpd.serviceoraz
systemctl disable ntpd.service
« Ostatnia zmiana: Marzec 20, 2019, 11:43:01 pm wysłana przez robson75 »
Arch Linux Xfce+compiz - 64Bit Linux User #621110

Offline Fibogacci

  • Jr. Member
  • **
  • Wiadomości: 97
Odp: MX długo się uruchamia
« Odpowiedź #65 dnia: Marzec 21, 2019, 12:26:23 am »
Aby wyłączyć NTP w MX:

Krok 1.

Skrót Alt + F3 a następnie wpisz MX Ustawienia czasu (wystarczy wpisać 'czasu')

Lub alternatywnie wybierz: menu Start (Whisker) > Ustawienia > MX Ustawienia czasu

Krok 2.

Wybierz numer 5: Choose whether NTP is enabled, i w okienku wybierz: Disable

Tym narzędziem generalnie zarządzasz czasem i ustawieniami (jak sama nazwa wskazuje).

Printscreen:
https://i.ibb.co/YLBCm4N/ustawienia-czasu.png


Czy to wyłączy to łączenie z serwerem przy starcie, musisz sprawdzić w logach po kolejnym uruchomieniu.

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 1335
Odp: MX długo się uruchamia
« Odpowiedź #66 dnia: Marzec 21, 2019, 12:48:16 am »
@robson75 - W MX domyślnie systemd nie działa.

Offline stefan1980

  • Full Member
  • ***
  • Wiadomości: 136
Odp: MX długo się uruchamia
« Odpowiedź #67 dnia: Marzec 21, 2019, 09:19:51 am »
Wczoraj przerobiłem to z tej strony
https://mxlinux.org/wiki/system/time-settings/jednak nic to nie zmieniło. Tam było wszystko w porządku tzn czas był dobrze ustawiony. Dziś spróbuję to co mi napisaliście i sprawdzę w logach syslog.

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 1335
Odp: MX długo się uruchamia
« Odpowiedź #68 dnia: Marzec 21, 2019, 09:52:13 am »
Wyłącz w ogóle ntp (masz pokazane wyżej przez @Fibogacci; prawdopodobnie jest to prawidłowe rozwiązanie) i wówczas sprawdź.
NTP nie jest Ci do szczęścia potrzebne, a niekiedy samo połączenie się z serwerem powoduje problemy. Na 99% tak jest w Twoim przypadku.
(NTP odpowiada za "sieciową synchronizację czasu")
« Ostatnia zmiana: Marzec 21, 2019, 10:52:44 am wysłana przez pavbaranov »

Offline stefan1980

  • Full Member
  • ***
  • Wiadomości: 136
Odp: MX długo się uruchamia
« Odpowiedź #69 dnia: Marzec 21, 2019, 06:58:53 pm »
wynik z syslog.1
Mar 20 19:08:51 stefan1980 kernel: [    0.060498] ACPI: IRQ0 used by override.
Mar 20 19:08:51 stefan1980 kernel: [    0.060500] ACPI: IRQ9 used by override.
Mar 20 19:08:51 stefan1980 kernel: [    0.403540] core: PEBS disabled due to CPU errata
Mar 20 19:08:51 stefan1980 kernel: [    0.423802] ACPI: EC: interrupt blocked
Mar 20 19:08:51 stefan1980 kernel: [    0.547659] ACPI: Using IOAPIC for interrupt routing
Mar 20 19:08:51 stefan1980 kernel: [    0.564707] ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 *5 7 9 10 11 12)
Mar 20 19:08:51 stefan1980 kernel: [    0.564805] ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 7 9 10 *11 12)
Mar 20 19:08:51 stefan1980 kernel: [    0.564895] ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 7 9 10 *11 12)
Mar 20 19:08:51 stefan1980 kernel: [    0.564985] ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 7 9 10 *11 12)
Mar 20 19:08:51 stefan1980 kernel: [    0.565074] ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 7 9 10 11 12) *0, disabled.
Mar 20 19:08:51 stefan1980 kernel: [    0.565164] ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 5 7 9 *10 11 12)
Mar 20 19:08:51 stefan1980 kernel: [    0.565253] ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 5 7 9 10 *11 12)
Mar 20 19:08:51 stefan1980 kernel: [    0.565342] ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 5 7 9 10 11 12) *0, disabled.
Mar 20 19:08:51 stefan1980 kernel: [    0.566054] ACPI: EC: interrupt unblocked
Mar 20 19:08:51 stefan1980 kernel: [    2.720763] i801_smbus 0000:00:1f.3: SMBus using PCI interrupt
Mar 20 19:09:29 stefan1980 ntpd[2731]: error resolving pool 0.debian.pool.ntp.org: Name or service not known (-2)
Mar 20 19:09:30 stefan1980 ntpd[2731]: error resolving pool 1.debian.pool.ntp.org: Name or service not known (-2)
Mar 20 19:09:31 stefan1980 ntpd[2731]: error resolving pool 2.debian.pool.ntp.org: Name or service not known (-2)
Mar 20 19:09:32 stefan1980 ntpd[2731]: error resolving pool 3.debian.pool.ntp.org: Name or service not known (-2)
Mar 20 19:10:33 stefan1980 ntpd[2731]: error resolving pool 0.debian.pool.ntp.org: Name or service not known (-2)
Mar 20 19:10:35 stefan1980 ntpd[2731]: error resolving pool 1.debian.pool.ntp.org: Name or service not known (-2)
Mar 20 19:10:37 stefan1980 ntpd[2731]: error resolving pool 2.debian.pool.ntp.org: Name or service not known (-2)
Mar 20 19:10:39 stefan1980 ntpd[2731]: error resolving pool 3.debian.pool.ntp.org: Name or service not known (-2)
Mar 20 19:33:37 stefan1980 ntpd[2731]: error resolving pool 3.debian.pool.ntp.org: Name or service not known (-2)
Mar 20 19:33:39 stefan1980 ntpd[2731]: error resolving pool 1.debian.pool.ntp.org: Name or service not known (-2)
Mar 20 19:33:43 stefan1980 ntpd[2731]: error resolving pool 0.debian.pool.ntp.org: Name or service not known (-2)
Mar 20 19:39:52 stefan1980 ntpd[2731]: error resolving pool 1.debian.pool.ntp.org: Name or service not known (-2)
Mar 20 19:40:22 stefan1980 ntpd[2731]: error resolving pool 1.debian.pool.ntp.org: Name or service not known (-2)
Wynika z tego tak mi się wydaje że do wczoraj ntp działało bo dziś je wyłączyłem i nie ma nic z dzisiejszą datą. Jeszcze mam taki wynik loga ntp.conf
# /etc/ntp.conf, configuration for ntpd; see ntp.conf(5) for help

driftfile /var/lib/ntp/ntp.drift

# Enable this if you want statistics to be logged.
#statsdir /var/log/ntpstats/

statistics loopstats peerstats clockstats
filegen loopstats file loopstats type day enable
filegen peerstats file peerstats type day enable
filegen clockstats file clockstats type day enable


# You do need to talk to an NTP server or two (or three).
#server ntp.your-provider.example

# pool.ntp.org maps to about 1000 low-stratum NTP servers.  Your server will
# pick a different set every time it starts up.  Please consider joining the
# pool: <http://www.pool.ntp.org/join.html>
server 0.pl.pool.ntp.org iburst
server 1.pl.pool.ntp.org iburst
server 2.pl.pool.ntp.org iburst
server 3.pl.pool.ntp.org iburst


# Access control configuration; see /usr/share/doc/ntp-doc/html/accopt.html for
# details.  The web page <http://support.ntp.org/bin/view/Support/AccessRestrictions>
# might also be helpful.
#
# Note that "restrict" applies to both servers and clients, so a configuration
# that might be intended to block requests from certain clients could also end
# up blocking replies from your own upstream servers.

# By default, exchange time with everybody, but don't allow configuration.
restrict -4 default kod notrap nomodify nopeer noquery limited
restrict -6 default kod notrap nomodify nopeer noquery limited

# Local users may interrogate the ntp server more closely.
restrict 127.0.0.1
restrict ::1
server 127.127.1.0
fudge 127.127.1.0 stratum 10

# Needed for adding pool entries
restrict source notrap nomodify noquery

# Clients from this (example!) subnet have unlimited access, but only if
# cryptographically authenticated.
#restrict 192.168.123.0 mask 255.255.255.0 notrust


# If you want to provide time to your local subnet, change the next line.
# (Again, the address is an example only.)
#broadcast 192.168.123.255

# If you want to listen to time broadcasts on your local subnet, de-comment the
# next lines.  Please do this only if you trust everybody on the network!
#disable auth
#broadcastclient
Czy tu jeszcze trzeba coś ustawiać/wyłaczyć?
Jednak system jak startował dugo tak startuje. Oprócz ACPI ERROR pojawia mi się jeszcze coś takiego podczas startu
drm:drm atomic helper wait for flip done -drm kms helper error CRTC41 pipe B1
drm:drm atomic helper wait for dependiences error connector:50 S VIDEO-1 flip done time out
Tak myśle czy nie zainstalować MX17 i zaktualizować go do 18.1
« Ostatnia zmiana: Marzec 21, 2019, 07:16:42 pm wysłana przez stefan1980 »

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 1335
Odp: MX długo się uruchamia
« Odpowiedź #70 dnia: Marzec 21, 2019, 07:17:34 pm »
Zerknij na:
(...)
Mar 20 19:08:51 stefan1980 kernel: [    0.566054] ACPI: EC: interrupt unblocked
Mar 20 19:08:51 stefan1980 kernel: [    2.720763] i801_smbus 0000:00:1f.3: SMBus using PCI interrupt
Mar 20 19:09:29 stefan1980 ntpd[2731]: error resolving pool 0.debian.pool.ntp.org: Name or service not known (-2)
(...)
I tu masz pierwsze 40 sek opóźnienie. Potem też łapie zadyszkę i wszystko jest związane z ntp, albowiem system nie potrafi się dogadać z debian.pool.ntp.org. Po prostu tego nie zna (nie znajduje nazwy lub nie wie co z nią ma zrobić).
# /etc/ntp.conf, configuration for ntpd; see ntp.conf(5) for help
(...)
# pool.ntp.org maps to about 1000 low-stratum NTP servers.  Your server will
# pick a different set every time it starts up.  Please consider joining the
# pool: <http://www.pool.ntp.org/join.html>
server 0.pl.pool.ntp.org iburst
server 1.pl.pool.ntp.org iburst
server 2.pl.pool.ntp.org iburst
server 3.pl.pool.ntp.org iburst
Czy tu jeszcze trzeba coś ustawiać/wyłaczyć?
Jakoś nie wygląda mi na to, abyś ntp wyłączył. Nadto w cytowanym fragmencie masz dokładnie to co boli MX.
Pewnie gdzieś jest opis dla MX (lub Debiana), ale mi się nie chce szukać. Opis NTP masz m.in. tu: https://wiki.archlinux.org/index.php/Network_Time_Protocol_daemon
Przy okazji - nie możesz tego odinstalować w cholerę?

Offline stefan1980

  • Full Member
  • ***
  • Wiadomości: 136
Odp: MX długo się uruchamia
« Odpowiedź #71 dnia: Marzec 21, 2019, 07:24:56 pm »
Dlatego też wczoraj zmieniłem server z debian.pool na pl.pool ale i z tym widzę sobie nie radzi.

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 1335
Odp: MX długo się uruchamia
« Odpowiedź #72 dnia: Marzec 21, 2019, 07:28:15 pm »
Wyłącz w ogóle NTP!!!
Do tego czasu odmawiam współpracy w tym wątku :) W żaden bowiem sposób nie będziemy w stanie ocenić, czy w istocie ów NTP jest powodem długiego uruchamiania się MX. I możemy tak jeszcze bardzo długo bić pianę, ale szkoda czasu.

Offline Fibogacci

  • Jr. Member
  • **
  • Wiadomości: 97
Odp: MX długo się uruchamia
« Odpowiedź #73 dnia: Marzec 21, 2019, 07:33:49 pm »
Zrób tak, zainstaluj MX 17, zaktualizuj do MX 18 (poprzez aktualizacje), kernel jak chcesz możesz dać nowy (najnowszy, ten co w 18) (trzeba zamienić na nowszy ręcznie, to w automatycznej aktualizacji specjalnie nie jest możliwe), albo zostawić domyślny dla wersji 17.

Będziesz miał system w wersji 18 (programy, narzędzie, reszta) i pewnie będzie działał normalnie (skoro piszesz, że 17 działa).

W Linuksie z moich doświadczeń jest tak, że ten sam efekt i rezultaty często można osiągnąć wieloma drogami, ale nie ma sensu upierać się specjalnie przy danym konkretnym sposobie, jeśli inny zadziała (ale jak ktoś lubi lub stanowi to wyzwanie, to oczywiście można próbować rozwiązać problem wybranym sposobem - dla satysfakcji/nauki/wpisać co kto chce).

Powodzenia.
« Ostatnia zmiana: Marzec 21, 2019, 07:35:51 pm wysłana przez Fibogacci »

Offline stefan1980

  • Full Member
  • ***
  • Wiadomości: 136
Odp: MX długo się uruchamia
« Odpowiedź #74 dnia: Marzec 22, 2019, 09:57:28 am »
Więc zainstalowałem MX17 wszystko działa i szybko się uruchamia jak i zamyka. Zaktualizowałem i zostawiam na razie tą dystrybucję. Pewnie będę miał jeszcze pytania. Dzięki wszystkim za pomoc w szczególności Pavbaranovi że wytrzymał, bo się już chyba na koniec dobrze zagrzał:)