Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: Szyfrowanie dysku, VeraCrypt  (Przeczytany 5058 razy)

Offline mark

  • Jr. Member
  • **
  • Wiadomości: 61
Odp: Szyfrowanie dysku, VeraCrypt
« Odpowiedź #60 dnia: Styczeń 17, 2019, 11:11:03 am »
Powiem Wam, że bawię się w wirtualnej maszynie różnymi dystrybucjami i ich instalacjami.

Z tego co widzę, to np. Feodra i openSUSE mają bardzo mocno konfigurowalne instalatory i można dowolne partycjonować i szyfrować, czego nie można zrobić w Ubuntu-pochodnych, bo ichniejszy instalator jest mocno ograniczony.

Offline mark

  • Jr. Member
  • **
  • Wiadomości: 61
Odp: Szyfrowanie dysku, VeraCrypt
« Odpowiedź #61 dnia: Styczeń 18, 2019, 04:47:17 pm »
Co robię źle?

Otóż, próbując zainstalować coś opartego na instalatorze Ubiquity, przed samym rozpoczęciem instalacji trafiam na ścianę. Po kolei co robię:

1. Odpalam Minta/Ubuntu z USB i wybieram instalację.
2. Wybieram ręczne partycjonowanie.
3. Tworzę nową tablicę partycji MBR.
4. Tworzę sda1 o wielkości 512mb, ext2 i punkt montowanie /boot - nieszyfrowane, partycja podstawowa.
5. Tworzę sda2 o wielkości 25GB i wybieram opcję "fizyczny wolumin do szyfrowania", wpisuję hasło X. Partycja podstawowa.
6. Tworzę sda3 o wielkości 2GB i wybieram opcję "fizyczny wolumin do szyfrowania", wpisuję hasło Y. Partycja podstawowa.
7. Tworzę sda4 o wielkości ....GB i wybieram opcję "fizyczny wolumin do szyfrowania", wpisuję hasło Z. Partycja podstawowa.
8. Ustawiam odpowiednie punkty montowania (/dev/mapper/sdaX_crypt):
- /
- swap
- /home.
Dla roota i home system ext4, dla swap przestrzeń wymiany.
9. Urządzenie dla instalacji rozruchu dev/sda.
10. Klikam instaluj.

W tym momencie dostaję komunikat: "Próba zamontowania systemu plików ext4 na Szyfrowany wolumin (sda5_crypt) w / nie powiodła się". Możesz kontynuować partycjonowanie z menu partycjonowania."

Co robię źle?
Praktycznie w 99,9% odtwarzam tutorial znaleziony pod adresem:
http://linuxbsdos.com/2014/01/16/manual-full-disk-encryption-setup-guide-for-ubuntu-13-10-linux-mint-16/

Wygląda na to, że tam zadziałało.

Uwagi:
- problem występuje mi w VB jak i podczas prawdziwej instalacji,
- tak, zdaję sobie sprawę że jeśli by mi się powiodło to będę 3 razy wprowadzać hasło przy rozruchu,
- próbowałem te fizyczne nośniki do szyfrowania ustawiać jako partycje podstawowe, próbowałem też jako logiczne. Zawsze ten sam komunikat o treści jw. wyskakuje.

ps. dlaczego np. Fedora bez problemu pozwoliła mi na taką operację podczas instalacji a z Ubuntu-pochodnymi jest problem? W sensie - Fedora bez problemu pozwoliła mi zrobić 4 osobne partycje (boot, /, swap, home) i przy odpalaniu 3 razy prosi mnie o hasło i wszystko śmiga aż miło.

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 1252
Odp: Szyfrowanie dysku, VeraCrypt
« Odpowiedź #62 dnia: Styczeń 18, 2019, 06:12:45 pm »
Jedno krótkie pytanie: UEFI?
Reszty nie chce mi się czytać, a pytanie dotyczy FS na /boot

Offline mark

  • Jr. Member
  • **
  • Wiadomości: 61
Odp: Szyfrowanie dysku, VeraCrypt
« Odpowiedź #63 dnia: Styczeń 19, 2019, 09:26:15 am »
Jedno krótkie pytanie: UEFI?
Reszty nie chce mi się czytać, a pytanie dotyczy FS na /boot

Tzn? Przyznam szczerze, że nie rozumiem Twojego posta i tego co miałeś na myśli.

Co do UEFI - ustawiłem wszystko na tryb Legacy, robię tablice MBR itd.

Ok mniejsza z tym, poradziłem sobie z tematem w ten sposób, że najpierw odpalam instalację, dzielę dysk na niezaszyfrowane /boot oraz na 3 fizyczne nośniki do szyfrowania, ustawiam hasła i więcej nic. Wyłączam program instalacyjny.
Następnie wchodzę do GParted i ręcznie formatuje ww. partycje do ext2 (boot) i ext4 (/ oraz /home), a swap jako swap.
Dalej znowu uruchamiam instalatora i wskazuję punkty montowania itd. Dalej instalacja idzie normalnie, nie wyskakują żadne komunikaty czy błędy, czyli problem zażegnany  ;D

Ale utknąłem znowu w innym miejscu. Po zakończonej instalacji system bootuje jedynie do pewnego momentu. Uruchamia się GRUB, wybieram Ubuntu po czym system nie pyta mnie w ogóle o hasła i zatrzymuje się na etapie initramfs. Czyli domyślam się, że system nie widzi (nie umie znaleźć) roota i skąd ma go odpalić. Pytanie tylko czy chodzi o jakiś prosty błąd, czy też nie ma szans go odpalić bo jest przecież zaszyfrowany i brakuje mi jakichś poleceń które kazałyby pytać o hasło. Nie wiem jak to rozumieć.

Po wpisaniu 'exit' w initramf wypluwa mniej więcej:
gave up waiting for root file system device
check rootdelay
missing modules (cat /proc/modules; ls/dev/)
ALERT! UUID= ................................ does not exist. Dropping to a shell


Szukam w necie jak to obejść, co z tym zrobić. Na razie bez skutku.
« Ostatnia zmiana: Styczeń 19, 2019, 09:34:02 am wysłana przez mark »