Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: laptop się nie wyłącza  (Przeczytany 6563 razy)

Offline mbbartek

  • Jr. Member
  • **
  • Wiadomości: 52
laptop się nie wyłącza
« dnia: Listopad 20, 2018, 10:57:03 pm »
po kliknięciu w wyłącz, system zaczyna się zamykać i w pewnym momencie się zatrzymuje i dopiero jak wcisnę nawet na krótko przycisk zasilania gaśnie.
troszkę pogrzebałem i w grubie mam taki wpis:

GRUB_CMDLINE_LINUX_DEFAULT="apm=off acpi=off mce=off barrier=off ide=nodma idewait=50 i8042.nomux psmouse.proto=bare irqpoll pci=nommconf resume=/dev/disk/by-id/ata-WDC_WD5000BEVT-22A0RT0_WD-WXA1C20K5233-part6 splash=silent quiet showopts apm=off acpi=off mce=off barrier=off ide=nodma idewait=50 i8042.nomux psmouse.proto=bare irqpoll pci=nommconf resume=/dev/disk/by-id/ata-WDC_WD5000BEVT-22A0RT0_WD-WXA1C20K5233-part6 splash=silent quiet showopts"
GRUB_CMDLINE_LINUX=""


czy powinienem zmienić wpisy przy acpi?? np na force?? lub jakoś inaczej??

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 1330
Odp: laptop się nie wyłącza
« Odpowiedź #1 dnia: Listopad 21, 2018, 12:33:12 am »
Nie powinieneś dać wynik journalctl z ostatniego bootowania (w zasadzie wyłączania) przed tym, z którego je wywołujesz. Wówczas - być może - będziemy wiedzieć dlaczego nie wyłącza się.
Nadto: nie wyłącza się, czy długo to trwa?
Jak na razie - przy następnym bootowaniu usuń z GRUBa:
splash=silent quiettylko to i niech startuje dalej - przy okazji dowiesz się też co się pokazuje na końcu, przy próbie wyłączenia.

Offline mbbartek

  • Jr. Member
  • **
  • Wiadomości: 52
Odp: laptop się nie wyłącza
« Odpowiedź #2 dnia: Listopad 21, 2018, 08:45:53 pm »
journalctl
-- Logs begin at Wed 2018-11-21 18:16:08 CET, end at Wed 2018-11-21 20:41:59 CET. --
lis 21 18:16:08 linux-zbeu kernel: microcode: microcode updated early to revision 0x7, date = 2018-04-23
lis 21 18:16:08 linux-zbeu kernel: Linux version 4.12.14-lp150.12.25-default (geeko@buildhost) (gcc version 7.3.1 20180323 [>
lis 21 18:16:08 linux-zbeu kernel: Command line: BOOT_IMAGE=/boot/vmlinuz-4.12.14-lp150.12.25-default root=UUID=c0960a2c-6f7>
lis 21 18:16:08 linux-zbeu kernel: x86/fpu: x87 FPU will use FXSAVE
lis 21 18:16:08 linux-zbeu kernel: e820: BIOS-provided physical RAM map:
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x0000000000000000-0x000000000009cfff] usable
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x000000000009d000-0x000000000009ffff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000000e0000-0x00000000000fffff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x0000000000100000-0x00000000b3674fff] usable
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b3675000-0x00000000b36befff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b36bf000-0x00000000b373afff] usable
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b373b000-0x00000000b37befff] ACPI NVS
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b37bf000-0x00000000b37e0fff] usable
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b37e1000-0x00000000b37fefff] ACPI data
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b37ff000-0x00000000b37fffff] usable
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b3800000-0x00000000bfffffff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000f0000000-0x00000000f7ffffff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000feb00000-0x00000000feb03fff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000fec00000-0x00000000fec00fff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000fed10000-0x00000000fed13fff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000fed18000-0x00000000fed19fff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000fed1b000-0x00000000fed1ffff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000fee00000-0x00000000fee00fff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000ffe00000-0x00000000ffffffff] reserved
lines 1-25...skipping...
-- Logs begin at Wed 2018-11-21 18:16:08 CET, end at Wed 2018-11-21 20:41:59 CET. --                                                                                                           
lis 21 18:16:08 linux-zbeu kernel: microcode: microcode updated early to revision 0x7, date = 2018-04-23                                                                                       
lis 21 18:16:08 linux-zbeu kernel: Linux version 4.12.14-lp150.12.25-default (geeko@buildhost) (gcc version 7.3.1 20180323 [gcc-7-branch revision 258812] (SUSE Linux) ) #1 SMP Thu Nov 1 06:14>
lis 21 18:16:08 linux-zbeu kernel: Command line: BOOT_IMAGE=/boot/vmlinuz-4.12.14-lp150.12.25-default root=UUID=c0960a2c-6f7c-4704-b9a9-a4860de6f729 apm=off acpi=off mce=off barrier=off ide=n>
lis 21 18:16:08 linux-zbeu kernel: x86/fpu: x87 FPU will use FXSAVE                                                                                                                             
lis 21 18:16:08 linux-zbeu kernel: e820: BIOS-provided physical RAM map:                                                                                                                       
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x0000000000000000-0x000000000009cfff] usable                                                                                               
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x000000000009d000-0x000000000009ffff] reserved                                                                                             
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000000e0000-0x00000000000fffff] reserved                                                                                             
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x0000000000100000-0x00000000b3674fff] usable                                                                                               
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b3675000-0x00000000b36befff] reserved                                                                                             
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b36bf000-0x00000000b373afff] usable                                                                                               
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b373b000-0x00000000b37befff] ACPI NVS                                                                                             
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b37bf000-0x00000000b37e0fff] usable                                                                                               
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b37e1000-0x00000000b37fefff] ACPI data                                                                                             
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b37ff000-0x00000000b37fffff] usable                                                                                               
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b3800000-0x00000000bfffffff] reserved                                                                                             
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000f0000000-0x00000000f7ffffff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000feb00000-0x00000000feb03fff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000fec00000-0x00000000fec00fff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000fed10000-0x00000000fed13fff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000fed18000-0x00000000fed19fff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000fed1b000-0x00000000fed1ffff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000fee00000-0x00000000fee00fff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000ffe00000-0x00000000ffffffff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x0000000100000000-0x0000000137ffffff] usable
lis 21 18:16:08 linux-zbeu kernel: NX (Execute Disable) protection: active
lis 21 18:16:08 linux-zbeu kernel: SMBIOS 2.6 present.
lis 21 18:16:08 linux-zbeu kernel: DMI: Acer Aspire 5820TG/ZR7B, BIOS V1.13 05/14/2010
lis 21 18:16:08 linux-zbeu kernel: tsc: Fast TSC calibration using PIT
lis 21 18:16:08 linux-zbeu kernel: e820: update [mem 0x00000000-0x00000fff] usable ==> reserved
lis 21 18:16:08 linux-zbeu kernel: e820: remove [mem 0x000a0000-0x000fffff] usable
lis 21 18:16:08 linux-zbeu kernel: e820: last_pfn = 0x138000 max_arch_pfn = 0x400000000
lis 21 18:16:08 linux-zbeu kernel: MTRR default type: uncachable
lis 21 18:16:08 linux-zbeu kernel: MTRR fixed ranges enabled:
lis 21 18:16:08 linux-zbeu kernel:   00000-9FFFF write-back
lis 21 18:16:08 linux-zbeu kernel:   A0000-BFFFF uncachable
lis 21 18:16:08 linux-zbeu kernel:   C0000-EFFFF write-through
lis 21 18:16:08 linux-zbeu kernel:   F0000-FFFFF write-combining
lis 21 18:16:08 linux-zbeu kernel: MTRR variable ranges enabled:
lis 21 18:16:08 linux-zbeu kernel:   0 base 000000000 mask F80000000 write-back
lis 21 18:16:08 linux-zbeu kernel:   1 base 0FFE00000 mask FFFE00000 write-protect
« Ostatnia zmiana: Listopad 21, 2018, 09:31:39 pm wysłana przez lami07 »

Offline mbbartek

  • Jr. Member
  • **
  • Wiadomości: 52
Odp: laptop się nie wyłącza
« Odpowiedź #3 dnia: Listopad 21, 2018, 08:47:29 pm »
Logs begin at Wed 2018-11-21 18:16:08 CET, end at Wed 2018-11-21 20:41:59 CET. --
lis 21 18:16:08 linux-zbeu kernel: microcode: microcode updated early to revision 0x7, date = 2018-04-23
lis 21 18:16:08 linux-zbeu kernel: Linux version 4.12.14-lp150.12.25-default (geeko@buildhost) (gcc version 7.3.1 20180323 [>
lis 21 18:16:08 linux-zbeu kernel: Command line: BOOT_IMAGE=/boot/vmlinuz-4.12.14-lp150.12.25-default root=UUID=c0960a2c-6f7>
lis 21 18:16:08 linux-zbeu kernel: x86/fpu: x87 FPU will use FXSAVE
lis 21 18:16:08 linux-zbeu kernel: e820: BIOS-provided physical RAM map:
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x0000000000000000-0x000000000009cfff] usable
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x000000000009d000-0x000000000009ffff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000000e0000-0x00000000000fffff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x0000000000100000-0x00000000b3674fff] usable
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b3675000-0x00000000b36befff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b36bf000-0x00000000b373afff] usable
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b373b000-0x00000000b37befff] ACPI NVS
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b37bf000-0x00000000b37e0fff] usable
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b37e1000-0x00000000b37fefff] ACPI data
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b37ff000-0x00000000b37fffff] usable
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b3800000-0x00000000bfffffff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000f0000000-0x00000000f7ffffff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000feb00000-0x00000000feb03fff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000fec00000-0x00000000fec00fff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000fed10000-0x00000000fed13fff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000fed18000-0x00000000fed19fff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000fed1b000-0x00000000fed1ffff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000fee00000-0x00000000fee00fff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000ffe00000-0x00000000ffffffff] reserved

-- Logs begin at Wed 2018-11-21 18:16:08 CET, end at Wed 2018-11-21 20:41:59 CET. --
lis 21 18:16:08 linux-zbeu kernel: microcode: microcode updated early to revision 0x7, date = 2018-04-23
lis 21 18:16:08 linux-zbeu kernel: Linux version 4.12.14-lp150.12.25-default (geeko@buildhost) (gcc version 7.3.1 20180323 [gcc-7-branch revision 258812] (SUSE Linux) ) #1 SMP Thu Nov 1 06:14>
lis 21 18:16:08 linux-zbeu kernel: Command line: BOOT_IMAGE=/boot/vmlinuz-4.12.14-lp150.12.25-default root=UUID=c0960a2c-6f7c-4704-b9a9-a4860de6f729 apm=off acpi=off mce=off barrier=off ide=n>
lis 21 18:16:08 linux-zbeu kernel: x86/fpu: x87 FPU will use FXSAVE
lis 21 18:16:08 linux-zbeu kernel: e820: BIOS-provided physical RAM map:
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x0000000000000000-0x000000000009cfff] usable
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x000000000009d000-0x000000000009ffff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000000e0000-0x00000000000fffff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x0000000000100000-0x00000000b3674fff] usable
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b3675000-0x00000000b36befff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b36bf000-0x00000000b373afff] usable
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b373b000-0x00000000b37befff] ACPI NVS
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b37bf000-0x00000000b37e0fff] usable
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b37e1000-0x00000000b37fefff] ACPI data
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b37ff000-0x00000000b37fffff] usable
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b3800000-0x00000000bfffffff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000f0000000-0x00000000f7ffffff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000feb00000-0x00000000feb03fff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000fec00000-0x00000000fec00fff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000fed10000-0x00000000fed13fff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000fed18000-0x00000000fed19fff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000fed1b000-0x00000000fed1ffff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000fee00000-0x00000000fee00fff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000ffe00000-0x00000000ffffffff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x0000000100000000-0x0000000137ffffff] usable
lis 21 18:16:08 linux-zbeu kernel: NX (Execute Disable) protection: active
lis 21 18:16:08 linux-zbeu kernel: SMBIOS 2.6 present.
lis 21 18:16:08 linux-zbeu kernel: DMI: Acer Aspire 5820TG/ZR7B, BIOS V1.13 05/14/2010
lis 21 18:16:08 linux-zbeu kernel: tsc: Fast TSC calibration using PIT
lis 21 18:16:08 linux-zbeu kernel: e820: update [mem 0x00000000-0x00000fff] usable ==> reserved
lis 21 18:16:08 linux-zbeu kernel: e820: remove [mem 0x000a0000-0x000fffff] usable
lis 21 18:16:08 linux-zbeu kernel: e820: last_pfn = 0x138000 max_arch_pfn = 0x400000000
lis 21 18:16:08 linux-zbeu kernel: MTRR default type: uncachable
lis 21 18:16:08 linux-zbeu kernel: MTRR fixed ranges enabled:
lis 21 18:16:08 linux-zbeu kernel:   00000-9FFFF write-back
lis 21 18:16:08 linux-zbeu kernel:   A0000-BFFFF uncachable
lis 21 18:16:08 linux-zbeu kernel:   C0000-EFFFF write-through
lis 21 18:16:08 linux-zbeu kernel:   F0000-FFFFF write-combining
lis 21 18:16:08 linux-zbeu kernel: MTRR variable ranges enabled:
lis 21 18:16:08 linux-zbeu kernel:   0 base 000000000 mask F80000000 write-back
lis 21 18:16:08 linux-zbeu kernel:   1 base 0FFE00000 mask FFFE00000 write-protect

-- Logs begin at Wed 2018-11-21 18:16:08 CET, end at Wed 2018-11-21 20:41:59 CET. --
lis 21 18:16:08 linux-zbeu kernel: microcode: microcode updated early to revision 0x7, date = 2018-04-23
lis 21 18:16:08 linux-zbeu kernel: Linux version 4.12.14-lp150.12.25-default (geeko@buildhost) (gcc version 7.3.1 20180323 [>
lis 21 18:16:08 linux-zbeu kernel: Command line: BOOT_IMAGE=/boot/vmlinuz-4.12.14-lp150.12.25-default root=UUID=c0960a2c-6f7>
lis 21 18:16:08 linux-zbeu kernel: x86/fpu: x87 FPU will use FXSAVE
lis 21 18:16:08 linux-zbeu kernel: e820: BIOS-provided physical RAM map:
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x0000000000000000-0x000000000009cfff] usable
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x000000000009d000-0x000000000009ffff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000000e0000-0x00000000000fffff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x0000000000100000-0x00000000b3674fff] usable
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b3675000-0x00000000b36befff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b36bf000-0x00000000b373afff] usable
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b373b000-0x00000000b37befff] ACPI NVS
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b37bf000-0x00000000b37e0fff] usable
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b37e1000-0x00000000b37fefff] ACPI data
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b37ff000-0x00000000b37fffff] usable
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000b3800000-0x00000000bfffffff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000f0000000-0x00000000f7ffffff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000feb00000-0x00000000feb03fff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000fec00000-0x00000000fec00fff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000fed10000-0x00000000fed13fff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000fed18000-0x00000000fed19fff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000fed1b000-0x00000000fed1ffff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000fee00000-0x00000000fee00fff] reserved
lis 21 18:16:08 linux-zbeu kernel: BIOS-e820: [mem 0x00000000ffe00000-0x00000000ffffffff] reserved
lines 1-25
« Ostatnia zmiana: Listopad 21, 2018, 09:32:14 pm wysłana przez lami07 »

Offline mbbartek

  • Jr. Member
  • **
  • Wiadomości: 52
Odp: laptop się nie wyłącza
« Odpowiedź #4 dnia: Listopad 21, 2018, 08:55:08 pm »
Nie powinieneś dać wynik journalctl z ostatniego bootowania (w zasadzie wyłączania) przed tym, z którego je wywołujesz. Wówczas - być może - będziemy wiedzieć dlaczego nie wyłącza się.
Nadto: nie wyłącza się, czy długo to trwa?
hmm, jak dać ten wynik z wyłączania?? to wyrzej wkleiłem z już odpalonego systemu z konsoli.
wyłączanie trwa w miarę przyzwoicie i w pewnym momencie wszystko w zasadzie przestaje pracować i czeka na wciśnięcie przycisku zailania.
Cytuj
Jak na razie - przy następnym bootowaniu usuń z GRUBa:
splash=silent quiettylko to i niech startuje dalej - przy okazji dowiesz się też co się pokazuje na końcu, przy próbie wyłączenia.
wszedłem w plik gruba i mam taki wpis:
GRUB_CMDLINE_LINUX_DEFAULT="apm=off acpi=off mce=off barrier=off ide=nodma idewait=50 i8042.nomux psmouse.proto=bare irqpoll pci=nommconf resume=/dev/disk/by-id/ata-WDC_WD5000BEVT-22A0RT0_WD-WXA1C20K5233-part6 splash=silent quiet showopts apm=off acpi=off mce=off barrier=off ide=nodma idewait=50 i8042.nomux psmouse.proto=bare irqpoll pci=nommconf resume=/dev/disk/by-id/ata-WDC_WD5000BEVT-22A0RT0_WD-WXA1C20K5233-part6 splash=silent quiet showopts"
GRUB_CMDLINE_LINUX=""

chyba, że nie o to zupełnie chodzi?? zrobiłem to na odpalonym juz systemie.

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 1330
Odp: laptop się nie wyłącza
« Odpowiedź #5 dnia: Listopad 21, 2018, 09:27:05 pm »
Nie wiem, jak Ci się ten GRUB włącza, ale jeśli nie masz jego menu to shift lub esc powinien Ci otworzyć menu GRUB. Wówczas na dole "tabelki" masz możliwość edycji polecenia (właśnie tego GRUB_CMDLINE_LINUX_DEFAULT i tu musisz po prostu wykasować splash=silent quiet i uruchomić system. Wówczas nic Ci nie będzie przesłaniać komend zarówno podczas uruchamiania, jak i podczas wyłączania komend, które kernel/systemd/itd. przekazują.

To co podałeś to są wyniki z logowania. Przedostatnia (czyli ta, którą zamykałeś) sesja zapisana przez journal to:
journalctl -b1Ostatnie linijki, to są te, które nas najbardziej będą interesować.

Offline mbbartek

  • Jr. Member
  • **
  • Wiadomości: 52
Odp: laptop się nie wyłącza
« Odpowiedź #6 dnia: Listopad 21, 2018, 09:58:35 pm »
a jak wykasuję te lini komendy, to pożniej moge jej jakoś przywrócić??


journalctl -b1
Specifying boot ID or boot offset has no effect, no persistent journal was found.

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 1330
Odp: laptop się nie wyłącza
« Odpowiedź #7 dnia: Listopad 21, 2018, 10:31:36 pm »
journalctl -b --list-bootsi wybierz sobie.
Ta "lista" jest zapisywana właśnie w dzienniku systemowym. W Zuśce to było bodaj do przeglądnięcia gdzieś w YaST o ile pamiętam.

Offline mbbartek

  • Jr. Member
  • **
  • Wiadomości: 52
Odp: laptop się nie wyłącza
« Odpowiedź #8 dnia: Listopad 21, 2018, 11:21:55 pm »
wkleiłem to w konsolę i wyszło tak:
journalctl -b --list-boots
 0 8c7e18bedda44b55a6ac855d31b0da1e Wed 2018-11-21 18:16:08 CET—Wed 2018-11-21 23:03:28 CET

wszedłem w yast i dziennik systemowy i mam 3 opcje rozwijane u góry:
y2log, messages, boot.log.
wchodzę w każdą, ale tam jest tyle tego wypisane, że nie bardzo wiem czego szukać, a wszystkiego tu nie wkleję ;/
na czym się skupić??

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 1330
Odp: laptop się nie wyłącza
« Odpowiedź #9 dnia: Listopad 22, 2018, 10:12:07 am »
Z tych w YaST może tylko jakieś "messages" mieć jakieś informacje na ten temat.
W dzienniku systemowym (journal) po prostu trzeba poszukać czegoś co będzie się bardzo długo wykonywać, bo prawdopodobnie na czymś takim stoi. Generalnie - przeglądnąć. Tam jest zapis całej sesji. Szukać. Informacje nt. wyłączania winny zacząć się od linii w stylu:
data nazwa-komputera systemd-logind[cyfra]: System is powering downPamiętaj, że to co widzisz po wywołaniu dziennika, to tylko część, trzeba to przewinąć (np. enterem).

Możliwe, że podałem Ci niewłaściwą komendę i SUSE na tym punkcie jest czułe. Prawidłowa, która winna wszędzie działać, to:
journalctl -b -1To jest informacja o przedostatniej zapisanej sesji. Pod jej koniec winno być o zamykaniu. Z --list-boots wygląda jednak tak, jakby u Ciebie zapisana była wyłącznie jedna z 21.11.2018, któ©a rozpoczęta została o 18:16:08. Dlaczego tylko ta jedna - nie wiem.

Możesz też w konsoli wpisać np. sync && shutdown - jak się zatrzyma, przepisać na czym.

Offline mbbartek

  • Jr. Member
  • **
  • Wiadomości: 52
Odp: laptop się nie wyłącza
« Odpowiedź #10 dnia: Listopad 22, 2018, 11:39:28 pm »
journalctl -b -1
Specifying boot ID or boot offset has no effect, no persistent journal was found.

w załączniku screen z gruba, który ten splash mam wykasować, bo jest wiecej niz jeden.
https://ibb.co/ggEKqV

a jeśli chodzi o sync && shutdown, to wyłącza się jak zwykle, czyli zamyka system i zatrzymuje sie na logo leap. wtedy na ułąmek sekundy wystarczy wcisnąć power i laptop gaśnie

hmm, chyba nie mogę umieszczać na forum załączników ;/
« Ostatnia zmiana: Listopad 22, 2018, 11:45:15 pm wysłana przez mbbartek »

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 1330
Odp: laptop się nie wyłącza
« Odpowiedź #11 dnia: Listopad 22, 2018, 11:51:49 pm »
To poproszę o screen, bo jakby go brak :)

Możesz też tak:
sudo nano /etc/default/grubLinię:
GRUB_CMDLINE_LINUX_DEFAULT="apm=off acpi=off mce=off barrier=off ide=nodma idewait=50 i8042.nomux psmouse.proto=bare irqpoll pci=nommconf resume=/dev/disk/by-id/ata-WDC_WD5000BEVT-22A0RT0_WD-WXA1C20K5233-part6 splash=silent quiet showopts apm=off acpi=off mce=off barrier=off ide=nodma idewait=50 i8042.nomux psmouse.proto=bare irqpoll pci=nommconf resume=/dev/disk/by-id/ata-WDC_WD5000BEVT-22A0RT0_WD-WXA1C20K5233-part6 splash=silent quiet showopts"doprowadzasz do stanu:
GRUB_CMDLINE_LINUX_DEFAULT="apm=off acpi=off mce=off barrier=off ide=nodma idewait=50 i8042.nomux psmouse.proto=bare irqpoll pci=nommconf resume=/dev/disk/by-id/ata-WDC_WD5000BEVT-22A0RT0_WD-WXA1C20K5233-part6 showopts apm=off acpi=off mce=off barrier=off ide=nodma idewait=50 i8042.nomux psmouse.proto=bare irqpoll pci=nommconf resume=/dev/disk/by-id/ata-WDC_WD5000BEVT-22A0RT0_WD-WXA1C20K5233-part6 showopts"Generalnie nie rozumiem po jakiego diabła tam masz 2x to samo, bo ja bym dał (z uwzględnieniem wycięcia tego co nam przesłania komunikaty) tak:
GRUB_CMDLINE_LINUX_DEFAULT="apm=off acpi=off mce=off barrier=off ide=nodma idewait=50 i8042.nomux psmouse.proto=bare irqpoll pci=nommconf resume=/dev/disk/by-id/ata-WDC_WD5000BEVT-22A0RT0_WD-WXA1C20K5233-part6 showopts"i wystarczy. Po zatwierdzeniu wydaj w konsoli komendę:
sudo update-grub(jeśli jest) lub
sudo grub-mkconfig -o /boot/grub/grub.cfgSprawdź, czy na 100% w /boot/grub/ jest plik grub.cfg (powinien, ale nie mam 100%, że w Zuśce jest dokładnie tak samo.
 
PS1: Będziesz chciał potem powrócić do "przesłonięcia" tych komend, to jak się wszystko już uspokoi, to dodasz w ten sam sposób jak teraz usunąłeś, do tej samej linii, to co usunąłeś, czyli: quiet splash=silent i znów komenda z grub-mkconfig.
PS2: Jeśli nie masz nano - zainstaluj, bo i tak Ci się przyda.
PS3: Ok, pokaż po prostu zawartość journalctl, przy czym przeszukaj je i "obkrój" do wpisów, o których wcześniej pisałem. Łatwiej będzie Ci to zrobić tak:
journalctl > zapis.txti potem po prostu przeglądnąć plik zapis.txt w jakimś edytorze tekstu.

Offline mbbartek

  • Jr. Member
  • **
  • Wiadomości: 52
Odp: laptop się nie wyłącza
« Odpowiedź #12 dnia: Listopad 22, 2018, 11:58:58 pm »
Ok, pokombinuje jutro, a screen masz pod linkiem jaki wkleilem w poprzedniej wiadomości.

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 1330
Odp: laptop się nie wyłącza
« Odpowiedź #13 dnia: Listopad 23, 2018, 12:04:58 am »
Screen nie ma znaczenia - odpowiedź z poprzedniego wpisu jest prawidłowa.

PS: Za diabła nie wiem, dlaczego Zuśka ogranicza Ci dziennik wyłącznie do bierzącego wpisu. Możesz jeszcze wrzucić zawartość: /etc/systemd/journald.confJeśli nie będzie go w takiej lokalizacji, to poszukaj tego pliku.

Offline mbbartek

  • Jr. Member
  • **
  • Wiadomości: 52
Odp: laptop się nie wyłącza
« Odpowiedź #14 dnia: Listopad 23, 2018, 11:21:32 pm »
był dokładnie tam gdzie napisałeś:

 This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.
#
# Entries in this file show the compile time defaults.
# You can change settings by editing this file.
# Defaults can be restored by simply deleting this file.
#
# See journald.conf(5) for details.

[Journal]
#Storage=auto
#Compress=yes
#Seal=yes
#SplitMode=uid
#SyncIntervalSec=5m
#RateLimitIntervalSec=30s
#RateLimitBurst=1000
#SystemMaxUse=
#SystemKeepFree=
#SystemMaxFileSize=
#SystemMaxFiles=100
#RuntimeMaxUse=
#RuntimeKeepFree=
#RuntimeMaxFileSize=
#RuntimeMaxFiles=100
#MaxRetentionSec=
#MaxFileSec=1month
#ForwardToSyslog=yes
#ForwardToKMsg=no
#ForwardToConsole=no
#ForwardToWall=yes
#TTYPath=/dev/console
#MaxLevelStore=debug
#MaxLevelSyslog=debug
#MaxLevelKMsg=notice
#MaxLevelConsole=info
#MaxLevelWall=emerg
« Ostatnia zmiana: Listopad 24, 2018, 12:40:12 am wysłana przez lami07 »