Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: Błąd logowania w trybie graficznym po resecie systemu  (Przeczytany 398 razy)

Offline dawidxx7

  • Newbie
  • *
  • Wiadomości: 7
Błąd logowania w trybie graficznym po resecie systemu
« dnia: Listopad 15, 2018, 02:22:17 pm »
Zostawiłem na chwilę laptopa z odpaloną grą przez Wine, gdy wróciłem laptop się wybudził, ale nie chciało pojawić się okienko z logowaniem (zawsze po wybudzeniu muszę wpisać hasło). Z braku cierpliwości niewiele czekając przytrzymałem przycisk POWER żeby wyłączyć lapka. Gdy go chciałem włączyć to uruchomił się normalnie, wyskoczyło okienko z logowaniem, ale po próbie zalogowania, mignęło coś i włączył się tryb tekstowy z komunikatem
[49.109977] nouveau 0000:04:00.0: bus: MMIO read of 00000000 FAULT at 085048 [ IBUS ]za każdym razem jak się próbuję tak zalogować to liczba w nawiasie kwadratowym jest inna, ale ta 085048 ciągle ta sama.
Gdy po wpisaniu danych logowania w trybie graficznym kliknę enter to na krótką chwilę, dosłownie mignięcie pojawia się inny komunikat, udało mi się zrobić temu zdjęcie i komunikat brzmi tak
*speech-dispatcher disabled; edit /etc/default/speech-dispacher
Starting VirtualBox kernelmodules ...failed!
 (modprobe vboxdrv failed. Please use 'dmesg' to find out why)
*VirtualBox Additions disabled, not in a Virtual Machine
*Loading WebcamStudio kernel modules
*No suitable WebcamStudio modules for the running kernel found

saned disabled; edit /etc/default/saned
*Restoring resolver state...
W trybie tekstowym mogę się zalogować, ale oczywiście chcę normalnie.
Z tego co doczytałem w Internecie to jakiś problem z grafiką, ale jaki i jak go rozwiązać to niestety nie udało mi się znaleźć. Więc proszę o pomoc tutaj. Linux Mint 17.3 z Cinnamonem.

Online TataPingu

  • Hero Member
  • *****
  • Wiadomości: 668
Odp: Błąd logowania w trybie graficznym po resecie systemu
« Odpowiedź #1 dnia: Listopad 15, 2018, 02:45:01 pm »
@dawidxx7
- gdy już się zalogujesz w trybie tekstowym wtypuj:

startx

i enter

Offline dawidxx7

  • Newbie
  • *
  • Wiadomości: 7
Odp: Błąd logowania w trybie graficznym po resecie systemu
« Odpowiedź #2 dnia: Listopad 15, 2018, 04:36:58 pm »
Ekran jest cały czarny i tylko kursor jest. Nic się nie dzieje chodź raz widziałem jak coś mignęło, ale od razu znikło.
Edit: po przełączeniu na tty1 jest coś takiego

https://i.imgur.com/8GD2zYfr.jpg
« Ostatnia zmiana: Listopad 15, 2018, 04:47:59 pm wysłana przez dawidxx7 »

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 513
Odp: Błąd logowania w trybie graficznym po resecie systemu
« Odpowiedź #3 dnia: Listopad 15, 2018, 05:20:46 pm »
To jest maszyna na VB? Masz problem z nią, bo modułu nie potrafi załadować. W pierwszym swoim poście masz wskazane co masz zrobić, by w ogóle zdeterminować problem.

Offline dawidxx7

  • Newbie
  • *
  • Wiadomości: 7
Odp: Błąd logowania w trybie graficznym po resecie systemu
« Odpowiedź #4 dnia: Listopad 15, 2018, 09:53:51 pm »
To nie VB, mam zwykły system na laptopie. Wpisałem dmesg i wypluło kilka stron logów. Załączyć to?

Online TataPingu

  • Hero Member
  • *****
  • Wiadomości: 668
Odp: Błąd logowania w trybie graficznym po resecie systemu
« Odpowiedź #5 dnia: Listopad 16, 2018, 11:06:57 am »
@dawidxx7
Nie wiem na ile obeznany jesteś z linuksem. Wychodzę z założenia, że na tyle, że radzisz sobie z terminalem, czy konsolą.
Na pewno coś jest z Xorgiem i systemem graficznym systemu.
Na Twoim miejscu, by, zamiast mozolnie szukać problemu, czy błędu, wszystko "zautomatyzować".
Wyinstalowałbym cały system graficzny wraz z konfiguracjami i na nowo go wgrał.

Użyj do tego ap-getu, remove ale z parametrem --purge, albo samego purge np:

sudo apt-get purge mate cinnamon

Dla pewności po wszystkim:

sudo apt-get autoremove

Następnie zainstaluj na nowo jakieś środowisko np:

sudo apt-get install mate




Offline dawidxx7

  • Newbie
  • *
  • Wiadomości: 7
Odp: Błąd logowania w trybie graficznym po resecie systemu
« Odpowiedź #6 dnia: Listopad 16, 2018, 03:01:07 pm »
Nie ma pakietu mate ani cinnamon. Są poszczególne np. mate-desktop albo cinnamon-session.
Mam takiego samego minta na live USB. Może da się z niego coś naprawić?

Online TataPingu

  • Hero Member
  • *****
  • Wiadomości: 668
Odp: Błąd logowania w trybie graficznym po resecie systemu
« Odpowiedź #7 dnia: Listopad 16, 2018, 03:23:02 pm »
Zapewne się da, tylko nie wiadomo co "poszło"...

Wydaje mi się, że "automatyką" pręcej to naprawisz, a jeśli nie ma mate to wtypuj:

sudo apt-get purge mate-desktop cinnamon-session
« Ostatnia zmiana: Listopad 16, 2018, 03:26:31 pm wysłana przez TataPingu »

Offline hobbysta

  • Newbie
  • *
  • Wiadomości: 27
Odp: Błąd logowania w trybie graficznym po resecie systemu
« Odpowiedź #8 dnia: Listopad 23, 2018, 08:47:43 pm »
Skoro system działał a teraz przestał działać to nie jest to wina sterownika. Przecież to ten sam sterownik co wcześniej - ale być może wcześniej był używany sterownik Nvidia - bo noveauo jest sterownikiem do tych właśnie kart. Jest możlwe, że teraz system zamiast sterownika nvidii ładuje nouveau - ale to nie może zadziałać. Dlatego to pierwsza rzecz, którą trzeba sprawdzić.  Zrób tak: zaloguj  w tryb tekstowy i wpisz
$ lsmod
i pokaż nam co tam masz w środku. Dalej: jak grafika nie działa spróbuj albo Ctrl+PrawyAlt+Backspace, albo Ctrl+LewyAlt+F6 - zamiast F6 być może będziesz musiał wcisnąć F5 albo jeszcze jakiś inny. Pierwsze 'zabija' grafikę i powracasz do ekranu logowania, drugie 'wstrzymuje' grafikę i wchodzi w konsolę. Powrót do grafiki to LewyAlt+F7.  Jak grafika  się zawiesiła i nie daje się 'zabić' - to wtedy można wejść w konsole (jak opisałem) i 'czysto'  zamknąć system takim poleceniem.
$ sudo shutdown -Ph now
albo zrestartowac
$ sudo reboot
Wyłączenie przez przycisk zasilania może powodować utratę danych na dysku. Nie jest to częste ale zdarza się.

Offline dawidxx7

  • Newbie
  • *
  • Wiadomości: 7
Odp: Błąd logowania w trybie graficznym po resecie systemu
« Odpowiedź #9 dnia: Listopad 29, 2018, 12:56:39 pm »
lsmod wypluło takie coś
Module                  Size  Used by
drbg                   28672  1
ansi_cprng             16384  0
ctr                    16384  1
ccm                    20480  1
rfcomm                 69632  8
bnep                   20480  2
binfmt_misc            20480  1
arc4                   16384  2
iwlmvm                311296  0
uvcvideo               90112  0
videobuf2_vmalloc      16384  1 uvcvideo
videobuf2_memops       16384  1 videobuf2_vmalloc
videobuf2_v4l2         28672  1 uvcvideo
videobuf2_core         36864  2 uvcvideo,videobuf2_v4l2
v4l2_common            16384  1 videobuf2_v4l2
videodev              180224  4 uvcvideo,v4l2_common,videobuf2_core,videobuf2_v4l2
hid_multitouch         20480  0
media                  24576  2 uvcvideo,videodev
mac80211              733184  1 iwlmvm
intel_rapl             20480  0
x86_pkg_temp_thermal    16384  0
intel_powerclamp       16384  0
coretemp               16384  0
kvm_intel             172032  0
dell_wmi               16384  0
sparse_keymap          16384  1 dell_wmi
snd_hda_codec_hdmi     53248  1
dell_led               16384  1
dell_laptop            20480  0
dcdbas                 16384  1 dell_laptop
dell_smm_hwmon         16384  0
btusb                  45056  0
btrtl                  16384  1 btusb
btbcm                  16384  1 btusb
kvm                   544768  1 kvm_intel
snd_hda_codec_realtek    90112  1
btintel                16384  1 btusb
bluetooth             520192  25 bnep,btbcm,btrtl,btusb,rfcomm,btintel
snd_hda_codec_generic    73728  1 snd_hda_codec_realtek
snd_hda_intel          40960  0
snd_hda_codec         135168  4 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel
irqbypass              16384  1 kvm
crct10dif_pclmul       16384  0
crc32_pclmul           16384  0
ghash_clmulni_intel    16384  0
aesni_intel           167936  2
iwlwifi               200704  1 iwlmvm
snd_hda_core           73728  5 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
snd_hwdep              16384  1 snd_hda_codec
cfg80211              561152  3 iwlwifi,mac80211,iwlmvm
dm_multipath           24576  0
aes_x86_64             20480  1 aesni_intel
lrw                    16384  1 aesni_intel
gf128mul               16384  1 lrw
glue_helper            16384  1 aesni_intel
ablk_helper            16384  1 aesni_intel
cryptd                 20480  3 ghash_clmulni_intel,aesni_intel,ablk_helper
snd_pcm               106496  4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_core
joydev                 20480  0
input_leds             16384  0
serio_raw              16384  0
rtsx_pci_ms            20480  0
memstick               20480  1 rtsx_pci_ms
snd_seq_midi           16384  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_rawmidi            32768  1 snd_seq_midi
snd_seq                69632  2 snd_seq_midi_event,snd_seq_midi
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              32768  2 snd_pcm,snd_seq
snd                    81920  11 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,snd_seq_device
mei_me                 36864  0
mei                    98304  1 mei_me
dell_rbtn              16384  0
mac_hid                16384  0
intel_smartconnect     16384  0
lpc_ich                24576  0
shpchp                 36864  0
soundcore              16384  1 snd
parport_pc             40960  0
ppdev                  20480  0
lp                     20480  0
parport                49152  3 lp,ppdev,parport_pc
dm_mirror              24576  0
dm_region_hash         24576  1 dm_mirror
dm_log                 20480  2 dm_region_hash,dm_mirror
usbhid                 49152  0
hid                   118784  2 hid_multitouch,usbhid
nouveau              1482752  0
i915                 1228800  3
rtsx_pci_sdmmc         24576  0
mxm_wmi                16384  1 nouveau
i2c_algo_bit           16384  2 i915,nouveau
ttm                    94208  1 nouveau
drm_kms_helper        151552  2 i915,nouveau
ahci                   40960  2
syscopyarea            16384  1 drm_kms_helper
sysfillrect            16384  1 drm_kms_helper
libahci                32768  1 ahci
sysimgblt              16384  1 drm_kms_helper
psmouse               131072  0
fb_sys_fops            16384  1 drm_kms_helper
r8169                  86016  0
mii                    16384  1 r8169
drm                   360448  6 ttm,i915,drm_kms_helper,nouveau
rtsx_pci               53248  2 rtsx_pci_ms,rtsx_pci_sdmmc
wmi                    20480  4 dell_led,dell_wmi,mxm_wmi,nouveau
video                  40960  4 i915,dell_wmi,nouveau,dell_laptop
fjes                   28672  0
Co do tych skrótów klawiszowych to reset grafiki nie działa (bo ten skrót chyba nie działa na ekranie logowania, a dalej nie mogę przejść).

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 513
Odp: Błąd logowania w trybie graficznym po resecie systemu
« Odpowiedź #10 dnia: Listopad 29, 2018, 01:32:21 pm »
Który to Mint? Jeśli używa systemd, to spróbuj gdy pokaże Ci się GRUB przejść do jego edycji, dodać:
systemd.unit=multi-user.targetlub
systemd.unit=rescue.targetW pierwszym przypadku uruchomi Ci się sesja użytkownika, ale bez Xów, w drugim "goły" root z jedynie podstawowymi usługami. Sądzę, że pierwsze będzie dla Ciebie wygodniejsze na tym etapie.
Alternatywnie możesz również spróbować nacisnąć gdy pojawi się ten ekran ze zdjęcia klawisze: ctrl+alt+Fx, gdzie x musisz sobie znaleźć. Nie wiem na którym TTY działają Xy w Mincie, zatem któryś inny będzie włączony. Zwykle jest to albo TTY1 albo TTY2 albo TTY7, zatem "bezpieczne" są F3-6 i F8.
Zaloguj się do systemu w TTY (innymi słowy do konsoli, bez DE).
W tym momencie możesz dokonać podstawowej diagnostyki systemu i jego naprawy.
Przede wszystkim - połącz się z netem. W pierwszym przypadku po kablu powinno połączyć się OTB, w przypadku wifi najlepiej skorzystaj z nmtui i skonfiguruj połączenie.
Dokonaj pełnej aktualizacji systemu z naprawą paczek itd. Ktoś lepiej obeznany w arkanach APTa poda Ci aktualne polecenia.
Zrestartuj system, bo może się naprawiło.
Jeśli nie - ponów operację i po zalogowaniu sprawdź co go boli wywołując:
journalctl --since "10 min ago"(pokaże to dziennik systemowy powstały w przeciągu 10 minut od wydania powyższej komendy, jeśli potrzebujesz innego czasu zmień to 10 na cokolwiek innego, albo wpisz:
journalctl -b(powinno pokazać dziennik aktualny dziennik od bieżącego bootowania się).
Przeszukaj dziennik pod kątem błędów. Winny one się wyróżniać kolorystycznie.
Możesz spróbować znaleźć same błędy, alerty itp. filtrując dziennik:
journalctl -b -p err...alertPrawdopodobnie jednak system ma jakiś problem z grafiką. Wydaje się, że Twój komputer to układ z hybrydową grafiką. Domyślnie winien pracować na GPU Intela. GPU Nvidii jest obecnie (a w zasadzie próbuje być) obsługiwane przez sterownik nouveau. I teraz pytanie: czy kiedykolwiek instalowałeś na tym komputerze sterowniki własnościowe (NVidia/nvidia)? Jak na razie wyłącznie przypuszczam, że właśnie tu coś nawaliło.

Jeśli masz problem ze zrozumieniem logów i naprawą, wrzuć - całkiem możliwe, że się coś wymyśli. Jeśli dziennik będzie długi przekieruj go na jakiś plik i ów plik wrzuć na jakiś serwis typu pastebin, a tu daj tylko linka. I nie - nie chcemy zdjęcia :)'

Inna sprawa, że - niestety wzrok już nie ten - wydaje się, że system startuje normalnie, a jedynie nie podnosi DM. Jeśli tak jest w istocie (po starcie jest prompt, a ty wpisujesz tam startx, który coś się kiełbasi), to spróbuj wywołać ekran logowania:
sudo systemctl start lightdm(jeśli w Mint/u Ciebie nie jest to lightdm, tylko inny DM, to trzeba wywołać jego usługę). Jeśli system odżyje i pojawi Ci się ekran logowania, to tę usługę trzeba będzie dodać do uruchamianych przy starcie (enable).