Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: Problem z libx264-148 (Rozwiązany)  (Przeczytany 515 razy)

Offline Delfin22

  • Newbie
  • *
  • Wiadomości: 12
Problem z libx264-148 (Rozwiązany)
« dnia: Wrzesień 15, 2018, 03:46:16 pm »
Uszanowanie!
Ostatnio znalazłem starego, małego netbooka, gdzie dawno temu zainstalowałem Sparkiego z lxde. Chciałem go odświeżyć i trochę po korzystać, więc zrobiłem generalny update z upragadem i wszystko działa, ale nie mogę wejść, do Synaptic, bo wywala takie coś:
Cytuj
E: Pakiet libx264-148 ma zostać ponownie zainstalowany, ale nie można znaleźć jego archiwum.
E: Błąd wewnętrzny pamięci podręcznej (1). Proszę zgłosić błąd.

Tak samo przy jakiejkolwiek próbie instalacji jakiegoś programu przez terminal.
Proszę o pomoc, co z tym zrobić. Poszukiwania rozwiązania na zagranicznych stronach nic nie dały.
« Ostatnia zmiana: Wrzesień 18, 2018, 09:03:39 pm wysłana przez Delfin22 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1661
Odp: Problem z libx264-148
« Odpowiedź #1 dnia: Wrzesień 15, 2018, 07:06:34 pm »
Spróbuj w terminalu:
sudo apt update
sudo apt-cache policy libx264-148
i pokaż wynik drugiego polecenia.

Zakładam, że jest to Sparky 4 ?
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline Delfin22

  • Newbie
  • *
  • Wiadomości: 12
Odp: Problem z libx264-148
« Odpowiedź #2 dnia: Wrzesień 16, 2018, 01:37:17 pm »
Tak, to Sparky 4. Oto wynik:

Cytuj
libx264-148:
  Zainstalowana: 3:0.148.2691+git00597d7-dmo1
  Kandydująca:   3:0.148.2691+git00597d7-dmo1
  Tabela wersji:
 *** 3:0.148.2691+git00597d7-dmo1 100
        100 /var/lib/dpkg/status
« Ostatnia zmiana: Wrzesień 16, 2018, 01:47:53 pm wysłana przez Delfin22 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1661
Odp: Problem z libx264-148
« Odpowiedź #3 dnia: Wrzesień 16, 2018, 10:49:23 pm »
Spróbuj naprawić uszkodzony pakiet:
sudo dpkg --configure -aJeśli nie pomoże, to:
sudo apt update
sudo apt install --reinstall libx264-148
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline Delfin22

  • Newbie
  • *
  • Wiadomości: 12
Odp: Problem z libx264-148
« Odpowiedź #4 dnia: Wrzesień 16, 2018, 11:55:52 pm »
Pierwsze polecenie nic nie dało i wyrzuciło takie coś, nie wiem czy to się jakoś łączy czy nie, jakby co wrzucam:
Cytuj
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
E: Pakiet libx264-148 ma zostać ponownie zainstalowany, ale nie można znaleźć jego archiwum.
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libreoffice-core:
 libreoffice-core zależy od libboost-date-time1.61.0; jednakże:
  Pakiet libboost-date-time1.61.0 nie jest zainstalowany.
 libreoffice-core zależy od libhunspell-1.4-0; jednakże:
  Pakiet libhunspell-1.4-0 nie jest zainstalowany.

dpkg: błąd przetwarzania pakietu libreoffice-core (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libreoffice-calc:
 libreoffice-calc zależy od libreoffice-core (= 1:5.2.0-1); jednakże:
  Pakiet libreoffice-core nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu libreoffice-calc (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu python3-uno:
 python3-uno zależy od libreoffice-core (= 1:5.2.0-1); jednakże:
  Pakiet libreoffice-core nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu python3-uno (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libreoffice-base-drivers:
 libreoffice-base-drivers zależy od libreoffice-core (= 1:5.2.0-1); jednakże:
  Pakiet libreoffice-core nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu libreoffice-base-drivers (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libreoffice-draw:
 libreoffice-draw zależy od libreoffice-core (= 1:5.2.0-1); jednakże:
  Pakiet libreoffice-core nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu libreoffice-draw (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libreoffice-avmedia-backend-gstreamer:
 libreoffice-avmedia-backend-gstreamer zależy od libreoffice-core (= 1:5.2.0-1); jednakże:
  Pakiet libreoffice-core nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu libreoffice-avmedia-backend-gstreamer (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libreoffice-writer:
 libreoffice-writer zależy od libreoffice-core (= 1:5.2.0-1); jednakże:
  Pakiet libreoffice-core nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu libreoffice-writer (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libreoffice-impress:
 libreoffice-impress zależy od libreoffice-core (= 1:5.2.0-1); jednakże:
  Pakiet libreoffice-core nie jest jeszcze skonfigurowany.
 libreoffice-impress zależy od libreoffice-draw (= 1:5.2.0-1); jednakże:
  Pakiet libreoffice-draw nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu libreoffice-impress (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libreoffice-sdbc-firebird:
 libreoffice-sdbc-firebird zależy od libreoffice-core (= 1:5.2.0-1); jednakże:
  Pakiet libreoffice-core nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu libreoffice-sdbc-firebird (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libreoffice-base:
 libreoffice-base zależy od libreoffice-base-drivers (= 1:5.2.0-1); jednakże:
  Pakiet libreoffice-base-drivers nie jest jeszcze skonfigurowany.
 libreoffice-base zależy od libreoffice-core (= 1:5.2.0-1); jednakże:
  Pakiet libreoffice-core nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu libreoffice-base (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libreoffice-math:
 libreoffice-math zależy od libreoffice-core (= 1:5.2.0-1); jednakże:
  Pakiet libreoffice-core nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu libreoffice-math (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libreoffice:
 libreoffice zależy od libreoffice-base; jednakże:
  Pakiet libreoffice-base nie jest jeszcze skonfigurowany.
 libreoffice zależy od libreoffice-calc; jednakże:
  Pakiet libreoffice-calc nie jest jeszcze skonfigurowany.
 libreoffice zależy od libreoffice-core (= 1:5.2.0-1); jednakże:
  Pakiet libreoffice-core nie jest jeszcze skonfigurowany.
 libreoffice zależy od libreoffice-draw; jednakże:
  Pakiet libreoffice-draw nie jest jeszcze skonfigurowany.
 libreoffice zależy od libreoffice-impress; jednakże:
  Pakiet libreoffice-impress nie jest jeszcze skonfigurowany.
 libreoffice zależy od libreoffice-math; jednakże:
  Pakiet libreoffice-math nie jest jeszcze skonfigurowany.
 libreoffice zależy od libreoffice-writer; jednakże:
  Pakiet libreoffice-writer nie jest jeszcze skonfigurowany.
 libreoffice zależy od libreoffice-avmedia-backend-gstreamer | libreoffice-avmedia-backend-vlc; jednakże:
  Pakiet libreoffice-avmedia-backend-gstreamer nie jest jeszcze skonfigurowany.
  Pakiet libreoffice-avmedia-backend-vlc nie jest zainstalowany.
 libreoffice zależy od python3-uno (>= 4.4.0~beta2); jednakże:
  Pakiet python3-uno nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu libreoffice (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libreoffice-report-builder-bin:
 libreoffice-report-builder-bin zależy od libreoffice-base; jednakże:
  Pakiet libreoffice-base nie jest jeszcze skonfigurowany.
 libreoffice-report-builder-bin zależy od libreoffice-core (= 1:5.2.0-1); jednakże:
  Pakiet libreoffice-core nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu libreoffice-report-builder-bin (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libreoffice-base-core:
 libreoffice-base-core zależy od libreoffice-core (= 1:5.2.0-1); jednakże:
  Pakiet libreoffice-core nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu libreoffice-base-core (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libreoffice-sdbc-hsqldb:
 libreoffice-sdbc-hsqldb zależy od libreoffice-core (= 1:5.2.0-1); jednakże:
  Pakiet libreoffice-core nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu libreoffice-sdbc-hsqldb (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
Wystąpiły błędy podczas przetwarzania:
 libreoffice-core
 libreoffice-calc
 python3-uno
 libreoffice-base-drivers
 libreoffice-draw
 libreoffice-avmedia-backend-gstreamer
 libreoffice-writer
 libreoffice-impress
 libreoffice-sdbc-firebird
 libreoffice-base
 libreoffice-math
 libreoffice
 libreoffice-report-builder-bin
 libreoffice-base-core
 libreoffice-sdbc-hsqldb

Reinstalacja też nic nie dała, tylko wywaliło to samo:
Cytuj
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
E: Pakiet libx264-148 ma zostać ponownie zainstalowany, ale nie można znaleźć jego archiwum.

 :-\

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1661
Odp: Problem z libx264-148
« Odpowiedź #5 dnia: Wrzesień 17, 2018, 03:39:25 pm »
Ten pakiet w tej wersji nie istniej w repozytorium, więc nie może być pobrany i przeinstalowany, w repo jest nowsza wersja. Jest to przyczyną kolejnych problemów apt związanych z odświeżeniem listy pakietów.

W takim razie spróbuj przeinstalować ten pakiet ręcznie.
Pobierz paczkę deb od Debiana, w zależności od twoje architektury (amd64 lub i386):
https://packages.debian.org/stretch/libx264-148
Następnie w katalogu z pobranym pakietem deb spróbuj go zainstalować:
sudo dpkg -i pełna-nazwa-pakietu.debJesli się powiedzie, to:
sudo apt update
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline Delfin22

  • Newbie
  • *
  • Wiadomości: 12
Odp: Problem z libx264-148
« Odpowiedź #6 dnia: Wrzesień 18, 2018, 09:01:16 pm »
To pomogło, działa  :D Dziękuję za pomoc, pozdrawiam i zamykam temat.