Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: logowanie Num Lock  (Przeczytany 204 razy)

Offline Czesław

  • Full Member
  • ***
  • Wiadomości: 122
logowanie Num Lock
« dnia: Wrzesień 09, 2018, 08:58:58 pm »
Xubuntu 18.04 64 bit

Przed logowaniem muszę wcisnąć  Num Lock, kiedyś tak nie było. Co padło?
------------------------
Pozdrawiam Czesław dell-OptiPlex-9020-AIO, i7, 8 GB RAM

Offline Robert75

  • Hero Member
  • *****
  • Wiadomości: 852
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: logowanie Num Lock
« Odpowiedź #1 dnia: Wrzesień 09, 2018, 11:17:06 pm »
Musisz jako root wklepać do terminala:
numlockx onA następnie reboot.
Manjaro Xfce LTS - 64Bit Linux User #621110
PC: HP Compaq 6200 Pro MT / CPU: Intel Core 4x i3-2100 CPU @ 3.10GHz / GPU: Intel HD Graphics 2000 / Nvidia GeForce 7600 GT / RAM: 8 GB  / Dysk: HDD 1 TB

Offline Czesław

  • Full Member
  • ***
  • Wiadomości: 122
Odp: logowanie Num Lock
« Odpowiedź #2 dnia: Wrzesień 10, 2018, 08:18:23 pm »
Niestety nie działa  ani sudo numlockx on, ani sudo numlockx off
------------------------
Pozdrawiam Czesław dell-OptiPlex-9020-AIO, i7, 8 GB RAM

Offline Robert75

  • Hero Member
  • *****
  • Wiadomości: 852
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: logowanie Num Lock
« Odpowiedź #3 dnia: Wrzesień 10, 2018, 10:05:05 pm »
Być może nie masz zainstalowanego pakietu numlockx. Proponuje uruchomić Synaptic-a i sprawdzić.
Manjaro Xfce LTS - 64Bit Linux User #621110
PC: HP Compaq 6200 Pro MT / CPU: Intel Core 4x i3-2100 CPU @ 3.10GHz / GPU: Intel HD Graphics 2000 / Nvidia GeForce 7600 GT / RAM: 8 GB  / Dysk: HDD 1 TB

Offline Czesław

  • Full Member
  • ***
  • Wiadomości: 122
Odp: logowanie Num Lock
« Odpowiedź #4 dnia: Wrzesień 11, 2018, 01:19:56 am »
Reinstalowałem numlockx, przy okazji cały system i bez zmian. Może to i dobrze, bo mam zabezpieczenie przed logowaniem, nawet poprawnym  :)
------------------------
Pozdrawiam Czesław dell-OptiPlex-9020-AIO, i7, 8 GB RAM

Offline gom1

  • Hero Member
  • *****
  • Wiadomości: 543
  • RLU #281182
Odp: logowanie Num Lock
« Odpowiedź #5 dnia: Wrzesień 11, 2018, 09:16:31 am »
Zasadniczo pobieżnie to NumLock zawsze można było w BIOS wyłączyć.
Wszędzie dobrze, ale w /home najlepiej

Offline Robert75

  • Hero Member
  • *****
  • Wiadomości: 852
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: logowanie Num Lock
« Odpowiedź #6 dnia: Wrzesień 11, 2018, 11:55:52 am »
Czesław W sumie to ja Tobie podałem rozwiązanie jak włączyć Num Lock-a z Manjaro Xfce, ale najwidoczniej w Xubuntu trzeba poczynić inne kroki. Znalazłem w sieci takie coś:
https://askubuntu.com/questions/155679/how-to-enable-numlock-at-boot-time-for-login-screen

EDIT:
A jak Tobie się nie chce bawić, to proponuje to rozwiązanie:
Oto mój działający config.
Utwórz nowy, pusty dokument i wklej tą zawartość:
<?xml version="1.0" encoding="UTF-8"?>

<channel name="keyboards" version="1.0">
  <property name="Default" type="empty">
    <property name="RestoreNumlock" type="bool" value="true"/>
    <property name="Numlock" type="bool" value="true"/>
  </property>
</channel>
I nazwij dokument keyboards.xml, następnie wejdż w ukryte pliki do .config/xfce4/xfconf/xfce-perchannel-xml, i do tego ostatniego wklej ten dokument.
Po tym zabiegu powinno zadziałać.
« Ostatnia zmiana: Wrzesień 11, 2018, 10:50:53 pm wysłana przez Robert75 »
Manjaro Xfce LTS - 64Bit Linux User #621110
PC: HP Compaq 6200 Pro MT / CPU: Intel Core 4x i3-2100 CPU @ 3.10GHz / GPU: Intel HD Graphics 2000 / Nvidia GeForce 7600 GT / RAM: 8 GB  / Dysk: HDD 1 TB