Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: znów problem z aktualizacją ROZWIĄZANY  (Przeczytany 3943 razy)

Offline PomPom

  • Hero Member
  • *****
  • Wiadomości: 1309
  • dawniej Dziadek Starowinek
Odp: znów problem z aktualizacją
« Odpowiedź #15 dnia: Sierpień 18, 2018, 03:34:48 pm »
Plejanto, instaluj przez terminal i dodaj --skippgpcheck, czyli np.
yaourt --m-arg "--skippgpcheck" -S ffmpeg2.8
Tak podano w komentarzach w AUR. Komentarze tam są kluczowe, jeżeli coś nie działa, a i warto tam zajrzeć, czy ktoś jakiejś nieprawidłowości nie wyłapał.
( ಥ益ಥ)Arch Linux Plasma & MATE Chrome OS

Offline Robert75

  • Hero Member
  • *****
  • Wiadomości: 909
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: znów problem z aktualizacją
« Odpowiedź #16 dnia: Sierpień 18, 2018, 03:46:47 pm »
Plejanto, instaluj przez terminal i dodaj --skippgpcheck, czyli np.
yaourt --m-arg "--skippgpcheck" -S ffmpeg2.8
Tak podano w komentarzach w AUR. Komentarze tam są kluczowe, jeżeli coś nie działa, a i warto tam zajrzeć, czy ktoś jakiejś nieprawidłowości nie wyłapał.
Dziadosław proszę Cię nie podawaj takich skomplikowanych operacji, gdyż user Plejanto to jest starszy człowiek, i trudniej mu zrozumieć to co wypisujemy w postach.
Anarchy Xfce - 64Bit Linux User #621110PC: HP Compaq 6200 Pro MT / CPU: Intel Core 4x i3-2100 CPU @ 3.10GHz / GPU: Intel HD Graphics 2000 / Nvidia GeForce 7600 GT / RAM: 8 GB / Dysk: HDD 1 TB

Offline PomPom

  • Hero Member
  • *****
  • Wiadomości: 1309
  • dawniej Dziadek Starowinek
Odp: znów problem z aktualizacją
« Odpowiedź #17 dnia: Sierpień 18, 2018, 03:49:12 pm »
Dałem mu gotowe polecenie i z grzeczności uznaję, że potrafi je przekleić. Jeżeli nie, to od początku powinniśmy krzyczeć, żeby nie bawił się w Archa.
( ಥ益ಥ)Arch Linux Plasma & MATE Chrome OS

Offline Piejanto

  • Full Member
  • ***
  • Wiadomości: 208
Odp: znów problem z aktualizacją
« Odpowiedź #18 dnia: Wrzesień 02, 2018, 01:23:50 pm »
Dziadek Starowinek Robert75 
Musiałem wyjechać i odłożyć walkę. Teraz tak: - ściągnąłem ffmpeg-2.8.15.tar.xz i rozpakowałem w oddzielnym katalog. Powstał podlkatalog 'ffmpeg-2.8.15.
Co do klucza, to podany przez Roberta75 klucz właśnie mi sygnalizowało że : "==> Weryfikowanie podpisów plików źródłowych za pomocą gpg...
    ffmpeg-2.8.15.tar.xz ... NIE ZGADZA SIĘ (nieznany klucz publiczny B4322F04D67658D8) " . Podany przez Ciebie klucz, to właśnie ten klucz, który dostałem na zakończenie błędnej instalacji.
Na stronie:
https://aur.archlinux.org/packages/ffmpeg2.8/
mówią o kluczu:
> gpg --recv-key FCF986EA15E6E293A5644F10B4322F04D67658D8

ale też nie bardzo wiem, kiedy go wklepać, bo po uruchomieniu instalacji ostatnią informacją jest informacja o błędnym kluczu i wcześniej mnie o klucz nie pyta.
Miałem uruchomić w terminalu ffmpeg-2.8.15 ale to jest katalog.  Poza tym, bez ffmpeg-2.8 aktualizacje też mi nie chcą działać, a jest ich już do chwili obecnej cała fura.
Tym razem Antergos nie chce mi się aktualizować ani na HP, ani na Acerze. Krewa. Dzięki za pomoc.

Offline PomPom

  • Hero Member
  • *****
  • Wiadomości: 1309
  • dawniej Dziadek Starowinek
Odp: znów problem z aktualizacją
« Odpowiedź #19 dnia: Wrzesień 02, 2018, 01:32:36 pm »
yaourt --m-arg "--skippgpcheck" -S ffmpeg2.8
A próbowałeś tego?

W katalogu właśnie się otwiera terminal, żeby z niego zarządzać plikami w katalogu. Co do tych aktualizacji - co się pojawia? Bo możliwe, że musisz coś ręcznie zmienić, bo Antergos to nakładka na Archa.
https://www.archlinux.org/
Masz na głównej wypisane wymagane rzeczy do ręcznego zrobienia, to może akurat coś się pokrywa.
( ಥ益ಥ)Arch Linux Plasma & MATE Chrome OS

Offline Robert75

  • Hero Member
  • *****
  • Wiadomości: 909
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: znów problem z aktualizacją
« Odpowiedź #20 dnia: Wrzesień 02, 2018, 01:52:30 pm »
Piejanto Klucz należy skopiować i wkleić do terminala przed budowaniem ffmpeg2.8. Pytanie tylko do czego jest Tobie potrzebny ten pakiet, bo mi np. do działania 4Kvideodownloader, ale zastanawiam się nad przejściem na ClipGrab-qt5, ponieważ w tygodniu miałem aktualizacje pakietuffmpeg2.8 i to jest jakiś koszmar, ponieważ jego budowa trwa ponad pół godziny.
Anarchy Xfce - 64Bit Linux User #621110PC: HP Compaq 6200 Pro MT / CPU: Intel Core 4x i3-2100 CPU @ 3.10GHz / GPU: Intel HD Graphics 2000 / Nvidia GeForce 7600 GT / RAM: 8 GB / Dysk: HDD 1 TB

Offline gom1

  • Hero Member
  • *****
  • Wiadomości: 590
  • RLU #281182
Odp: znów problem z aktualizacją
« Odpowiedź #21 dnia: Wrzesień 02, 2018, 02:19:35 pm »
mówią o kluczu:
> gpg --recv-key FCF986EA15E6E293A5644F10B4322F04D67658D8

ale też nie bardzo wiem, kiedy go wklepać
W terminalu, przed rozpoczęciem aktualizacji. Jako zwykły użytkownik.

I nie FCF986EA15E6E293A5644F10B4322F04D67658D8 a B4322F04D67658D8.
Wszędzie dobrze, ale w /home najlepiej

Offline Robert75

  • Hero Member
  • *****
  • Wiadomości: 909
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: znów problem z aktualizacją
« Odpowiedź #22 dnia: Wrzesień 02, 2018, 02:42:24 pm »
Powinno to tak wyglądać:
[robson@pc ~]$ gpg --recv-key B4322F04D67658D8
gpg: key B4322F04D67658D8: 7 signatures not checked due to missing keys
gpg: klucz B4322F04D67658D8: ,,FFmpeg release signing key <ffmpeg-devel@ffmpeg.org>'' 3 nowych podpisów
gpg: brak absolutnie zaufanych kluczy
gpg: Ogółem przetworzonych kluczy: 1
gpg:              nowych podpisów: 3

A po operacji:
pacman-key --refresh-keys
[robson@pc ~]$ gpg --recv-key B4322F04D67658D8
gpg: key B4322F04D67658D8: 7 signatures not checked due to missing keys
gpg: klucz B4322F04D67658D8: ,,FFmpeg release signing key <ffmpeg-devel@ffmpeg.org>'' bez zmian
gpg: Ogółem przetworzonych kluczy: 1
gpg:                    bez zmian: 1
« Ostatnia zmiana: Wrzesień 02, 2018, 04:07:15 pm wysłana przez Robert75 »
Anarchy Xfce - 64Bit Linux User #621110PC: HP Compaq 6200 Pro MT / CPU: Intel Core 4x i3-2100 CPU @ 3.10GHz / GPU: Intel HD Graphics 2000 / Nvidia GeForce 7600 GT / RAM: 8 GB / Dysk: HDD 1 TB

Offline Piejanto

  • Full Member
  • ***
  • Wiadomości: 208
Odp: znów problem z aktualizacją
« Odpowiedź #23 dnia: Wrzesień 14, 2018, 12:15:56 am »
Odpuściłem sobie ffmpeg-2.8, bo faktycznie nie jest chyba mi specjalnie potrzebny, ale jest cała fura innych aktualizacji i otrzymuję komunikat:

nie udało się rozwiązać zależności:
usuwanie libx264przerwanych zależności 'libx264.so=152-64' wymaganych przez ffmpeg
usuwanie libx264-allprzerwanych zależności 'libx264-all' wymaganych przez gst-plugins-ugly

Co im przeszkadza? Czy powinienem wyrzucić ffmpeg? W sumie to ja raczej już nie nagrywam ani nie konwertuję  audio ani video. Pytanie tylko, czy to nie zawali mi innych funkcji?
Robert75 dzięki za informację o ClipGrab-qt5, bo to mi uświadamia, że na wypadek potrzeby, można się obejść bez ffmpeg-2.8   
W tej sytuacji, czy wyrzucić też ffmpeg? Czy to odblokuje czekające aktualizacje?

Offline Robert75

  • Hero Member
  • *****
  • Wiadomości: 909
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: znów problem z aktualizacją
« Odpowiedź #24 dnia: Wrzesień 14, 2018, 11:54:52 am »
Piejanto Wywal w diabły pakiet ffmpeg2.8 skoro nie jest Ci potrzebny, a jestem pewien że wtedy aktualizacja ruszy.
Anarchy Xfce - 64Bit Linux User #621110PC: HP Compaq 6200 Pro MT / CPU: Intel Core 4x i3-2100 CPU @ 3.10GHz / GPU: Intel HD Graphics 2000 / Nvidia GeForce 7600 GT / RAM: 8 GB / Dysk: HDD 1 TB

Offline Piejanto

  • Full Member
  • ***
  • Wiadomości: 208
Odp: znów problem z aktualizacją
« Odpowiedź #25 dnia: Wrzesień 17, 2018, 08:41:50 pm »
Robert75.. no, właśnie wywaliłem ffmpeg-2.8, ale jeszcze ma jakieś pretensje do ffmpeg. Czy mam wywalić również ffmpeg? Nie chciałbym wywalić jakiegoś komponentu bez którego nie może się obejść system.
Przy ostatnich próbach aktualizacji otrzymuję informację:

nie udało się rozwiązać zależności:
usuwanie libx264przerwanych zależności 'libx264.so=152-64' wymaganych przez ffmpeg

Bo było tak: miałem zainstalowane ffmpeg-2.8 które wywaliłem i nie mogę wrócić, a pozostało zainstalowane ffmpeg oraz ffmpegthumbnailer . Czy mam wywalić również te dwie pozycje?
« Ostatnia zmiana: Wrzesień 17, 2018, 09:03:30 pm wysłana przez Piejanto »

Offline PomPom

  • Hero Member
  • *****
  • Wiadomości: 1309
  • dawniej Dziadek Starowinek
Odp: znów problem z aktualizacją
« Odpowiedź #26 dnia: Wrzesień 17, 2018, 09:52:09 pm »
Przeinstaluj ten ffmpeg. O ile wiesz, co wywalasz, a masz to napisane, o tyle możesz spokojnie wywalać, bo szybko to wgrasz na nowo. I najlepiej w terminalu: sudo pacman -Syyuu
( ಥ益ಥ)Arch Linux Plasma & MATE Chrome OS

Offline TataPingu

  • Hero Member
  • *****
  • Wiadomości: 600
Odp: znów problem z aktualizacją
« Odpowiedź #27 dnia: Wrzesień 17, 2018, 11:15:03 pm »
@Piejanto
- jeśli masz na to czas, nerwy i cierpliwość, to się baw, ale jeśli oprócz instalowania, wgrywania, "wywalania", dopasowywania (systemu) chcesz jeszcze robić na tej elektronicznej skrzyni coś konstruktywnego, to wywal w cholerę tego Archa i zainstaluj sobie coś działającego...

Obojętnie co zainstalujesz, to i tak możesz zdobywać doświadczenia z linuksem...

Offline Robert75

  • Hero Member
  • *****
  • Wiadomości: 909
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: znów problem z aktualizacją
« Odpowiedź #28 dnia: Wrzesień 18, 2018, 01:06:44 am »
Zgadzam się z TataPingu. System jest od tego aby z niego korzystać, a nie ciągle przy nim grzebać.
Piejanto bez urazy, ale Antergos nie jest dla Ciebie, jak już chcesz używać systemu Arch-pochodnego to polecam Manjaro, system naprawdę jest solidny a to za sprawą deweloperów którzy trzymają rękę na pulsie. Co za tym idzie aktualizacje przebiegają bezproblemowo. Tak naprawdę to czekam aż mi się Manjaro wysypie, ale gdzie tam, system ciągle działa i działa.
« Ostatnia zmiana: Wrzesień 18, 2018, 12:23:13 pm wysłana przez Robert75 »
Anarchy Xfce - 64Bit Linux User #621110PC: HP Compaq 6200 Pro MT / CPU: Intel Core 4x i3-2100 CPU @ 3.10GHz / GPU: Intel HD Graphics 2000 / Nvidia GeForce 7600 GT / RAM: 8 GB / Dysk: HDD 1 TB

Offline Piejanto

  • Full Member
  • ***
  • Wiadomości: 208
Odp: znów problem z aktualizacją
« Odpowiedź #29 dnia: Wrzesień 18, 2018, 01:55:44 pm »
Robert75; TataPingu; Dziadek Starowinek
Prawdopodobnie maciue rację, ze Antergos nie jest dla mnie, ale... najlepiej mi się na nim pracuje. Fakt, że od paru lat mam po raz drugi z nim kłopoty mnie specjalnie nie zniechęca, chociaż rozumiem, że Was może zn iechęcać kontakt z takim głąbem jak ja. Poprzednie kłopoty przewalczyłem z Waszą pomocą, więc może i tym razem się jakoś przebujam, przez tego nieszczęsnego ffmpge-2,8 i jemu podobnych.  Rzecz w tym, że ja nie specjalnie się orientuję, co mogę wywalić na pysk bez uszczerbku dla moich potrzeb. A potrzeby moje są takie, że obsługuję konta bankowe, używam LibreOffice, czasem coś popełnię na Audacity, a czasem obejrzę jakiś film. Potrzebuję też mieć dostęp do televizji i to mi zapewnia Kaffeine i potrzebuję mieć dostęp do internetu nie tylko przez Wi-Fi i kabel, ale też przez Aero2. To w zasadzie wszystko, no, może jeszcze od czasu do czasu Gimp, aha... no, i jeszcze Stellarium uważam za niezbędne.   Filmów w zasadzie nie opracowuję, ale nie wiem, co jest potrzebne do zwykłego odtwarzania. Stąd moje obawy co do usunięcia ffmpeg i wszystkich pokrewnych i stąd moja uciecha, że nie tylko ffmpeg ale jeszcze mogę się podeprzeć (w razie potrzeby) programem ClipGrab-qt5 , o którym się dowiedziałem od Roberta75. Jak to już zauważył któryś z Was, Panowie, faktem jest, że jestem "starszym człowiekiem" (68 lat), ale nic na to nie poradzę, ze akurat Linux jest moim ulubionym systemem, a w szczególności z pulpitami XFCE lub Gnome. Przekopiowanie i wklejenie w terminalu nie nastręcza mi trudności, ale już uwaga, że trzeba to uczynić jako "zwykły użytkownik" jest dla mnie bardzo cenna, gdyż zazwyczaj zmiany wymagają  aby to robił w terminalu "su". Bardzo Wam jestem wdzięczny za pomoc, gdyż nie bardzo sobie wyobrażam zesłanie na Windows.
TataPingu. Przyjacielu, dzięki za sugestię o Manjaro. Już właściwie byłem zdecydowany, ale przeraża mnie trochę ilość„ roboty związana z przewalaniem zawartości laptopów, na dyski, a później z dysków na laptopy. O ile już wiem, np, jak sobie w Antergosie dawać rad np. z TTF-ami, o tyle obawiam się, że w innej odmianie Linuxa może być inaczej. Przykłądem może być Ubuntu, na którym nie czułem się dobrze, a zaoferowany mi bez uprzedzenia pulpit Cannonicala zniechęcił mnie na tyle, że zainstalowałem Antergosa i poczułem ulgę.
Reasumując: - Manjaro tak, ale w ostateczności. Póki rozumiem, co do mnie mówicie i póki całkowicie mi się nie wysypie Antergos XFCE, będę się go trzymał. Gdy mi się Antergos wysypie, przejdę na Manjaro i będzie to prawdopodobnie ostatnia w moim życiu przesiadka z systemu na inny system.
A wracając do problemu: - Dziadku Starowinkudzięki za tę uwagę :
- "Przeinstaluj ten ffmpeg. O ile wiesz, co wywalasz, a masz to napisane, o tyle możesz spokojnie wywalać, bo szybko to wgrasz na nowo. I najlepiej w terminalu: sudo pacman -Syyuu"
Nick "Dziadek Starowinek" mnie szczególnie ujmuje, gdyż moim ulubionym trunkiem w czasach PRL-u i w czasach DOS-a, był trunek o nazwie "Starowin" i częstokroć sięgałem po kieliszek "starowinka", chociaż nie był to dziadek w ani jednej kropli. Pozdrowienia.
Wszystkie Wasze uwagi są dla mnie nie do przecenienia i dziękuję Wam za cierpliwość. Wywalam ffmpeg i zobaczę co się stanie.
« Ostatnia zmiana: Wrzesień 18, 2018, 02:00:53 pm wysłana przez Piejanto »