Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: Problem z uruchomieniem środowiska Gnome 3.  (Przeczytany 330 razy)

Offline wesiora999

  • Jr. Member
  • **
  • Wiadomości: 70
Problem z uruchomieniem środowiska Gnome 3.
« dnia: Czerwiec 02, 2018, 12:49:35 pm »
Witam!
Po instalacji Arch Linuksa postanowiłem zainstalować środowisko graficzne Gnome 3. Zaktualizowałem pakiety (#pacman -Syu), zainstalowałem środowisko graficzne (#pacman -S gnome gnome-extra) oraz zainstalowałem menadżer logowania gdm. Po ponownym uruchomienu i wpisaniu" systemctl start gdm.service"  pojawił się następujący komunikat, iż "Coś się nie powiodło. Wystąpił problem i nie można przywrócić systemu. Proszę się wylogować i spróbować ponownie." No ale niestety ponowne uruchomienie komputera nie pomaga. Próbowałem też uruchomić Gnoma za pomocą "startx", lecz nie mogę odnależć pliku ".xinitrc". Podczas instalcaji środowiska wybrałem Nvidie, więc może w tym leży problem, aczkolwiek zależy mi na sterownikach od Nvidii (wiecie...gry :) ). Z góry dziękuje za pomoc )

Offline Dziadek Starowinek

  • Hero Member
  • *****
  • Wiadomości: 1096
Odp: Problem z uruchomieniem środowiska Gnome 3.
« Odpowiedź #1 dnia: Czerwiec 02, 2018, 12:57:30 pm »
Nety piszą, że wina nievidii.  Ogólnie najlepiej by było przełączyć się na otwarte stery i później na uruchomionym systemie (potwierdzając, że śmiga) odpalić stery nvidii. No i nie można mieć Waylanda, bo ten się z nievidią gryzie.

startx potrzebuje doinstalowania xorg-xinit

Offline wesiora999

  • Jr. Member
  • **
  • Wiadomości: 70
Odp: Problem z uruchomieniem środowiska Gnome 3.
« Odpowiedź #2 dnia: Czerwiec 02, 2018, 01:00:35 pm »
Czy mogę zatem aktualnie jakoś przełączyć się na otwarte sterowniki?

Offline Dziadek Starowinek

  • Hero Member
  • *****
  • Wiadomości: 1096
Odp: Problem z uruchomieniem środowiska Gnome 3.
« Odpowiedź #3 dnia: Czerwiec 02, 2018, 01:09:06 pm »
https://wiki.archlinux.org/index.php/nouveau#Keep_NVIDIA_driver_installed
Dogranie sterów + to z wiki powinno dać radę.

W ogóle, w trakcie dogrywania wgrały się Xy? Bo GNOME to praktycznie już Wayland, więc może nie poleciało w zależnościach,

Offline wesiora999

  • Jr. Member
  • **
  • Wiadomości: 70
Odp: Problem z uruchomieniem środowiska Gnome 3.
« Odpowiedź #4 dnia: Czerwiec 02, 2018, 01:34:36 pm »
Usunąłem sterowniki od Nvidii i zainstalowałem te domyślne i proszę bardzo, wszystko działa :D. Dziękuje za pomoc! :) Co do tego Waylanda to instalowałem tylko xorg, więc Gnome 3 raczej wciąż działa na xorg.