Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: Pytanie dotyczące instalacji programu filezilla.  (Przeczytany 576 razy)

Offline Piko

  • Newbie
  • *
  • Wiadomości: 28
Pytanie dotyczące instalacji programu filezilla.
« dnia: Maj 14, 2018, 06:28:06 pm »
Witam.
Problemów cd. Dziś chciałem zainstalować z Menedźera  oprogramowania Filezill-ę (miałem ją na starym dysku i korzystałem  z niej ). I tu niespodzianka? Menedźer poinformował mnie że : Spowoduje to usunięcie następujących pakietów:  opera-stable
Czyżby nie pasowała mu Opera w moim komputerze, czy to jest przypadkowa zbieżność nazw a chodzi o coś innego?
Chcę mieć Operę więc wstrzymałem się z dalszą instalacją.
Może później spróbuję jeszcze zrobić to samo z terminala?
Pozdrawiam Piko.

Offline Dziadek Starowinek

  • Hero Member
  • *****
  • Wiadomości: 1188
Odp: Pytanie dotyczące instalacji programu filezilla.
« Odpowiedź #1 dnia: Maj 14, 2018, 07:04:53 pm »
https://github.com/nedrichards/filezilla-flatpak
Jak masz wersję obsługującą flatpak (spróbuj i jak nie udaje się, to nie masz).

Pokrętnie:
https://filezilla-project.org/download.php?show_all=1
Pobierz to i sobie wypakuj gdzieś. W folderze bin masz plik filezilla, który odpali program. Jeżeli nie odpali (np. u mnie nie odpala), to możesz otworzyć terminal w tym folderze i wpisać ./filezilla. To odpali program. Możesz to sobie ułatwić poprzez otwarcie terminalu w folderze bin i wpisanie nano filez.sh, i tam wpisanie ./filezilla. Póżniej prawym klikiem otwierasz i w uprawnieniach dajesz możłiwość odpalania jako plik wykonywalny. Utworzony plik filez.sh powinien odpalać Filezillę.

Offline Piko

  • Newbie
  • *
  • Wiadomości: 28
Odp: Pytanie dotyczące instalacji programu filezilla.
« Odpowiedź #2 dnia: Maj 14, 2018, 08:28:15 pm »
Witam.
https://github.com/nedrichards/filezilla-flatpak
Jak masz wersję obsługującą flatpak (spróbuj i jak nie udaje się, to nie masz).
Powyższy link wkleiłem do przeglądarki, odpaliła się strona i było coś do pobrania więc pobrałem katalog (są jakieś pliki -filezilla-flatpak-master z rozszerzeniem .flatpak i takie samo z .json). I nic ja z tym zrobić nie mogę po za rozpakowaniem. ;)

Pokrętnie:
https://filezilla-project.org/download.php?show_all=1
Pobierz to i sobie wypakuj gdzieś. W folderze bin masz plik filezilla, który odpali program. Jeżeli nie odpali (np. u mnie nie odpala), to możesz otworzyć terminal w tym folderze i wpisać ./filezilla. To odpali program. Możesz to sobie ułatwić poprzez otwarcie terminalu w folderze bin i wpisanie nano filez.sh, i tam wpisanie ./filezilla. Póżniej prawym klikiem otwierasz i w uprawnieniach dajesz możłiwość odpalania jako plik wykonywalny. Utworzony plik filez.sh powinien odpalać Filezillę.
A co do tego ? Nie odpala się rozpakowana wersja Filezilli  w wygląda to tak: kade-linux bin # ./filezilla
./filezilla: error while loading shared libraries: libpng16.so.16: cannot open shared object file: No such file or directory
kade-linux bin #
Będę później jeszcze kombinował. Na razie dzięki za podpowiedzi... i pozdrawiam Piko.

Offline Dziadek Starowinek

  • Hero Member
  • *****
  • Wiadomości: 1188
Odp: Pytanie dotyczące instalacji programu filezilla.
« Odpowiedź #3 dnia: Maj 14, 2018, 08:41:43 pm »
Jaki Mint? Chyba wiem, dlaczego Ci chce wywalić Operę. Ty masz jakoś "sposobem" ją, nie? Że na starym Mincie, na którym nie powinno iść, bo zależności nie spełnia. Odpaliłem u siebie na Debianie apt install filezilla i Opery nie chce ruszać w ogóle.

Offline Piko

  • Newbie
  • *
  • Wiadomości: 28
Odp: Pytanie dotyczące instalacji programu filezilla.
« Odpowiedź #4 dnia: Maj 14, 2018, 09:59:28 pm »
Właśnie otwierając ten wątek, naszła mnie taka myśl że może nie potrzebnie innym głowę zawracam ? Bo w sumie i tak będę chciał zmienić system na "nowszy".. ale ciekawość pozostała.
Mam jeszcze dysk z tym samym systemem Mint 17.2 i starszą Operą (49_02725.34) oraz Filezillą (tej nr. wersji nie pamiętam) i na nim mogę przeprowadzić jeszcze próby? Ale to innym razem.
Dzięki za udzielenie odpowiedzi, pozdrawiam Piko.
...
...
Witam.  Na 99,9% winowajcą w tej sprawie jest oprogramowanie Opery nie pasujące do zainstalowanego systemu, które udało mi się zainstalować  według wzoru zaczerpniętego z YT.  Wątek powiązany z tym tematem to: https://linuxiarze.pl/forum/index.php/topic,2767.msg13678.html#msg13678Pozdrawiam Piko.
« Ostatnia zmiana: Maj 16, 2018, 09:29:54 am wysłana przez Piko »