Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: Problem z aktualizacją ?  (Przeczytany 1363 razy)

Offline sovtware

  • Sr. Member
  • ****
  • Wiadomości: 256
Problem z aktualizacją ?
« dnia: Maj 24, 2013, 09:34:56 am »
w tej chwili korzystam z Mint Lmde edycji Mate Spark za dużo mi przy aktualizacji instalował pakiet Gnome Gnome Sheel itp:

dodałem repo z Debiana i tu zobaczyłem jak aktualizację pójdą zero takich niespodzianek jak na Sparky ale nie instalowałem nic czekam na aktualizacje od Lmde

nie wiem dlaczego nawet na OpenBox chce mi instalować Gnome na Sparkym ale to już nie ważne mam nadzieje że tu nie będę miał takich problemów i zabaw na orginalnch repo
« Ostatnia zmiana: Maj 24, 2013, 09:34:56 am wysłana przez 157 »

Offline sovtware

  • Sr. Member
  • ****
  • Wiadomości: 256
Odp: Problem z aktualizacją ?
« Odpowiedź #1 dnia: Lipiec 07, 2013, 12:48:41 am »
w tej chwili korzystam z Mint Lmde edycji Mate Spark za dużo mi przy aktualizacji instalował pakiet Gnome Gnome Sheel itp:

dodałem repo z Debiana i tu zobaczyłem jak aktualizację pójdą zero takich niespodzianek jak na Sparky ale nie instalowałem nic czekam na aktualizacje od Lmde

nie wiem dlaczego nawet na OpenBox chce mi instalować Gnome na Sparkym ale to już nie ważne mam nadzieje że tu nie będę miał takich problemów i zabaw na orginalnch repo
« Ostatnia zmiana: Lipiec 07, 2013, 12:48:41 am wysłana przez 157 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1527
Odp: Problem z aktualizacją ?
« Odpowiedź #2 dnia: Maj 24, 2013, 08:47:50 pm »
W pierwszej kolejności zmień repozytoria (/etc/apt/sources.list) mate z:

Code:

deb http://repo.mate-desktop.org /debian wheezy main


na aktualne dla testing:

Code:

deb http://repo.mate-desktop.org /debian jessie main


i spróbuj ponownie.

Wygląda na to, że coś się gryzie.

Poza tym brak pakietu update-notifier-gnome w repo Debiana.

Trochę to potrwa zanim zaktualizują wszystkie pakiety w testing.
« Ostatnia zmiana: Maj 24, 2013, 08:47:50 pm wysłana przez 2 »
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline Albedo 0.64

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 593
Odp: Problem z aktualizacją ?
« Odpowiedź #3 dnia: Maj 25, 2013, 04:36:41 pm »
Coś mi tu nie gra u kolegi sovtware, może wcześniej były wprowadzone jakieś zmiany w repozytoriach? U mnie aktualizacja przebiegła bez takich kwiatków. Sprawdziłem żródła oprogramowania i teraz mam repo "debian jessie/sid".
« Ostatnia zmiana: Maj 25, 2013, 04:36:41 pm wysłana przez 90 »
Linux Mint Debian
Linux registered user 556565

Offline sovtware

  • Sr. Member
  • ****
  • Wiadomości: 256
Odp: Problem z aktualizacją ?
« Odpowiedź #4 dnia: Maj 26, 2013, 07:06:52 pm »
Jestem teraz na openbox i nie wiem czy to tak właśnie ma być czy też nie ?

jak zrobić by mi tego świństwa nie instalowało ?

i czy jest taka możliwość

przy środowisku Mate kasuje mi go a instaluje to



Albedo-

0.64 repo nie zmieniałem a mam na testing ustawione




tu na OpenBox to samo mi chce zainstalować lecz mi nic nie kasuje to normalne jak nie używam Gnome aby mi

instalował to środowisko i nautilusa ?

tutaj pokazuje screena



zrzutekranuz20130526185.png



pavroo tak też miałem zrobione teraz jestem na Świerzym systemie i pokazuję to co chce mi zainstalować

czy może robić bezpieczną aktualizację tak zwaną która nic nie kasuje i nic nowego nie instaluje tylko aktualizuje programy ?



Na środowisku Mate to samo mi instaluje tylko że mam jeszcze :

mate-desktop-gnome: do usunięcia



P.S.

Instalowałem wczoraj w nocy środowisko Gnome aby sprawdzić i mieć spokój  Boże ,,, jak tego można używać :( już Unity 100% lepsze gdyby było na Debiana bym przeszedł aby mieć spokój z takimi instalacjami przy aktualizacji

teraz mam na nowo zainstalowanego Sparka



Proszę o odpowiedz czy tak to wyglądać ma ta aktualizacja
« Ostatnia zmiana: Maj 26, 2013, 07:06:52 pm wysłana przez 157 »

Offline Albedo 0.64

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 593
Odp: Problem z aktualizacją ?
« Odpowiedź #5 dnia: Maj 26, 2013, 08:44:33 pm »
Wygląda na to, że powinno być wszystko ok. Przeprowadź aktualizację a później doinstaluj Mate. Pakiety Gnome są wymagane jako zależności Brasero, gThumb, Network Managera czy innych programów z tego środowiska. Może być, że aktualizacja dystrybucji usiłuje zainstalować domyślne środowisko i wywala przy okazji Mate. Widzę, że robisz aktualizacje w terminalu, spróbuj zrobić to przez menedżera aktualizacji, może będzie inaczej? Ja aktualizowałem Sparka 2.1 Mate w ten sposób i problemów nie było.
« Ostatnia zmiana: Maj 26, 2013, 08:44:33 pm wysłana przez 90 »
Linux Mint Debian
Linux registered user 556565

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1527
Odp: Problem z aktualizacją ?
« Odpowiedź #6 dnia: Maj 26, 2013, 10:51:31 pm »
Ze zrzutu nie wynika, że aktualizacja doinstalowuje gnome, lecz tak jak napisał Albedo - instaluje zależności do kilku programów. Nic nie jest usuwane - więc MATE pozostaje nienaruszone. Wszystko jest w porządku, aktualizuj system.
« Ostatnia zmiana: Maj 26, 2013, 10:51:31 pm wysłana przez 2 »
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline sovtware

  • Sr. Member
  • ****
  • Wiadomości: 256
Odp: Problem z aktualizacją ?
« Odpowiedź #7 dnia: Maj 27, 2013, 06:47:58 am »
Albedo-0.64 , pavroo dziękuję za podpowiedzi i pomoc robię aktualizacje przez menadrzera aktualizacji klikając na tak

nic mi nie powołanego nie instaluje i jest dobrze miłego poniedziałku



zrzutekranuv.png
« Ostatnia zmiana: Maj 27, 2013, 06:47:58 am wysłana przez 157 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1527
Odp: Problem z aktualizacją ?
« Odpowiedź #8 dnia: Czerwiec 01, 2013, 01:11:53 pm »
Aktualizacja Sparka 2, a więc Debiana testing z wersji Wheezy do Jessie może wprowadzić trochę zamieszania.

Jessie nie posiada wersji instalacyjnej pakietu 'update-notifier'.

Dodatkowo instaluje nautilusa jako zależność. Bez paniki.

Po wykonaniu pełnej aktualizacji usuń pakiety: 'nautilus' oraz 'nautilus-data'.

W wesji Ultra dodatkowo usuń pakiet 'brasero'.

Następnie usuń wszystkie pozostałości poleceniem:

Code:

apt-get autoremove


« Ostatnia zmiana: Czerwiec 01, 2013, 01:11:53 pm wysłana przez 2 »
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline sovtware

  • Sr. Member
  • ****
  • Wiadomości: 256
Odp: Problem z aktualizacją ?
« Odpowiedź #9 dnia: Czerwiec 01, 2013, 01:51:57 pm »
 @pavroo usunąłem update menadżera już mi tych rzeczy nie instaluje jest w porządku teraz wszystko a Brasero używam mój ulubiony program

więc nie muszę usuwać tych rzeczy aktualizację robię raz dziennie programem synpatic

patrzę mniej więcej co mi chce instalować i wychodzi na to że teraz jest dobrze
« Ostatnia zmiana: Czerwiec 01, 2013, 01:51:57 pm wysłana przez 157 »

Offline urbek

  • Jr. Member
  • **
  • Wiadomości: 98
Odp: Problem z aktualizacją ?
« Odpowiedź #10 dnia: Lipiec 07, 2013, 08:07:16 am »
@sovtware moim zdaniem sam zainstalowałeś sobie jakieś pakiety od gnome, które wymagają innych i tak powstaje twój problem. Jak wiesz ja używam sparka od wielu miesięcy i podobne problemy miałem raz i to też na własne życzenie, gdyż doinstlowałem pakiety od gnome, które potem domagały się kolejnych. LMDE to też dobry system, ale nie wiem czy to dobry pomysł, by mieć obydwa zestawy repozytoriów, w których pakiety się będą dublować. Ja kiedyś do LMDE dodałem repo debiana, ale zrobiłem to zamiennie zamiast oryginalnych.
« Ostatnia zmiana: Lipiec 07, 2013, 08:07:16 am wysłana przez 350 »

Offline sovtware

  • Sr. Member
  • ****
  • Wiadomości: 256
Odp: Problem z aktualizacją ?
« Odpowiedź #11 dnia: Lipiec 07, 2013, 01:46:31 pm »
@urbek



Repo Debiana mam wyłączone

więc Sparky oryginalnie coś musi mieć zainstalowane że potrzebuje pakiety Gnome ponieważ po instalacji i skasowaniu paru programów pierwsza aktualizacja która zajmuje ponad 600 mb to są również do zainstalowania Pakiety Gnome sprawdzałem dwa dni temu po instalowałem od nowa Sparky a nie mam wiele zainstalowane

no nic zostanę tutaj na Lmde zobaczymy jak puszczą aktualizację co mi będzie chciało instalować

nie wiem dlaczego Tobie tych linków nie otwiera mi również wieczorem zrąbie jeszcze raz i wyślę
« Ostatnia zmiana: Lipiec 07, 2013, 01:46:31 pm wysłana przez 157 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1527
Odp: Problem z aktualizacją ?
« Odpowiedź #12 dnia: Lipiec 07, 2013, 02:40:04 pm »
Problem okazał się pakiet "gnome-bluetooth", który ciągnął masę zależności.

Można go odinstalować, do zarządzania urządzeniami bluetooth preinstalowany jest blueman.

W wersji 3.0 rc jest już to poprawione.
« Ostatnia zmiana: Lipiec 07, 2013, 02:40:04 pm wysłana przez 2 »
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline urbek

  • Jr. Member
  • **
  • Wiadomości: 98
Odp: Problem z aktualizacją ?
« Odpowiedź #13 dnia: Lipiec 07, 2013, 06:01:32 pm »
To teraz ja wiem dla czego u mnie takie problemy nie mają miejsca. Ja nie mam fizycznego urządzenia bluetooth więc wywalam też pakiety, które miały by z nim współpracować i w konsekwencji ominęły mnie powyższe problemy z pakietami gnome.
« Ostatnia zmiana: Lipiec 07, 2013, 06:01:32 pm wysłana przez 350 »

Offline sovtware

  • Sr. Member
  • ****
  • Wiadomości: 256
Odp: Problem z aktualizacją ?
« Odpowiedź #14 dnia: Lipiec 07, 2013, 09:59:34 pm »
@pavroo

dziękuję że zwróciłeś na to uwagę i że problem naprawiony narazię zostanę na LMDE i czekam na Finalna wersje Sparky 3 by pobrać od Nas i sprawdzić pozdrawiam
« Ostatnia zmiana: Lipiec 07, 2013, 09:59:34 pm wysłana przez 157 »