Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: Aktualizacja Opery - błąd Libdbus-1-3 (>= 1.9.14)  (Przeczytany 291 razy)

Offline Piko

  • Newbie
  • *
  • Wiadomości: 28
Aktualizacja Opery - błąd Libdbus-1-3 (>= 1.9.14)
« dnia: Maj 12, 2018, 10:11:25 pm »
Witam.
Używam systemu  Mint 17.2 w innym wątku pisałem o wysypanym systemie i odzyskaniu danych i właśnie jestem na etapie odbudowy komputera. Pojawił się problem z aktualizacją przeglądarki Opera. Posiadana przeze mnie wersja 49.0.2725.34 działa bez zarzutu aczkolwiek dopomina się o aktualizację. Pobrałem najnowszą na dzień dzisiejszy aktualizację  53.0.2907.37 i lipa ..
Nie da się zaktualizować bo jest błąd  Libdbus-1-3 (>= 1.9.14) . Nie znalazłem nic optymistycznego na polskich forach w tym temacie. Piszą ludzie że czas się wycofać w Opery .. ble ble ble.. Natomiast szukając jeszcze znalazłem na YT.. filmik pokazujący instalację aktualizacji na nowszym Mint-cie 18.2.  Cała sprawa polega na dwukrotnym uruchomieniu instalacji z pobranego pliku (np. opera-stable_53.0.2907.37_amd64.deb) z terminala . I po sprawie.. Faktycznie przeszło . Nie skopiowałem komunikatu o błędzie w terminalu.. ale tak jak na filmie pokazano .. pojawiła się przeglądarka Opera w grupie Internet.. ba  z informacją o wersji:53.0.2907.37 - Posiadasz najnowszą wersję Opery
Kanał aktualizacji: Stable
System: Ubuntu 14.04.2 LTS (x86_64; X-Cinnamon)
Identyfikacja przeglądarki
Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.139 Safari/537.36 OPR/53.0.2907.37

Ścieżki dostępu
Instalacja: /usr/lib/x86_64-linux-gnu/opera
Profil: /home/kade/.config/opera
Pamięć podręczna: /home/kade/.cache/opera

Włączyłem i tak na oko .. to wszystko działa.. Czy mam się czegoś  doszukiwać ? Czy to po prostu tylko "grozi" niestabilnością systemu? Czy się niczym nie przejmować ?
Pozdrawiam Piko.


Offline Dziadek Starowinek

  • Hero Member
  • *****
  • Wiadomości: 906
  • linux nie istnieje
Odp: Aktualizacja Opery - błąd Libdbus-1-3 (>= 1.9.14)
« Odpowiedź #1 dnia: Maj 12, 2018, 10:18:50 pm »
Super rady dają z tym porzucaniem przeglądarki, a nie systemu z czteroletnimi bibliotekami...
Opera wymaga Ubuntu przynajmniej 16.04. Jak Ci jakoś poszło na starszym i działa to spoko, tylko jak będzie coś nie tak z przeglądarką, to możliwe, że właśnie winą jest to wymuszenie aktualizacji.
nie istniejesz

Offline Piko

  • Newbie
  • *
  • Wiadomości: 28
Odp: Aktualizacja Opery - błąd Libdbus-1-3 (>= 1.9.14)
« Odpowiedź #2 dnia: Maj 13, 2018, 10:12:33 am »
Super rady dają z tym porzucaniem przeglądarki, a nie systemu z czteroletnimi bibliotekami...

Witam.
Skłamałbym  gdybym powiedział że takich opinii nie widziałem? Owszem były ale tego nie brałem pod uwagę. A ty jesteś jednak za zmianą systemu?
Niedawno tak z sentymentu do nazwy ... zainstalowałem sobie na osobnym dysku - 18.2 Sonia.  Owszem podoba mi się, i jest nowszy ale nie wiem czy to z mojej winy czy taką jakąś opcje wybrałem że w żaden sposób nie mogłem się zalogować jako root?  I  zainstalowałem z powrotem 17.2  gdzie jest ta funkcja i mogłem wykonywać polecenia z poziomu terminala. 
To jednak przymierzać się do zmiany systemu?
Pozdrawiam Piko.

Offline Dziadek Starowinek

  • Hero Member
  • *****
  • Wiadomości: 906
  • linux nie istnieje
Odp: Aktualizacja Opery - błąd Libdbus-1-3 (>= 1.9.14)
« Odpowiedź #3 dnia: Maj 13, 2018, 11:27:52 am »
Po prostu przymierzaj się do aktualizacji. Niedługo wejdzie Mint 19 i LMDE3. Z tym rootem, to ogólnie miałem wrażenie, że Ubuntu to domyślnie blokuje i musiałbyś sobie poszukać poradnika, jak to odblokować.
nie istniejesz

Offline Albedo 0.64

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 643
Odp: Aktualizacja Opery - błąd Libdbus-1-3 (>= 1.9.14)
« Odpowiedź #4 dnia: Maj 13, 2018, 12:17:27 pm »
Miałem to samo w LMDE 2 - po prostu przestarzałe biblioteki w systemie. Ale może być też druga przyczyna ponieważ na Sparky 5 (Debian Testing) nie poszła instalacja Opery przez APTus, dopiero z pobranego pakietu deb instalacja się powiodła.
Debian
Linux registered user 556565

Offline lesio

  • Sr. Member
  • ****
  • Wiadomości: 467
Odp: Aktualizacja Opery - błąd Libdbus-1-3 (>= 1.9.14)
« Odpowiedź #5 dnia: Maj 13, 2018, 05:42:24 pm »
Odblokowanie root-a w ubuntu:
https://pl.wikibooks.org/wiki/Ubuntu/Dost%C4%99p_do_konta_root

A tu razem z odblokowaniem sesji graficznej:
https://linuxtechlab.com/enabling-root-account-ubuntu/

Offline Piko

  • Newbie
  • *
  • Wiadomości: 28
Odp: Aktualizacja Opery - błąd Libdbus-1-3 (>= 1.9.14)
« Odpowiedź #6 dnia: Maj 14, 2018, 01:55:55 pm »
Dziękuję za pomocne sugestie i linki. Za kilka dni spróbuję zainstalować sobie Sonię i sprawdzę  jak to mi zagra?
Pozdrawiam Piko.
...
...
Witam.
Minęło już kilka dni chociaż jeszcze nie zainstalowałem nowego systemu, to doszły kolejne mocne argumenty za jego zmianą. 
Ikona informująca o rekomendowanych aktualizacjach poinformowała że jest do pobrania poppler, przy próbie aktualizacji pojawiła się informacja o usunięciu opera-stable. Dziś doszła kolejna aktualizacja o nazwie kmod i efekt ten sam.
Tak więc dochodzę do przekonania że nie ma sensu dalej brnąć w tę stronę i trzeba zmienić system na nowszy.
Powiązany wątek:
https://linuxiarze.pl/forum/index.php/topic,2771.msg13694.html#msg13694
...
...
I zainstalowałem dziś Sonię.. 18.2 ver 64bit. Ciekawostką jest to, że repozytoriach do pobrania (instalowania) nie ma Opery.. ;)
Są inne przeglądarki.. a tej nie ma.. Lipa.
Pozdrawiam Piko.
« Ostatnia zmiana: Maj 16, 2018, 04:58:07 pm wysłana przez Piko »

Offline Piko

  • Newbie
  • *
  • Wiadomości: 28
Odp: Aktualizacja Opery - błąd Libdbus-1-3 (>= 1.9.14)
« Odpowiedź #7 dnia: Maj 16, 2018, 11:50:44 pm »
Witam.
Jak wspomniałem, dziś zainstalowałem nowy system Mint 18.02 Sonia. Owszem nie ma w repozytoriach systemu Opery ale na stronie Opery są pliki do pobrania. Ja miałem już pobrany wcześniej plik opera-stable_53.0.2907.37_amd64.deb i kliknąłem aby spróbować zainstalować. Przeszło, pojawił się komunikat o pobraniu jakiś plików i za chwilę Opera już była. Po jakiejś godzinie oznajmiła że jest nowsza wersja do pobrania więc pobrałem i teraz jest:Informacje o wersji
Wersja: 53.0.2907.57 - Posiadasz najnowszą wersję Opery
Kanał aktualizacji: Stable
System: Linux Mint 18.2 (x86_64; XFCE)
Identyfikacja przeglądarki
Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.170 Safari/537.36 OPR/53.0.2907.57

Ścieżki dostępu
Instalacja: /usr/lib/x86_64-linux-gnu/opera
Profil: /home/kade/.config/opera
Pamięć podręczna: /home/kade/.cache/opera
Zainstalowałem również sobie filezillę i błędów nie ma. Program się uruchamia, tak więc temat zakończony. Przestarzały system i tyle. Dziękuję za pomocne uwagi i spostrzeżenia.
Pozdrawiam Piko.

Offline Piko

  • Newbie
  • *
  • Wiadomości: 28
Odp: Aktualizacja Opery - błąd Libdbus-1-3 (>= 1.9.14)
« Odpowiedź #8 dnia: Maj 17, 2018, 10:15:14 am »
Odblokowanie root-a w ubuntu:
https://pl.wikibooks.org/wiki/Ubuntu/Dost%C4%99p_do_konta_root

A tu razem z odblokowaniem sesji graficznej:
https://linuxtechlab.com/enabling-root-account-ubuntu/

Witam. Działa odblokowałem. Dziękuję.