Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: Problemy z modemem ZTE MF195  (Przeczytany 231 razy)

Offline lukas60055

  • Newbie
  • *
  • Wiadomości: 5
Problemy z modemem ZTE MF195
« dnia: Maj 11, 2018, 04:58:12 pm »
Witam, otóż nie mogę sobie poradzić od dłuższego czasu z uruchomieniem modemu. Przeszukałem wiele artykułów ale na nic :(

Do rzeczy:
Urządzenie mi normalnie wykrywa

lukas60055@lukas60055-hp-t5740:~$ lsusb
Bus 002 Device 003: ID 0bda:2838 Realtek Semiconductor Corp. RTL2838 DVB-T
Bus 002 Device 002: ID 058f:6387 Alcor Micro Corp. Flash Drive
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 022: ID 04b4:0060 Cypress Semiconductor Corp. Wireless optical mouse
Bus 001 Device 016: ID 04e8:6863 Samsung Electronics Co., Ltd GT-I9500 [Galaxy S4] / GT-I9250 [Galaxy Nexus] (network tethering)

Bus 001 Device 021: ID 19d2:1515 ZTE WCDMA Technologies MSM

Bus 001 Device 008: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 001 Device 007: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 04d9:1702 Holtek Semiconductor, Inc. Keyboard LKS02
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

--- dodane uprawnienia chmod 777
crwxrwxrwx 1 root dialout 166,  0 maj 11 16:39 /dev/ttyACM0
crwxrwxrwx 1 root dialout 166,  1 maj 11 16:35 /dev/ttyACM1
crwxrwxrwx 1 root dialout 166,  2 maj 11 16:36 /dev/ttyACM2


Ale już jako modem nie:
lukas60055@lukas60055-hp-t5740:~$ wvdialconf
Editing `/etc/wvdial.conf'.
 
Scanning your serial ports for a modem.
 
ttyS0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyS0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyS0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
Modem Port Scan<*1>: S1   S2   S3   S4   S5   S6   S7   S8 
Modem Port Scan<*1>: S9   S10  S11  S12  S13  S14  S15  S16 
Modem Port Scan<*1>: S17  S18  S19  S20  S21  S22  S23  S24 
Modem Port Scan<*1>: S25  S26  S27  S28  S29  S30  S31 
ttyACM0<Info>: Device or resource busy
Modem Port Scan<*1>: ACM0
ttyACM1<Info>: Device or resource busy
Modem Port Scan<*1>: ACM1
WvModem<*1>: Cannot set information for serial port.
ttyACM2<*1>: ATQ0 V1 E1 -- ERROR
ttyACM2<*1>: failed with 2400 baud, next try: 9600 baud
ttyACM2<*1>: ATQ0 V1 E1 -- ERROR
ttyACM2<*1>: failed with 9600 baud, next try: 115200 baud
ttyACM2<*1>: ATQ0 V1 E1 -- ERROR
ttyACM2<*1>: and failed too at 115200, giving up.
 
 
Sorry, no modem was detected!  Is it in use by another program?
Did you configure it properly with setserial?
 
Please read the FAQ at http://alumnit.ca/wiki/?WvDial


Próbowałem z sudo przed wvdialconf i można powiedzieć ze wykrywało ale tylko ACM0 i ACM1. ACM2 ciągle error. Próbowałem podpiąć do gammu, ale pisze wyświetla się error: Error opening device. Unknown, busy or no permissions. Próbowałem także z usb_modeswitch itp. na nic.

Proszę o pomoc z góry dziękuje!

Offline San Dimas

  • Jr. Member
  • **
  • Wiadomości: 62
  • Debian Stretch 9.4
Odp: Problemy z modemem ZTE MF195
« Odpowiedź #1 dnia: Maj 11, 2018, 10:47:19 pm »
Modemy ZTE generalnie są DD.
Mam jeden 3g i nawet nie idzie go uruchomić pod windows 8/10, a co dopiero pod linuksem.
Sprzedaj jakiemuś frajerowi i kup Huawei.
Poważnie mówię.
'Dla tych raperów największe marzenie to żeby zagrano ich w Esce
Jadą taryfą, usłyszą Pitbulla i myślą "ej k***a, ja też chcę”.'

Offline Robert75

  • Hero Member
  • *****
  • Wiadomości: 795
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: Problemy z modemem ZTE MF195
« Odpowiedź #2 dnia: Maj 11, 2018, 11:36:28 pm »
Zobacz tutaj:
https://linuxiarze.pl/forum/index.php/topic,2692.msg12884.html#msg12884
Manjaro Xfce - 64Bit Linux User #621110
AMD Athlon 64 X2 Dual Core 4200+ @ 2x 2.21GHz / 4 GB RAM / Nvidia GeForce 7600 GT / Dysk HDD 1 TB