Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: CentOS Python 3.6 problem z SSL  (Przeczytany 842 razy)

Offline fieścik

  • Newbie
  • *
  • Wiadomości: 1
CentOS Python 3.6 problem z SSL
« dnia: Styczeń 19, 2018, 12:58:45 pm »
Witam, otóż mam problem z linuxem a dokładniej z prawidłową konfiguracją pythona na nim. Zainstalowałem pythona (3.6) potem PIP'a wszystkie biblioteki jakie znalazłem w internecie. Za to nie mogę pobrać żadnych bibliotek przez PIP'a typu cartography czy chociażby OpenSSL. Instalując wszystko przez yum zainstalowała mi się wersja Pythona 2.7. O dziwo pip w tej wersji działa wyśmienicie. Ale ja potrzebuję wersji pythona 3.5 lub wyższej. Z góry przepraszam za zaplątany język bądź powtarzalność ale jest pofrustrowany kofiguracją vps'a... Btw. mam dostęp tylko do SSH i częściowo do ftp. Tak wygląda komunikat błędu: pip is configured with locations that require TLS/SSL, however the ssl module in Python is not available.
« Ostatnia zmiana: Styczeń 19, 2018, 01:02:37 pm wysłana przez fieścik »