Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: Antergos - Wifi/Ethernet problem  (Przeczytany 558 razy)

Offline Gostop

  • Newbie
  • *
  • Wiadomości: 3
Antergos - Wifi/Ethernet problem
« dnia: Grudzień 04, 2017, 08:18:58 pm »
Witam,
od kilku tygodni próbuje rozwiązać następujący problem, mianowicie nie jestem w stanie połączyć się z niektórymi sieciami używając WiFi jak i po kablu. Moja domowa sieć działa bez problem ale np w biurze nie mogę się połączyć z siecią ani przez kabel ani przez WiFi. Próbowałem chyba już wszystkiego co poradzili mi na forum Antergosa ale nic to nie dało, liczyłem, że przedwczorajszy update kernela pomoże jednak też nic to nie dało, cały czas dostaje ten sam error:

wlp3s0: failed to remove key (1, ff:ff:ff:ff:ff:ff) from hardware (-22) fix
Dodam, że na mając zainstalowanego Manjaro i Ubuntu na tej samej maszynie łącze się z wifi w biurze bez żadnych problemów. Podobno ten patch https://bugzilla.kernel.org/attachment.cgi?id=260597&action=diff&collapsed=&headers=1&format=raw
naprawia ten błąd, niestety jestem dość świeżym użytkownikiem linuxa i nie mam pojęcia jak to zainstalować, więc jeśli ktoś jest w stanie mnie pokierować lub zna inne rozwiązanie tego problemu byłbym bardzo wdzięczny.


Online Dziadek Starowinek

  • Hero Member
  • *****
  • Wiadomości: 899
  • linux nie istnieje
Odp: Antergos - Wifi/Ethernet problem
« Odpowiedź #1 dnia: Grudzień 04, 2017, 08:36:21 pm »
Manjaro i Ubuntu mają inne kernele - jakie? Może starczy wgrać linux-lts i z niego odpalać.
nie istniejesz

Offline Gostop

  • Newbie
  • *
  • Wiadomości: 3
Odp: Antergos - Wifi/Ethernet problem
« Odpowiedź #2 dnia: Grudzień 04, 2017, 08:54:55 pm »
Nie pamiętam na jakich kernelach odpalałem ubuntu i manjaro. Odpalenie na linux-lts nie pomaga.

Offline Robert75

  • Hero Member
  • *****
  • Wiadomości: 775
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: Antergos - Wifi/Ethernet problem
« Odpowiedź #3 dnia: Grudzień 04, 2017, 08:56:58 pm »
Ja również miałem problem z połączeniem, na szczęście udało mi się rozwiązać ten problem.
  https://linuxiarze.pl/forum/index.php/topic,2444.msg11024.html#msg11024
Manjaro Xfce - 64Bit Linux User #621110
AMD Athlon 64 X2 Dual Core 4200+ @ 2x 2.21GHz / 4 GB RAM / Nvidia GeForce 7600 GT / Dysk HDD 1 TB

Offline Robert75

  • Hero Member
  • *****
  • Wiadomości: 775
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: Antergos - Wifi/Ethernet problem
« Odpowiedź #4 dnia: Grudzień 04, 2017, 09:03:05 pm »
Ja na Twoim miejscu bym zainstalował pakiet usb_modeswitch przez yaourt, a mianowicie:
yaourt -Sb usb_modeswitch
« Ostatnia zmiana: Grudzień 05, 2017, 01:23:44 am wysłana przez Robert75 »
Manjaro Xfce - 64Bit Linux User #621110
AMD Athlon 64 X2 Dual Core 4200+ @ 2x 2.21GHz / 4 GB RAM / Nvidia GeForce 7600 GT / Dysk HDD 1 TB

Offline Gostop

  • Newbie
  • *
  • Wiadomości: 3
Odp: Antergos - Wifi/Ethernet problem
« Odpowiedź #5 dnia: Grudzień 05, 2017, 08:42:50 am »
Zaintalowałem na Antergosie i nic nie pomogło, zainstalowałem Manjaro i o dziwo mam identyczny problem mimo ze wcześniej wifi działało.

update:

Sytuacja wyglada tak, że na Manjaro wifi działa na live usb i zaraz po instalacji ale gdy zrobie sudo pacman -Syu to wifi przestaje działać mimo ze nie zmieniam kernela, wiec zapewne to wina najnowszych sterowników, dobrze myslę?
« Ostatnia zmiana: Grudzień 05, 2017, 01:55:35 pm wysłana przez Gostop »

Offline Robert75

  • Hero Member
  • *****
  • Wiadomości: 775
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: Antergos - Wifi/Ethernet problem
« Odpowiedź #6 dnia: Grudzień 05, 2017, 01:59:48 pm »
Pakiet usb_modeswitch nie odpowiada za połączenia z wifi, jedynie za połączenia ethernet-owe. Ponieważ połączenie z netem w Manjaro działa bez zarzutu, to właśnie ostatnio aktualizowany pakiet usb_modeswitch namieszał trochę w systemie.
Manjaro Xfce - 64Bit Linux User #621110
AMD Athlon 64 X2 Dual Core 4200+ @ 2x 2.21GHz / 4 GB RAM / Nvidia GeForce 7600 GT / Dysk HDD 1 TB