Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: Synaptic - authorisation failed  (Przeczytany 429 razy)

Offline gom1

  • Sr. Member
  • ****
  • Wiadomości: 330
  • RLU #281182
Synaptic - authorisation failed
« dnia: Sierpień 08, 2017, 01:02:59 pm »
Cześć,

W najnowszej odmianie Sparka (5 LXQT) przy próbie uruchomienia Synaptica otrzymuję komunikat:
Authorization failed for some reason
Uruchamiając z konsoli dostaję:
gom1@sparky:~$ synaptic-pkexec
Error executing command as another user: Not authorized

This incident has been reported.

Z konsoli jako root nie mam problemu z uruchomieniem narzędzia, ale z wiadomych względów chciałbym mieć możliwość odpalania Synaptica z menu.

Dzięki
« Ostatnia zmiana: Sierpień 08, 2017, 01:13:04 pm wysłana przez gom1 »
Wszędzie dobrze, ale w /home najlepiej

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1570
Odp: Synaptic - authorisation failed
« Odpowiedź #1 dnia: Sierpień 08, 2017, 01:58:46 pm »
Jeśli dobrze pamiętam, nastąpiła zmiana w autoryzacji uprawnień LXQt.
Sprawdź czy posiadasz zainstalowany pakiet 'lxqt-policykit'; jeśli nie to zainstaluj i restart systemu.
Sprawdź czy jest uruchomiony:
pidof lxqt-policykit-agentJeśli wynik jest pusty, uruchom go ręcznie:
lxqt-policykit-agenti sprawdź możliwość uruchomienia dowolnego programu z uprawnieniami admina, np. synaptic.
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline gom1

  • Sr. Member
  • ****
  • Wiadomości: 330
  • RLU #281182
Odp: Synaptic - authorisation failed
« Odpowiedź #2 dnia: Sierpień 08, 2017, 02:27:00 pm »
Zainstalowany:
gom1@sparky:~$ sudo apt search lxqt-policykit
Sorting... Gotowe
Full Text Search... Gotowe
lxqt-policykit/testing,now 0.11.1-2 i386 [installed]
  LXQt authentication agent for PolicyKit
i uruchomiony:
gom1@sparky:~$ pidof lxqt-policykit-agent
2556
Błąd dalej występuje.

Edit: podobnie jest przy próbie uruchomienia GParted.

Edit 2: w wirtualce mam starszą wersję systemu (ok. tydzień) i tam wszystko chodzi prawidłowo. Sprawdzę jakie pakiety będą chciały się zaktualizować.

Edit 3:
Zostaną zainstalowane następujące NOWE pakiety:
  chromium-common libdrm-common libevent-2.1-6 libgpgmepp6 libwebpmux3 libxmlsec1 libxmlsec1-nss
Następujące pakiety zostaną zaktualizowane:
  chromium cups-browsed cups-filters cups-filters-core-drivers dbus dbus-x11 debhelper deluge deluge-common
  deluge-gtk ffmpeg fonts-opensymbol gir1.2-freedesktop gir1.2-glib-2.0 gir1.2-gtk-3.0
  gtk-update-icon-cache ifupdown imagemagick imagemagick-6-common imagemagick-6.q16 libaudio2 libavcodec57
  libavdevice57 libavfilter6 libavformat57 libavresample3 libavutil55 libcupsfilters1 libdatrie1
  libdbus-1-3 libdrm-amdgpu1 libdrm-intel1 libdrm-nouveau2 libdrm-radeon1 libdrm2 libexpat1 libfaad2
  libfontembed1 libgirepository-1.0-1 libgtk-3-0 libgtk-3-bin libgtk-3-common libipc-run-perl libldap-2.4-2
  libldap-common liblept5 liblwp-protocol-https-perl libmagickcore-6.q16-3 libmagickwand-6.q16-3
  libnet-dns-perl liborbit-2-0 libpcre16-3 libpcre3 libperl5.26 libpostproc54 libqt5xdg2 libreoffice
  libreoffice-avmedia-backend-gstreamer libreoffice-base libreoffice-base-core libreoffice-base-drivers
  libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-gtk3
  libreoffice-impress libreoffice-java-common libreoffice-math libreoffice-report-builder-bin
  libreoffice-sdbc-hsqldb libreoffice-style-galaxy libreoffice-style-tango libreoffice-writer
  libsdl-ttf2.0-0 libsdl2-2.0-0 libslang2 libswresample2 libswscale4 libtasn1-6 libthai-data libthai0
  libudisks2-0 libupower-glib3 libvo-aacenc0 libvo-amrwbenc0 libwayland-client0 libwayland-cursor0
  libwayland-server0 libwebp6 libwebpdemux2 libwww-perl libxcb-icccm4 libxcb-render-util0
  libxml-libxml-perl libxml-simple-perl manpages manpages-dev perl perl-base perl-modules-5.26 python3-pil
  python3-uno sparky-apt sparky-aptus-extra sparky-desktop t1utils udisks2 uno-libs3 upower ure
Zostaną zainstalowane STARE wersje następujących pakietów:
  libpolkit-agent-1-0 libpolkit-gobject-1-0
Zrobię snapshot, zaktualizuję i sprawdzę czy tu też się wywali.
« Ostatnia zmiana: Sierpień 08, 2017, 02:49:15 pm wysłana przez gom1 »
Wszędzie dobrze, ale w /home najlepiej

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1570
Odp: Synaptic - authorisation failed
« Odpowiedź #3 dnia: Sierpień 08, 2017, 03:06:13 pm »
Odpowiedzialny za autostart LXQt polkit jest:
/etc/xdg/autostart/lxqt-policykit-agent.desktop
Sprawdź również, czy podobny plik nie dubluje/niweluje działania lxqt polkit w:
/~HOME/.config/autostart/
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline gom1

  • Sr. Member
  • ****
  • Wiadomości: 330
  • RLU #281182
Odp: Synaptic - authorisation failed
« Odpowiedź #4 dnia: Sierpień 08, 2017, 03:07:41 pm »
Sprawdzę, ale na gorąco: po update na maszynie wirtualnej błąd również występuje.
Wszędzie dobrze, ale w /home najlepiej

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1570
Odp: Synaptic - authorisation failed
« Odpowiedź #5 dnia: Sierpień 08, 2017, 03:18:57 pm »
Cytuj
Zostaną zainstalowane STARE wersje następujących pakietów:
  libpolkit-agent-1-0 libpolkit-gobject-1-0
Spróbuj przeinstalować te dwa pakiety:
sudo apt update
sudo apt install --reinstall libpolkit-agent-1-0 libpolkit-gobject-1-0
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1570
Odp: Synaptic - authorisation failed
« Odpowiedź #6 dnia: Sierpień 08, 2017, 03:38:49 pm »
Ciekawe jest, iż te dwa pakiety były ostatnio downgradowane do wersji debianowych:
https://linuxiarze.pl/forum/index.php/topic,2192.msg9026.html#msg9026
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline gom1

  • Sr. Member
  • ****
  • Wiadomości: 330
  • RLU #281182
Odp: Synaptic - authorisation failed
« Odpowiedź #7 dnia: Sierpień 08, 2017, 03:45:39 pm »
Spróbuj przeinstalować te dwa pakiety:
sudo apt update
sudo apt install --reinstall libpolkit-agent-1-0 libpolkit-gobject-1-0
Niestety nie pomogło. Jeden naprawiony błąd generuje trzy nowe? ;-)
Wszędzie dobrze, ale w /home najlepiej

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1570
Odp: Synaptic - authorisation failed
« Odpowiedź #8 dnia: Sierpień 08, 2017, 06:57:21 pm »
Chwilowo nie mam dostępu do swojej maszyny roboczej, lecz zainstalowałem sparka lxqt na vboxie laptopa i...
Dwa pakiety, które poprzednio downgradowałeś to nie wszystko.
Wrzuciłem wszystkie wymagana do wstecznej aktualizacji do repo sparka, więc:
sudo apt update
sudo apt full-upgrade
sudo reboot
Daj znać czy pomogło.
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline gom1

  • Sr. Member
  • ****
  • Wiadomości: 330
  • RLU #281182
Odp: Synaptic - authorisation failed
« Odpowiedź #9 dnia: Sierpień 09, 2017, 08:57:45 am »
Daję znać - pomogło. Dzięki :-)
Wszędzie dobrze, ale w /home najlepiej