Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: SparkyLinux 4.6 STB MinimaGUI - IMHO błędy dwa  (Przeczytany 992 razy)

Offline da1k1

  • Newbie
  • *
  • Wiadomości: 5
SparkyLinux 4.6 STB MinimaGUI - IMHO błędy dwa
« dnia: Czerwiec 25, 2017, 02:31:10 pm »
Dzień dobry,

Wczoraj odkryłem :) w/w wersję i jest taka jaka mi potrzebna :) ... ale znalazłem dwa problemy.

1. Mniejszy. Wypalam ISO na USB i uruchamiam komputer. Uruchomiam instalatora bez podłączenia do internetu, wyłączam go ... i już go nie mogę uruchomić. Reset oczywiście pomaga :) Jeżeli jestem podłączony do sieci to mogę go uruchomić kolejne razy.

2. Większy. Odkryłem, że jeżeli zainstaluję Operę, to przy próbie zainstalowania następnego programu wyrzuca mi mega długą listę brakujących bądź uszkodzonych "dependencies" (nie wiem jak to nazwać po polsku :) ). I niby mogę użyć apt --fix-broken install, ale to kończy się wypluciem kolejnych błędów i system można w zasadzie postawić od nowa :/ Sprawdziłem, że w wersji SparkyLinux 4.6 STB LXDE ten problem nie występuje. Na tą chwil poradziłem sobie tak, że nie zainstalowałem po prostu Opery, ale nie ukrywam, że chętnie bym to zrobił. Więc jak mogę prosić o pomoc w tej kwestii to będę wdzięczny. Poniżej kawałek tego to co mi wypluwa po instalacji Opery (dla przykładu chciałem zainstalować Claws Mail).


vbox@vbox-pc:~$ sudo apt-get install claws-mail
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 acpi-support : Depends: x11-xserver-utils but it is not going to be installed
                Depends: acpid (>= 1.0.4) but it is not going to be installed
                Recommends: rfkill but it is not going to be installed
                Recommends: acpi-fakekey but it is not going to be installed
 acpi-support-base : Depends: acpid (>= 1.0.4) but it is not going to be installed
 adduser : Depends: passwd but it is not going to be installed
 adwaita-icon-theme : Depends: gtk-update-icon-cache but it is not going to be installed
                      Depends: librsvg2-common but it is not going to be installed
 alsa-base : PreDepends: dpkg (>= 1.15.7.2~) but it is not going to be installed
             Depends: kmod (>= 17-1) but it is not going to be installed
 apt : Depends: gpgv but it is not going to be installed or
                gpgv2 but it is not going to be installed or
                gpgv1 but it is not going to be installed
 aspell-en : Depends: aspell (>= 0.60.3-2) but it is not going to be installed
 autoconf : Depends: perl (> 5.005) but it is not going to be installed
            Depends: m4 (>= 1.4.13) but it is not going to be installed
            Depends: debianutils (>= 1.8) but it is not going to be installed
 autopoint : Depends: xz-utils but it is not going to be installed
 bash-completion : PreDepends: dpkg (>= 1.15.7.2~) but it is not going to be installed
                   Depends: bash (>= 3.2) but it is not going to be installed
 bluetooth : Depends: bluez but it is not going to be installed
 ca-certificates : Depends: openssl (>= 1.0.0) but it is not going to be installed
 claws-mail : Depends: libcompfaceg1 but it is not going to be installed
              Depends: libenchant1c2a (>= 1.6.0) but it is not going to be installed
              Depends: libetpan17 (>= 1.4) but it is not going to be installed
              Depends: libice6 (>= 1:1.0.0) but it is not going to be installed
              Depends: liblockfile1 (>= 1.0) but it is not going to be installed
              Depends: libpisock9 but it is not going to be installed
              Depends: libsm6 but it is not going to be installed
              Recommends: claws-mail-i18n but it is not going to be installed
              Recommends: xfonts-100dpi but it is not going to be installed or
                          xfonts-75dpi but it is not going to be installed or
                          xfonts-100dpi-transcoded but it is not going to be installed or
                          xfonts-75dpi-transcoded but it is not going to be installed
 colord:amd64 : Depends: colord-data:amd64 but it is not installable
 console-setup-linux : Depends: kbd (>= 0.99-12) but it is not going to be installed or
                                console-tools (>= 1:0.2.3-16) but it is not installable
 cpanminus : Depends: perl (>= 5.19.4) but it is not going to be installed
             Depends: perl (>= 5.23.0) but it is not going to be installed or
                      libhttp-tiny-perl (>= 0.056) or
                      curl but it is not going to be installed or
                      wget but it is not going to be installed
             Depends: perl (>= 5.23.9) but it is not going to be installed or
                      libversion-perl (>= 1:0.9912)
 deb-multimedia-keyring : Depends: gpgv but it is not going to be installed
                          Recommends: gnupg but it is not going to be installed
 debconf : PreDepends: perl-base (>= 5.20.1-3~) but it is not going to be installed
           Recommends: apt-utils (>= 0.5.1) but it is not going to be installed
 debconf-i18n : Depends: liblocale-gettext-perl but it is not going to be installed
                Depends: libtext-iconv-perl but it is not going to be installed
                Depends: libtext-charwidth-perl but it is not going to be installed
 debhelper : Depends: binutils but it is not going to be installed
             Depends: dpkg (>= 1.16.2) but it is not going to be installed
             Depends: file (>= 3.23) but it is not going to be installed
             Depends: man-db (>= 2.5.1-1) but it is not going to be installed
             Depends: perl but it is not going to be installed
 debian-archive-keyring : Depends: gpgv but it is not going to be installed
                          Recommends: gnupg but it is not going to be installed
 


pozdrawiam,
« Ostatnia zmiana: Czerwiec 26, 2017, 08:11:15 am wysłana przez da1k1 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1588
Odp: SparkyLinux 4.6 STB MinimaGUI - IMHO błędy dwa
« Odpowiedź #1 dnia: Czerwiec 25, 2017, 09:03:22 pm »
Witaj
Cytuj
Uruchomiam instalatora bez podłączenia do internetu
Który instalator? Sparky Installer czy Advanced Installer?

Problem z instalcją dowolnej aplikacji: Czy zaktualizowałeś listę pakietów przed próbą instalacji?
sudo apt updateWersja LXDE posiada wbudowany First Run, i jeśli go uruchomiłeś to lista pakietów została zaktualizowana.
Jeśli nie, to po usunięciu First Run i restarcie uruchamia się Update Notifier, więc lista jest również aktalizowana.
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline da1k1

  • Newbie
  • *
  • Wiadomości: 5
Odp: SparkyLinux 4.6 STB MinimaGUI - IMHO błędy dwa
« Odpowiedź #2 dnia: Czerwiec 25, 2017, 09:33:15 pm »
Cytuj
Który instalator? Sparky Installer czy Advanced Installer?
Sparky Installer

Cytuj
Problem z instalcją dowolnej aplikacji: Czy zaktualizowałeś listę pakietów przed próbą instalacji?

Jest tak: czysta instalacja, jak tylko się pierwszy raz loguję to uruchamiam
 sudo apt update i sudo apt upgrade Jeżeli chcę zainstalować Claws Mail (jako przykład) to ściąga mi coś koło 12MB i jest git. Ale jeżeli ściągnę instalkę Opery i ją zainstaluję to dostaję później to co opisałem
« Ostatnia zmiana: Czerwiec 25, 2017, 09:35:42 pm wysłana przez da1k1 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1588
Odp: SparkyLinux 4.6 STB MinimaGUI - IMHO błędy dwa
« Odpowiedź #3 dnia: Czerwiec 25, 2017, 09:58:53 pm »
Sparky Installer to po prostu Calamares - nie wniknąłem do niego aż tak głęboko, aby odpowiedzieć na to pytanie.

W przypadku Opery należy zidentyfikować błąd.
W katalogu z pobranym pakietem deb opery wydaj polecenie:
sudo dpkg -i opera_wersja-numer_amd64.debWyskoczą błędy, więc:
sudo apt update
sudo apt install -f
Jeśli instalacja się nie powiedzie, to pokaż wynik dwóch ostatnich poleceń.
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline da1k1

  • Newbie
  • *
  • Wiadomości: 5
Odp: SparkyLinux 4.6 STB MinimaGUI - IMHO błędy dwa
« Odpowiedź #4 dnia: Czerwiec 25, 2017, 10:48:30 pm »
nie działa, to co dostaję jest poniżej.

Postawiłem też świeżą VM i przy instalacji przez GDebi przy Status jest napisane: "Requires the removal of 21 packages Requires the installation of 137 packages" Jak kliknę Details to mam ich listę, niestety jest tak mała ramka, że widać tylko jedną linię. W to be removed są m.in: apt, python, sparky-*, task-* i taksel-*


vbox@vbox-pc:~/Downloads$ sudo dpkg -i opera-stable_45.0.2552.898_i386.deb
dpkg: regarding opera-stable_45.0.2552.898_i386.deb containing opera-stable:i386, pre-dependency problem:
 opera-stable:i386 pre-depends on apt-transport-https
 
dpkg: error processing archive opera-stable_45.0.2552.898_i386.deb (--install):
 pre-dependency problem - not installing opera-stable:i386
Errors were encountered while processing:
 opera-stable_45.0.2552.898_i386.deb
vbox@vbox-pc:~/Downloads$ sudo apt update
Hit:1 http://security.debian.org stretch/updates InRelease
Hit:2 http://www.deb-multimedia.org stretch InRelease
Ign:3 http://ftp.debian.org/debian stretch InRelease
Hit:5 https://sparkylinux.org/repo stable InRelease
Hit:6 https://sparkylinux.org/repo testing InRelease
Get:4 http://ftp.debian.org/debian stretch Release [113 kB]
Get:7 http://ftp.debian.org/debian stretch Release.gpg [3108 B]
Fetched 117 kB in 0s (200 kB/s)
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up to date.
vbox@vbox-pc:~/Downloads$ sudo apt install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1588
Odp: SparkyLinux 4.6 STB MinimaGUI - IMHO błędy dwa
« Odpowiedź #5 dnia: Czerwiec 25, 2017, 10:53:23 pm »
Cytuj
sudo dpkg -i opera-stable_45.0.2552.898_i386.deb
Podstawowe pytanie: w jaki sposób instalujesz pakiet opera i386, skoro Opera jest wydawana tylko dla maszyn 64 bitowych (amd64)?
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline da1k1

  • Newbie
  • *
  • Wiadomości: 5
Odp: SparkyLinux 4.6 STB MinimaGUI - IMHO błędy dwa
« Odpowiedź #6 dnia: Czerwiec 25, 2017, 11:22:56 pm »
Cytuj
sudo dpkg -i opera-stable_45.0.2552.898_i386.deb
Podstawowe pytanie: w jaki sposób instalujesz pakiet opera i386, skoro Opera jest wydawana tylko dla maszyn 64 bitowych (amd64)?
Taki plik dostaję jak wejdę z Midori w SparkyLinux na opera.com. Na stronie nie ma opcji, żeby wybrać inny plik. Sprawdzałem kilka razy. Wygląda więc na to, że albo Midori zgłasza się jako aplikacja i386, albo coś jest skopane na opera.com.

Zrobiłem test i sprawdziłem w Sparky LXDE i tam FF ściąga wersję 64-bitową. Jak ten sam plik uruchomię w wersji Minimal to Opera instaluje się i Claws Mail później też instaluje się prawidłowo.

Idąc za ciosem ;) sprawdziłem, że jak spod Windows 10 ściągam wersję dla Linux'a w DEB to dostaję ... plik i386 !

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1588
Odp: SparkyLinux 4.6 STB MinimaGUI - IMHO błędy dwa
« Odpowiedź #7 dnia: Czerwiec 26, 2017, 12:30:45 am »
To jakiś absurd, ale cuda się zdarzają.
Ostatnia, dostępna wersja opery i386 ma numer 12.

Wrzuciłem deba opery dla amd64 do repo sparkowego, więc:
sudo apt update
sudo apt install opera-stable
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline da1k1

  • Newbie
  • *
  • Wiadomości: 5
Odp: SparkyLinux 4.6 STB MinimaGUI - IMHO błędy dwa
« Odpowiedź #8 dnia: Czerwiec 26, 2017, 08:09:42 am »
Wrzuciłem deba opery dla amd64 do repo sparkowego

wielkie dzięki :)