Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: Błędy w aktualizacji  (Przeczytany 816 razy)

Offline Grzegorz

  • Full Member
  • ***
  • Wiadomości: 184
  • Inżynier to pewien stan umysłu , a nie tytuł.
Błędy w aktualizacji
« dnia: Maj 13, 2017, 08:32:04 am »
Witam
    Linux grzegorz-pc 4.11.0-1-MANJARO #1 SMP PREEMPT Mon May 1 06:59:15 UTC 2017 x86_64 GNU/Linux     [grzegorz@grzegorz-pc ~]$ mhwd-kernel -li
Currently running: 4.11.0-1-MANJARO (linux411)
The following kernels are installed in your system:
   * linux411

Zaznaczony problem
   [grzegorz@grzegorz-pc ~]$ sudo pacman -Syu
:: Synchronizowanie baz danych z pakietami…
 core jest aktualne
 extra jest aktualne
 community jest aktualne
 multilib jest aktualne
:: Rozpoczynanie pełnej aktualizacji systemu…
rozwiązywanie zależności…
szukanie sprzecznych pakietów...
błąd:  nie udało się przygotować transakcji (nie udało się rozwiązać zależności)
:: gstreamer0.10-good-plugins: instalacja libsoup (2.58.1-1) zależność przerw 'libsoup-gnome'

Poproszę o pomoc.
Grzegorz

Offline Robert75

  • Hero Member
  • *****
  • Wiadomości: 695
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: Błędy w aktualizacji
« Odpowiedź #1 dnia: Maj 13, 2017, 12:16:53 pm »
Dzisiaj ten wątek był poruszany na Forum Manjaro.pl i z tego co się orientuje został rozwiązany.
https://manjaro.pl/forum/topic/aktualizacja-systemu-problemy/#post-3947           
Manjaro Xfce - 64Bit Linux User #621110
AMD Athlon 64 X2 Dual Core 4200+ @ 2x 2.21GHz / 4 GB RAM / Nvidia GeForce 7600 GT / Dysk HDD 1 TB

Offline Grzegorz

  • Full Member
  • ***
  • Wiadomości: 184
  • Inżynier to pewien stan umysłu , a nie tytuł.
Odp: Błędy w aktualizacji
« Odpowiedź #2 dnia: Maj 15, 2017, 08:19:17 am »
Przeczytałem powyższą podpowiedź , jak dla mnie czarna magia.Może mi ktoś napisać krok po kroczku jak ten problem rozwiązać , co odinstalować , co zostawić by system ruszył?
Z góry dziękuje.
Grzegorz

Offline Robert75

  • Hero Member
  • *****
  • Wiadomości: 695
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: Błędy w aktualizacji
« Odpowiedź #3 dnia: Maj 15, 2017, 01:35:55 pm »
@Grzegorz Przecież w podanym poście jest jasno sprecyzowane że zbędnym pakietem w systemie jest "gstreamer0.10" i należy go odinstalować, jak i jego zależności.
Nie zwracałbym tez uwagi że podczas odinstalowania pakietu "gstreamer0.10" zostaniesz ostrzeżony że pakiet jest potrzebny. Śmiało można go odinstalować ponieważ wyżej wymieniony pakiet jest przestarzały i od dawna nie wspierany.
Manjaro Xfce - 64Bit Linux User #621110
AMD Athlon 64 X2 Dual Core 4200+ @ 2x 2.21GHz / 4 GB RAM / Nvidia GeForce 7600 GT / Dysk HDD 1 TB

Offline Grzegorz

  • Full Member
  • ***
  • Wiadomości: 184
  • Inżynier to pewien stan umysłu , a nie tytuł.
Odp: Błędy w aktualizacji
« Odpowiedź #4 dnia: Maj 15, 2017, 03:55:51 pm »
Wykonałem następujące czynności z poziomu menażera aktualizacji:
zaznaczyłem do aktualizacji wszystkie pakiety oprócz
gstreamer 0.10-good plugins
libsup-gnome
xorg-serwer
to pakiety w konflikcie
aktualizacja zakończona sukcesem
ale po restarcie system nie wstaje, mam czarny ekran z komunikatem :starting version 232
/dev/sda3:recovering journal
Grzegorz

Offline Robert75

  • Hero Member
  • *****
  • Wiadomości: 695
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: Błędy w aktualizacji
« Odpowiedź #5 dnia: Maj 15, 2017, 04:07:02 pm »
@Grzegorz Przecież ja Tobie tłumaczyłem że należy odinstalować tylko pakiet gstreamer0.10.
W takiej sytuacji należy wcisnąć jednocześnie kombinacje klawiszy Ctri+Alt+F2 (tak zwane tty) i po zalogowaniu się wklep do terminala zaklęcie:
sudo pacman -S xorg-serverI po zainstalowaniu pakietu wpisz:
rebootA jeżeli pakiet xorg-server będzie w konflikcie z pakietem gstreamer0.10 to będziesz go musiał odinstalować zaklęciem:
sudo pacman -R gstreamer0.10Ponieważ pakiet xorg-server jest bardzo ważnym pakietem w systemie i bez niego  system nie wstanie.
« Ostatnia zmiana: Maj 15, 2017, 04:18:11 pm wysłana przez Robert75 »
Manjaro Xfce - 64Bit Linux User #621110
AMD Athlon 64 X2 Dual Core 4200+ @ 2x 2.21GHz / 4 GB RAM / Nvidia GeForce 7600 GT / Dysk HDD 1 TB

Offline Grzegorz

  • Full Member
  • ***
  • Wiadomości: 184
  • Inżynier to pewien stan umysłu , a nie tytuł.
Odp: Błędy w aktualizacji
« Odpowiedź #6 dnia: Maj 15, 2017, 05:53:51 pm »
Nie udało się dokonać transakcji
(konfliktujące pliki)
xorg-server:/usr/lib/xorg/modules/extensions/libglx.so-znajduje się w systemi plików.Nie zaktualizowana żadnego pakietu.
Grzegorz

Offline Robert75

  • Hero Member
  • *****
  • Wiadomości: 695
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: Błędy w aktualizacji
« Odpowiedź #7 dnia: Maj 15, 2017, 06:26:09 pm »
W takim wypadku pozostaje tylko reinstalacja.
A gdybyś mnie posłuchał od początku i odinstalował pakiet gstreamer0.10 to aktualizacja by przebiegła prawidłowo, i po restarcie system by wstał normalnie.
Ale cóż człowiek uczy się na błędach.
Chociaż ja bym spróbował jeszcze jednego sposobu:
sudo pacman -SyuTo jest polecenie do sprawdzenia czy są dostępne aktualizacje.
Jeśli będą to wtedy odinstaluj ten nieszczęsny pakiet gstreamer0.10. poleceniem podanym w wcześniejszym moim poście. I zaktualizuj system brakującymi pakietami.
« Ostatnia zmiana: Maj 15, 2017, 07:04:29 pm wysłana przez Robert75 »
Manjaro Xfce - 64Bit Linux User #621110
AMD Athlon 64 X2 Dual Core 4200+ @ 2x 2.21GHz / 4 GB RAM / Nvidia GeForce 7600 GT / Dysk HDD 1 TB