Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: Kłopot z połączeniem internetowym  (Przeczytany 950 razy)

Offline bsharp142

  • Newbie
  • *
  • Wiadomości: 9
Kłopot z połączeniem internetowym
« dnia: Marzec 23, 2017, 01:20:33 pm »
Witajcie

Wczoraj znów zainstalowałem linuxa (ubuntu) i  gdy chciałem połączyć się z internetem, niespodziewanie nie mogłem. Pomyslałem: ok, jutro się naprawi.  Posiedziałem 20 minut i nic. Jakies propozycje co moze być nie tak?

Offline lesio

  • Sr. Member
  • ****
  • Wiadomości: 433
Odp: Kłopot z połączeniem internetowym
« Odpowiedź #1 dnia: Marzec 23, 2017, 04:37:46 pm »
No cóż, nie dajesz żadnych szans komuś, kto chciałby Ci pomóc. Nic nie wiadomo o tym, jak chcesz się łączyć z Internetem (wifi,rj-45,modem usb), z jakich urządzeń korzystasz, w jakich warunkach internet działał przedtem.

Offline bsharp142

  • Newbie
  • *
  • Wiadomości: 9
Odp: Kłopot z połączeniem internetowym
« Odpowiedź #2 dnia: Marzec 23, 2017, 04:57:18 pm »
Działał  przewodowo, rj-45. W sumie dalej działa podłączony do laptopa, ubuntu, od dwóch dni.  Nie znam sie na linuxie. Nie mam pojecie co powinienem podac, nie wiem jaki to model karty sieciowej, nie interesuje mnie hardware, wole algo w c++. Moze to moja wina. Wczoraj dzialal w windzie 8.1. Wiecej informacji nie posiadam.

Offline bsharp142

  • Newbie
  • *
  • Wiadomości: 9
Odp: Kłopot z połączeniem internetowym
« Odpowiedź #3 dnia: Marzec 23, 2017, 06:30:46 pm »
$ sudo ethtool eth0 | grep Link
ta komenda wywoluje napis yes. Czyli karta zdrowa tak?

Offline bsharp142

  • Newbie
  • *
  • Wiadomości: 9
Odp: Kłopot z połączeniem internetowym
« Odpowiedź #4 dnia: Marzec 23, 2017, 08:46:04 pm »
Więc ta, udalo mi sie ustalic, ze karta sieciowa jest wykrywana. Lecz eth0 nie ma przypisanego zadnego ip. Czy to moze byc  blad w konfiguracji? W internecie niz sensownego znalezc nie moge.

Offline lesio

  • Sr. Member
  • ****
  • Wiadomości: 433
Odp: Kłopot z połączeniem internetowym
« Odpowiedź #5 dnia: Marzec 24, 2017, 09:16:02 am »
Podaj wyniki poleceń:
$ ifconfig -a
$ lshw -class network
gdyby polecenia lshw nie było, to można je zainstalować komendą: sudo apt-get install lshw

Offline bsharp142

  • Newbie
  • *
  • Wiadomości: 9
Odp: Kłopot z połączeniem internetowym
« Odpowiedź #6 dnia: Marzec 24, 2017, 02:26:16 pm »
-ifconfig -a

eth0   Link encap: Ethernet HWaddr 00:40:f4:b4:e6:7d
         BROADCAST MULTICAST MTU: 1500 Metric: 1
         RX packets: 0 errors:0 dropped:0 overruns:0 frame:0
         TX packets: 0 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen: 1000
         RX bytes:0  (0.0 B) TX bytes:0 (0.0 B)

lo      Link encap:Local Loopback
         inet add:127.0.0.1 Mask:255.0.0.0
         inet6 adds: ::1/128 Scope:Host
         UP LOOPBACK RUNNING MTU:65536 Metric:1
         RX packets:96 errors:0 dropped:0 overruns:0 frame:0
         TX packets:96 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0
         RX bytes:7712 (7.7 KB) TX bytes:07712 (7.7 KB)



- lshw -class network
*-network DISABLED
   description: Ethernet interface
   product: RTL-8100/8101L/8139 PCI Fast Ethernet Adapter
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 1
   bus info: pci@0000:04:01:0
   logical name: eth0
   version: 10
   serial: 00:40:f4:b4:e6:7d
   size:  10Mbit/s
   capacity: 100Mbit/s
   width: 32 bits
   clock: 33MHz
   Capabilities: bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=half latency=32
   link=no maxlatency=64 mingnt=32 multicast=yes port=MII speed=10Mbit/s
   resources: ire:19 import:c000(size=256) memory:f700000-f71000ff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1570
Odp: Kłopot z połączeniem internetowym
« Odpowiedź #7 dnia: Marzec 24, 2017, 06:46:58 pm »
Podaj jeszcze wyniki:
lsmod
cat /etc/modules
lspci -nn | grep 0200
cat /etc/modprobe.d/blacklist.conf
cat /etc/network/interfaces
« Ostatnia zmiana: Marzec 24, 2017, 06:58:02 pm wysłana przez pavroo »
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline bsharp142

  • Newbie
  • *
  • Wiadomości: 9
Odp: Kłopot z połączeniem internetowym
« Odpowiedź #8 dnia: Marzec 24, 2017, 07:17:26 pm »
W jaki sposób to skopiować? To chorendalna ilość tekstu,  a nosnika nie mam.

Offline lesio

  • Sr. Member
  • ****
  • Wiadomości: 433
Odp: Kłopot z połączeniem internetowym
« Odpowiedź #9 dnia: Marzec 24, 2017, 07:38:56 pm »
tu jest coś nie tak:
*-network DISABLED

Problem ze zdisablowanym ethernetem przewija się w necie często w kontekście ubuntu - widać to częsta przypadłość. Znalazłem tylko jeden link, który być może przyda się:
https://askubuntu.com/questions/651132/networking-disabled-cant-re-enable/651170
Pod koniec tego tekstu jest wymuszenie restartu network-managera.
Tu znalazłem potwierdzenie tego rozwiązania, bardziej kompletne:
https://gist.github.com/micrypt/1207324
« Ostatnia zmiana: Marzec 24, 2017, 07:41:12 pm wysłana przez lesio »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1570
Odp: Kłopot z połączeniem internetowym
« Odpowiedź #10 dnia: Marzec 24, 2017, 07:52:06 pm »
Zrzuć wyniki do plików, np:
lsmod > lsmod.txtPlik znajdziesz w katalogu domowym.
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline bsharp142

  • Newbie
  • *
  • Wiadomości: 9
Odp: Kłopot z połączeniem internetowym
« Odpowiedź #11 dnia: Marzec 24, 2017, 07:57:04 pm »
Co do restart managera to komenda rm /var/lib/NetworkManager/NetworkManager.state nie dziala.

Offline lesio

  • Sr. Member
  • ****
  • Wiadomości: 433
Odp: Kłopot z połączeniem internetowym
« Odpowiedź #12 dnia: Marzec 24, 2017, 09:25:58 pm »
"Nie działa" - co to oznacza? Jaki był komunikat? Nie działa z poziomu użytkownika czy też po poleceniu "su root"? Nie było pliku do skasowania, czy nie potrafiło skasować istniejącego pliku?
Czy poprzednie polecenia z tego linku się wykonały?
https://gist.github.com/micrypt/1207324
su root
service network-manager stop
rm /var/lib/NetworkManager/NetworkManager.state
service network-manager start
reboot -h now

Offline bsharp142

  • Newbie
  • *
  • Wiadomości: 9
Odp: Kłopot z połączeniem internetowym
« Odpowiedź #13 dnia: Marzec 25, 2017, 04:27:00 pm »
Po prostu nic sie nie dzieje. Dodatkowo su root nie dziala, jakis blad ze komenda nie istnieje, uzylem sudo su.

Offline bsharp142

  • Newbie
  • *
  • Wiadomości: 9
Odp: Kłopot z połączeniem internetowym
« Odpowiedź #14 dnia: Marzec 25, 2017, 07:16:58 pm »
Co ciekawe, po zainstalowniu win 8 dalej jest problem. Czy to moze byc cos z karta sieciowa?