Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: Problem z wi fi  (Przeczytany 1380 razy)

Offline szifu20

  • Newbie
  • *
  • Wiadomości: 25
Problem z wi fi
« dnia: Styczeń 21, 2017, 09:38:23 pm »
Problem polega na tym iż mam dostęp do internetu przez kilka minut po czym mnie rozłącza i nie mogę ponownie się połączyć z wi fi i musze uruchomić ponownie komputer i tak w kółko

Offline szifu20

  • Newbie
  • *
  • Wiadomości: 25
Odp: Problem z wi fi
« Odpowiedź #1 dnia: Styczeń 21, 2017, 09:44:54 pm »
Dodatkowo mam problem z odtwarzaniem filmów oczywiście youtube działa.
Chciałbym dodać że nie mam możliwości połączenia się z internetem przez kabel tylko wi fi

Offline lesio

  • Hero Member
  • *****
  • Wiadomości: 528
Odp: Problem z wi fi
« Odpowiedź #2 dnia: Styczeń 21, 2017, 09:49:00 pm »
Na czym polega problem z rozłączaniem wi-fi - czy wyłącza się wi-fi w komputerze, czy widać dalej sieć do której się ma łączyć komputer, czy jest jakiś komunikat związany z nieudanym ponownym połączeniem? Czy można się logować do innej sieci, np. serwowanej przez smartfona?

Offline szifu20

  • Newbie
  • *
  • Wiadomości: 25
Odp: Problem z wi fi
« Odpowiedź #3 dnia: Styczeń 21, 2017, 09:56:43 pm »
Sieć jest widoczna i próbuje ponownie połączyć się z nią lecz bez żadnych efektów. Nie wiem czy mogę się logować do innej sieci jedynie co mam to router

Offline lesio

  • Hero Member
  • *****
  • Wiadomości: 528
Odp: Problem z wi fi
« Odpowiedź #4 dnia: Styczeń 21, 2017, 09:59:22 pm »
A jak wygląda sytuacja, gdy startujesz z jakigoś innego linuxa LIVE-CD? Też rozłącza, czy nie?

Offline szifu20

  • Newbie
  • *
  • Wiadomości: 25
Odp: Problem z wi fi
« Odpowiedź #5 dnia: Styczeń 21, 2017, 10:10:30 pm »
Sprawdzam.  Może mam problem przez to że zainstalowałem nowego linuxa i brakuje mi sterowników

Offline szifu20

  • Newbie
  • *
  • Wiadomości: 25
Odp: Problem z wi fi
« Odpowiedź #6 dnia: Styczeń 21, 2017, 10:19:32 pm »
Jak włączam linuxa przez USB nie ma problemów z wi fi

Offline lesio

  • Hero Member
  • *****
  • Wiadomości: 528
Odp: Problem z wi fi
« Odpowiedź #7 dnia: Styczeń 21, 2017, 10:24:55 pm »
Czyli to nie problem sprzętowy. Coś nie tak z instalacją (lub, jak pisałeś, ze sterownikami)
Uruchom system z dysku twardego i przekaż wyniki działania 2 poleceń:
$ lspci|grep -y net
$ uname -a

Offline szifu20

  • Newbie
  • *
  • Wiadomości: 25
Odp: Problem z wi fi
« Odpowiedź #8 dnia: Styczeń 21, 2017, 10:36:54 pm »
z pierwszego polecenia:
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8192E/RTL8192SE Wireless LAN Controller (rev 01)
06:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8057 PCI-E Gigabit Ethernet Controller (rev 10)
z drugiego:
Linux szifu-R520-R522-R620 4.9.0-12-generic #13-Ubuntu SMP Mon Jan 9 20:01:05 UTC 2017 i686 i686 i686 GNU/Linux

Offline lesio

  • Hero Member
  • *****
  • Wiadomości: 528
Odp: Problem z wi fi
« Odpowiedź #9 dnia: Styczeń 21, 2017, 10:43:37 pm »
Nie sądziłem, że Ubuntu może mieć problem z Realtekiem. Załączam 2 linki do stron, które mogą pomóc (ja nie używam Ubuntu, więc niczego nie sprawdzę):
http://askubuntu.com/questions/855668/how-to-install-wifi-driver-rtl8192
https://sites.google.com/site/easylinuxtipsproject/reserve-7

Offline szifu20

  • Newbie
  • *
  • Wiadomości: 25
Odp: Problem z wi fi
« Odpowiedź #10 dnia: Styczeń 21, 2017, 10:57:31 pm »
Dzięki za pomoc.  Dam znać czy udało mi się opanować sytuację

Offline szifu20

  • Newbie
  • *
  • Wiadomości: 25
Odp: Problem z wi fi
« Odpowiedź #11 dnia: Styczeń 22, 2017, 10:27:36 pm »
Nic nie pomogło nadal ten sam problem.

Offline szifu20

  • Newbie
  • *
  • Wiadomości: 25
Odp: Problem z wi fi
« Odpowiedź #12 dnia: Styczeń 22, 2017, 10:39:14 pm »
To co mi pokazało z polecenia ifconfig
enp0s29f7u3: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.42.45  netmask 255.255.255.0  broadcast 192.168.42.255
        inet6 fe80::f713:ce55:70ad:4098  prefixlen 64  scopeid 0x20<link>
        ether 7a:d8:a9:62:03:39  txqueuelen 1000  (Ethernet)
        RX packets 64728  bytes 75303193 (75.3 MB)
        RX errors 5  dropped 0  overruns 0  frame 5
        TX packets 41901  bytes 6750356 (6.7 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp2s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether be:ee:7c:67:62:b7  txqueuelen 1000  (Ethernet)
        RX packets 3540  bytes 2128032 (2.1 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 3755  bytes 463089 (463.0 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 16  memory 0xf84a8000-f84a8100 

enp6s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 00:24:54:1b:2f:56  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 19 

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Local Loopback)
        RX packets 30226  bytes 1818520 (1.8 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 30226  bytes 1818520 (1.8 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Offline szifu20

  • Newbie
  • *
  • Wiadomości: 25
Odp: Problem z wi fi
« Odpowiedź #13 dnia: Styczeń 22, 2017, 10:55:52 pm »
iwconfig
enp6s0    no wireless extensions.

enp2s0    802.11bgn  Nickname:"rtl8192E"
          Mode:Managed  Frequency=2.417 GHz  Access Point: Not-Associated   
          Bit Rate:1 Mb/s   
          Retry min limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=10/100  Signal level=0 dBm  Noise level=-100 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

lo        no wireless extensions.

enp0s29f7u3  no wireless extensions.

Offline lesio

  • Hero Member
  • *****
  • Wiadomości: 528
Odp: Problem z wi fi
« Odpowiedź #14 dnia: Styczeń 23, 2017, 09:04:38 am »
dot. wyników polecenia ifconfig:
enp0s29f7u3: ten wpis wydaje się być OK ze względu na treść, chociaż nazwa "dziwna", niezgodna z wynikiem polecenia lspci, dotyczy wifi
lo: ten wpis OK, dotyczy loopback (wirtualnego adresu sieciowego localhost)
enp6s0: To wygląda na nieużywany port ethernetowy (RJ-45)
enp2s0: ten wpis wygląda tak, jakby też dotyczył wifi i jest właściwy z uwagi na wynik działania polecenia lspci

patrząc jeszcze na wynik iwconfig można zauważyć, że wifi ma jakby dwa urządzenia zamiast jednego:
o "porządnej nazwie" enp2s0 i widziane jako wifi z poziomu sprzętowego
o "dziwnej nazwie" enp0s29f7u3 i widziane jako wifi z poziomu protokołu sieciowego

Warto by było zerknąć na konfigurację w LIVE CD.

Wygląda jak podwójna konfiguracja i wyraźnie się kłóci ze sobą. Moja propozycja:
- zobaczyć, jakie drivery realteka są zainstalowane w systemie (np. z poziomu synaptica)
- odinstalować wszystkie i kontrolować wynik działania poleceń ifconfig i iwconfig
- próbować instalować wybrane sterowniki, sprawdzać działanie i powtarzać do skutku, na wszelki wypadek rebootując komputer po odinstalowaniu.

Mam jeszcze niejasność co do tego, czy wifi jest wbudowane, czy też uruchamiane na donglu USB?
« Ostatnia zmiana: Styczeń 23, 2017, 09:31:03 am wysłana przez lesio »