Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: Konflikty zależności na SPARKY 3.6 GAME OVER  (Przeczytany 1052 razy)

Offline wlodarek1

  • Newbie
  • *
  • Wiadomości: 26
Konflikty zależności na SPARKY 3.6 GAME OVER
« dnia: Maj 02, 2016, 03:40:18 pm »
Mam zainstalowany SPARKY 3.6 GAME OVER , nie zmieniałem w nim ustawień w pliku
"sources.list" . Ale mam ciągle konflikty pakietów ;
Cytuj
darek@debian:~$ sudo apt-get install kaffeine
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Pakiet kaffeine nie ma dostępnej wersji, ale odnosi się do niego inny pakiet.
Zazwyczaj oznacza to, że pakietu brakuje, został zastąpiony przez inny
pakiet lub nie jest dostępny przy pomocy obecnie ustawionych źródeł.

N: Ignorowanie pliku "50unattended-upgrades.ucf-old" w katalogu "/etc/apt/apt.conf.d/", ponieważ ma on nieprawidłowe rozszerzenie pliku
E: Pakiet kaffeine nie ma kandydata do instalacji
darek@debian:~$ sudo apt-get install kadu
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 kadu : Wymaga: libkadu (= 3.0~rc1-1.1) ale nie zostanie zainstalowany
        Wymaga: libphonon4qt5-4 (>= 4:4.8.0) ale nie zostanie zainstalowany
        Wymaga: libqt5gui5 (>= 5.0.2) ale nie zostanie zainstalowany
        Wymaga: libqt5multimedia5 (>= 5.0.2) ale nie zostanie zainstalowany
        Wymaga: libqt5network5 (>= 5.0.2) ale nie zostanie zainstalowany
        Wymaga: libqt5qml5 (>= 5.0.2) ale nie zostanie zainstalowany
        Wymaga: libqt5quick5 (>= 5.0.2) ale nie zostanie zainstalowany
        Wymaga: libqt5quickwidgets5 (>= 5.3.0) ale nie zostanie zainstalowany
        Wymaga: libqt5webkit5 (>= 5.0.2) ale nie zostanie zainstalowany
        Wymaga: libqt5widgets5 (>= 5.4.0) ale nie zostanie zainstalowany
        Wymaga: libqt5x11extras5 (>= 5.1.0) ale nie zostanie zainstalowany
        Wymaga: libqt5xmlpatterns5 (>= 5.0.2) ale nie zostanie zainstalowany
        Wymaga: libqxmpp0 ale nie zostanie zainstalowany
        Wymaga: phonon4qt5 ale nie zostanie zainstalowany
N: Ignorowanie pliku "50unattended-upgrades.ucf-old" w katalogu "/etc/apt/apt.conf.d/", ponieważ ma on nieprawidłowe rozszerzenie pliku
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.
darek@debian:~$ sudo apt-get install skype
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
N: Ignorowanie pliku "50unattended-upgrades.ucf-old" w katalogu "/etc/apt/apt.conf.d/", ponieważ ma on nieprawidłowe rozszerzenie pliku
E: Nie udało się odnaleźć pakietu skype
darek@debian:~$

Cytuj
darek@debian:~$ sudo aptitude install kaffeine kadu
[sudo] hasło użytkownika darek:
Brak kandydującej wersji kaffeine           
Brak kandydującej wersji kaffeine
Następujące NOWE pakiety zostaną zainstalowane:
  kadu kadu-common{a} libapparmor1{a} libdouble-conversion1{a} libicu55{a} libinjeqt0{a} libinput10{a} libkadu{a} libmpdclient2{a} libotr5{a} libpcre16-3{a} libphonon4qt5-4{a} libproxy1v5{ab} libqca-qt5-2{a} libqca-qt5-2-plugins{a}
  libqca2{a} libqca2-plugin-ossl{a} libqca2-plugins{a} libqt4-sql{a} libqt4-sql-sqlite{a} libqt4-svg{a} libqt5concurrent5{a} libqt5core5a{a} libqt5dbus5{a} libqt5gui5{a} libqt5multimedia5{a} libqt5network5{a} libqt5opengl5{a}
  libqt5printsupport5{a} libqt5qml5{a} libqt5quick5{a} libqt5quickwidgets5{a} libqt5script5{a} libqt5sql5{a} libqt5sql5-sqlite{a} libqt5svg5{a} libqt5webkit5{a} libqt5widgets5{a} libqt5x11extras5{a} libqt5xml5{a}
  libqt5xmlpatterns5{a} libqxmpp0{a} libssl1.0.2{a} libvpx3{a} libwacom-bin{a} libwacom-common{a} libwacom2{a} libxcb-render-util0{a} libxcb-xkb1{a} libxkbcommon-x11-0{a} phonon4qt5{a} phonon4qt5-backend-vlc{a} qt-at-spi{a}
  qttranslations5-l10n{a}
Następujące pakiety zostaną zaktualizowane:
  dbus libdbus-1-3 libdbus-1-3:i386 libqtcore4 libqtgui4
5 pakietów aktualizowanych, 54 instalowanych, 0 do usunięcia i 441 nieaktualizowanych.
Do pobrania 45,5 MB archiwów. Zajęte po rozpakowaniu: 158 MB.
Następujące pakiety mają niespełnione zależności:
 libqt4-xml : Wymaga: libqtcore4 (= 4:4.8.6+git64-g5dc8b2b+dfsg-2+b1) ale zaplanowana jest instalacja wersji 4:4.8.7+dfsg-6.
 libqt4-network : Wymaga: libqtcore4 (= 4:4.8.6+git64-g5dc8b2b+dfsg-2+b1) ale zaplanowana jest instalacja wersji 4:4.8.7+dfsg-6.
 qdbus : Wymaga: libqtcore4 (= 4:4.8.6+git64-g5dc8b2b+dfsg-2+b1) ale zaplanowana jest instalacja wersji 4:4.8.7+dfsg-6.
 libqt4-opengl : Wymaga: libqtcore4 (= 4:4.8.6+git64-g5dc8b2b+dfsg-2+b1) ale zaplanowana jest instalacja wersji 4:4.8.7+dfsg-6.
                 Wymaga: libqtgui4 (= 4:4.8.6+git64-g5dc8b2b+dfsg-2+b1) ale zaplanowana jest instalacja wersji 4:4.8.7+dfsg-6.
 qt4-qtconfig : Wymaga: libqtcore4 (= 4:4.8.6+git64-g5dc8b2b+dfsg-2+b1) ale zaplanowana jest instalacja wersji 4:4.8.7+dfsg-6.
                Wymaga: libqtgui4 (= 4:4.8.6+git64-g5dc8b2b+dfsg-2+b1) ale zaplanowana jest instalacja wersji 4:4.8.7+dfsg-6.
 libqt4-script : Wymaga: libqtcore4 (= 4:4.8.6+git64-g5dc8b2b+dfsg-2+b1) ale zaplanowana jest instalacja wersji 4:4.8.7+dfsg-6.
 libqtdbus4 : Wymaga: libqtcore4 (= 4:4.8.6+git64-g5dc8b2b+dfsg-2+b1) ale zaplanowana jest instalacja wersji 4:4.8.7+dfsg-6.
 libproxy1v5 : W konflikcie z: libproxy1 ale zainstalowana jest wersja 0.4.11-4+b2.
Następujące działania rozwiążą problemy z zależnościami:

      Usunięcie następujących pakietów:                     
1)      holdingnuts                                         
2)      libphonon4                                         
3)      libqt4-dbus                                         
4)      libqt4-network                                     
5)      libqt4-opengl                                       
6)      libqt4-script                                       
7)      libqt4-xml                                         
8)      libqtdbus4                                         
9)      qdbus                                               
10)     qt4-qtconfig                                       
11)     tetzle                                             
12)     warzone2100                                         

      Zatrzymanie bieżących wersji następujących pakietów: 
13)     kadu [niezainstalowany]                             
14)     libkadu [niezainstalowany]                         
15)     libphonon4qt5-4 [niezainstalowany]                 
16)     libproxy1v5 [niezainstalowany]                     
17)     libqt5gui5 [niezainstalowany]                       
18)     libqt5multimedia5 [niezainstalowany]               
19)     libqt5network5 [niezainstalowany]                   
20)     libqt5opengl5 [niezainstalowany]                   
21)     libqt5printsupport5 [niezainstalowany]             
22)     libqt5qml5 [niezainstalowany]                       
23)     libqt5quick5 [niezainstalowany]                     
24)     libqt5quickwidgets5 [niezainstalowany]             
25)     libqt5svg5 [niezainstalowany]                       
26)     libqt5webkit5 [niezainstalowany]                   
27)     libqt5widgets5 [niezainstalowany]                   
28)     libqt5x11extras5 [niezainstalowany]                 
29)     libqt5xmlpatterns5 [niezainstalowany]               
30)     libqxmpp0 [niezainstalowany]                       
31)     phonon4qt5 [niezainstalowany]                       
32)     phonon4qt5-backend-vlc [niezainstalowany]           
33)     qt-at-spi [niezainstalowany]                       

      Pozostawienie następujących problemów z zależnościami:
34)     libqtgui4 poleca qt-at-spi                         
35)     warzone2100-data poleca warzone2100                 
36)     warzone2100-music poleca warzone2100               


Zaakceptować rozwiązanie? [Y/n/q/?] y
Następujące NOWE pakiety zostaną zainstalowane:
  libapparmor1{a} libicu55{a}
Następujące pakiety zostaną USUNIĘTE:
  holdingnuts{a} libphonon4{a} libqt4-dbus{a} libqt4-network{a} libqt4-opengl{a} libqt4-script{a} libqt4-xml{a} libqtdbus4{a} qdbus{a} qt4-qtconfig{a} tetzle{a} warzone2100{a} warzone2100-data{u} warzone2100-music{u}
Następujące pakiety zostaną zaktualizowane:
  dbus libdbus-1-3 libdbus-1-3:i386 libqtcore4 libqtgui4
Następujące pakiety POLECANE przez inne NIE zostaną zainstalowane:
  qt-at-spi
5 pakietów aktualizowanych, 2 instalowanych, 14 do usunięcia i 433 nieaktualizowanych.
Do pobrania 14,1 MB archiwów. Zwolnione po rozpakowaniu: 85,6 MB.
Kontynuować? [Y/n/?]

Jak ten problem rozwiązać  :'(
Z góry dzięki za pomoc .....

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1332
    • SparkyLinux
Odp: Konflikty zależności na SPARKY 3.6 GAME OVER
« Odpowiedź #1 dnia: Maj 02, 2016, 09:32:15 pm »
Witaj.
Powinieneś mieć problemy, 3.6 to stara wersja, ostatnia to 4.2, a najnowsza 4.3 powinna wyjść pod koniec tego tygodnia.
Dlaczego masz problem? Od wydania wersji 3.6 wiele pakietów zmieniło swoje wersje, a niektóre z nich nie są nawet dostępne w repo testing - (kaffeine jest w repo sida)

Masz dwa wyjścia:
1. Zaktualizuj listę pakietów:
sudo apt-get updatei spróbuj ponownie zainstalować to co potrzebujesz.
 
2. Zainstaluj ostatnią wersję 4.2 (lub poczekaj na 4.3).

Nie zalecam aktualizacji z wersji 3.x do 4.x
Sparky 3 bazował na Debianie testowym Jessie, a Sparky 4 bazuje na Debianie testowym Stretch.
Aktualizacja systemu może spowodować sporo problemów.
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline wlodarek1

  • Newbie
  • *
  • Wiadomości: 26
Odp: Konflikty zależności na SPARKY 3.6 GAME OVER
« Odpowiedź #2 dnia: Maj 03, 2016, 12:39:40 pm »
No więc przed chwilą zainstalowałem najnowzy Sparky 4.3 z pulpitem KDE
Stery nvidii zainstalowały się prawidłowo , ale w repo nie jest dostępny odtwarzacz KAFFEINE  :( Dlaczego ? Poprzez "skype-installer" - zainstalowałem Skype  , ale gdy w uruchomionym skype weszłem w ustawienia dźwięku , to system całkowicie się zamroził  :-[
Jedynie twardy reset kompa był wyjściem . I jest jeszcze stary problem z ustawieniem czasu dla debiana[sparky] i dla windows . Po uruchomieniu sparky-iego - czas jest prawidłowy  , ale po przejściu na windows 10 - czas jest wcześniejszy o 2 godz . Strefę czasową ustawiłem na Warszawę .
We wcześniejszych wersjach sparkiego był ten sam problem z czasem na windows obok sparky ......

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1332
    • SparkyLinux
Odp: Konflikty zależności na SPARKY 3.6 GAME OVER
« Odpowiedź #3 dnia: Maj 03, 2016, 10:36:39 pm »
Napisałem poprzednio, iż kaffeine jest repo sida:
https://packages.debian.org/search?keywords=kaffeine&searchon=names&suite=all&section=all&sourceid=mozilla-search
W takim wypadku aktywuj repozytoria Debiana niestabilnego Sid (w synaptic lub w pliku /etc/apt/sources.list.d/sid.list), odśwież listę pakietów i zainstaluj kaffeine.
Następnie zablokuj repo sid-a i ponownie odśwież listę pakietów aby powrócić do poprzednich ustawień.

Problem z czasem możesz rozwiązać konfigurując pakiet 'tzdata':
sudo dpkg-reconfigure tzdataJeśli wybrałeś strefę Europe/Warsaw podczas instalacji, to zmień na UTC ('+' lub '-' 2 godz) aby ustawić prawidłową.
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline wlodarek1

  • Newbie
  • *
  • Wiadomości: 26
Odp: Konflikty zależności na SPARKY 3.6 GAME OVER
« Odpowiedź #4 dnia: Maj 04, 2016, 06:19:59 pm »
Wykonałem to powyżej zalecane polecenie dla "tzdata" i teraz mam i na sparkym i na windows czas o 2 godz  wcześniejszy niż potrzeba czyli UTC  .
Skype nie chce współpracować z kamerką USB ;
Cytuj
Bus 003 Device 002: ID 041e:4064 Creative Technology, Ltd
Ani głosu ani obrazu z kamerki na skype nie ma  :'(

Offline sir_lucjan

  • Newbie
  • *
  • Wiadomości: 25
  • Nic nie działa, jak Polska cała!
Odp: Konflikty zależności na SPARKY 3.6 GAME OVER
« Odpowiedź #5 dnia: Maj 04, 2016, 07:31:47 pm »
Odnośnie stref czasowych całkiem sensowny poradnik jest pod adresem:

https://wiki.debian.org/TimeZoneChanges

Alternatywnie można spróbować użyć systemd.

https://wiki.archlinux.org/index.php/time#Time_zone

Polecenie winno przybrać więc kształt:

timedatectl set-timezone Europe/Warsaw
Oczywiście z prawami roota.

Możesz zawsze skonfigurować NTP by synchronizował czas - sam korzystam z tego rozwiązania od lat i jestem zadowolony.
Dell Inspiron 15-3542 (3542-2538) || Linux Register User: #536661