Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: jasność ekranu  (Przeczytany 4769 razy)

Offline Piejanto

  • Jr. Member
  • **
  • Wiadomości: 60
jasność ekranu
« dnia: Grudzień 26, 2015, 04:21:43 pm »
25.12.2015 r. zainstalowałem na swoim laptopie Acer, z Intelem Pentium w środku, system Antergos 64. Niestety nie działa funkcja jasności pulpitu. Po wpisaniu komendy :
> xrandr --output VGA1 --brightness 1.0 <
otrzymuję odpowiedź:
> Need crtc to set gamma on <
 Proszę o pomoc.

Offline Albedo 0.64

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 589
Odp: jasność ekranu
« Odpowiedź #1 dnia: Grudzień 30, 2015, 04:40:55 pm »
Ja też mam laptop Acer ale nie przypominam sobie by ten sprzęt miał monitor CRT. Z tego co napisałeś wynika, że masz uruchomiony podstawowy sterownik VGA do monitorów kineskopowych a nie masz sterownika grafiki do wyświetlacza LCD. Zainstaluj właściwy sterownik ekranu/karty graficznej.
Linux Mint Debian
Linux registered user 556565

Offline Piejanto

  • Jr. Member
  • **
  • Wiadomości: 60
Odp: jasność ekranu
« Odpowiedź #2 dnia: Grudzień 30, 2015, 05:33:55 pm »
Sprawa wygląda ta: Zainstalowałem Antergosa na dwu podręcznych, tj. na netbooku Acer Aspire One D255 zainstalowałem najpierw Antergosa 32 bity bo ma mniej pamięci. Później zainstalowałem na laptopie zainstalowałem Antergosa 64 bity i od razu miałem problem z ekranem. Postanowiłem spróbować z Antergosem 64 na netbooku i zainstalowało się wszystko pięknie i pięknie działa ale zauważyłem, że na poziomie live juz działała regulacja jasności. Postanowiłem przeinstalować powtórnie Antergosa na laptopie ale na poziomie live jasność nie działa. Tu dodam, że instalacja była z tego samego pendrive. Netbook ma następujące parametry: CPU Intel Atom Processor N450 (1.66Ghz, 512KB cache) Memory 2 GB.  Co do laptopa, to jest to Acer Aspire ale nie mogę się doczytać jego ekranu i wiem tylko, że ma procesor Intel Pentjum i 4 GB memory.  (Aktualnie dałem do przeczyszczenia bebechów i mam odebrać jutro). Co do wpisanego polecenia, to wziąłem je  z porady internetowej i nie jestem pewien, czy jest poprawne. jestem entuzjastą linuxa ale cholerycznie opornym informatycznie. Dlatego proszę o pomoc.

Offline Piejanto

  • Jr. Member
  • **
  • Wiadomości: 60
Odp: jasność ekranu
« Odpowiedź #3 dnia: Grudzień 30, 2015, 05:46:49 pm »
Nie bardzo wiem jak taki sterownik zainstalować.

Offline Albedo 0.64

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 589
Odp: jasność ekranu
« Odpowiedź #4 dnia: Grudzień 31, 2015, 01:41:20 pm »
Potrzebny jest sterownik karty graficznej, która również zarządza wyświetlaczem. Sprawdź jaką masz kartę, później wpisz w przeglądarce słowa kluczowe "nazwa-twojej-karty-graficznej"+sterownik+archlinux+antegros.
Linux Mint Debian
Linux registered user 556565

Offline Piejanto

  • Jr. Member
  • **
  • Wiadomości: 60
Odp: jasność ekranu
« Odpowiedź #5 dnia: Styczeń 03, 2016, 04:43:22 pm »
OK. dzięki. Tak uczynię, gdy tylko maszynka wróci z servisu. Dzięki za podpowiedź.

Offline Piejanto

  • Jr. Member
  • **
  • Wiadomości: 60
Odp: jasność ekranu
« Odpowiedź #6 dnia: Styczeń 15, 2016, 09:03:05 pm »
Chyba nie dam rady. Sprawdziłem model karty graficznej. To jest Intel(R) HD Graphics. Wszedłem na > https://wiki.archlinux.org/index.php/intel_graphics < . Zalogowałem się na konsoli jako su i usiłowałem porobić co mi tam kazali ale otrzymuję odpowiedzi, że nie ma takiego pliku. Nie bardzo wiem, jak sprawdzić numer tej karty graficznej, bo system tylko pokazuje Intel(R) HD Graphics i nic więcej.  Gdy przechodzę na Windows7 kontrola jasności działa. Znaczy tylko na Antergosie nie działa. Poproszę o dalszą pomoc.

Offline Piejanto

  • Jr. Member
  • **
  • Wiadomości: 60
Odp: jasność ekranu
« Odpowiedź #7 dnia: Styczeń 15, 2016, 09:38:18 pm »
Sprawdziłem VGA w Biosie. Ta moja karta to VGA BIOS VERSION Intel V1994 . MOże teraz jakieś porady do zainstalowania regulacji jasności?

Offline Albedo 0.64

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 589
Odp: jasność ekranu
« Odpowiedź #8 dnia: Styczeń 16, 2016, 01:07:57 pm »
Witaj ponownie. Sprawdzałeś na innej dystrybucji? Skoro na Windows jest ok to w Linuksie też powinno działać, tym bardziej, że podzespoły Intela są dobrze obsługiwane. A regulacja jasności z klawiatury (Fn+<-  ->) działa?
« Ostatnia zmiana: Styczeń 16, 2016, 01:09:36 pm wysłana przez Albedo 0.64 »
Linux Mint Debian
Linux registered user 556565

Offline Piejanto

  • Jr. Member
  • **
  • Wiadomości: 60
Odp: jasność ekranu
« Odpowiedź #9 dnia: Styczeń 16, 2016, 01:54:14 pm »
Dzięki, że się odezwałes. Jest tak: - Ja już od dawna korzystam z linuxów. Na tym ACERze już poprzednio miałem Ubuntu, a później, gdy zastosowali pulpit Unity, przeszedłem na Mint-a. Wszystko działało pieknie. Z Mint-a zrezygnowałem ponieważ Ubuntu wierzgnęło i i pozmieniało wszystkie bebech tak, że było mało kompatybilne z programami, których używam. Wykombinowałem sobie, że przejdę na Archa, bo lubię stare, znajome  formy (zaczynałem z Mandreake 6,0) i stabilność, ale że jestem zbyt cienki w instalacji, to wybrałem Antergosa, ze względu na prostotę instalacji. Jak już mówiłem, najpierw zainstalowałem ten system na netbooku i wszystko chodzi ładnie. Na notbooku sie skichało. Przede wszystkim już po uruchomieniu w  stanie LIVE jasność nie działa. I tak: podczas prób regulacji jasności pokazuje się odpowiedni aplet i na tym aplecie jest właściwa reakcja, gdy manipuluję zestawem Fn <...> ale tylko graficznie, gdyż nie ma reakcji w samej jasności. Jasność jest stale na max. Dodam, że na netboku zarówno po instalacji jak i w postaci LIVE regulacja jasności funkcjonuje bez zarzutów. Różnica jest jeszcze taka, że na netbooku mam tylko jeden system, na laptopie mam Windows7, którego nie lubię i nie używam oraz właśnie Linuxa. Nie sądzę aby to sąsiedztwo było przyczyna kłopotu tym bardziej, że zawsze tak miałem i było dobrze.

Offline Albedo 0.64

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 589
Odp: jasność ekranu
« Odpowiedź #10 dnia: Styczeń 16, 2016, 04:15:15 pm »
Mogę jedynie sugerować zmianę dystrybucji. Moim zdaniem szkoda życia na walkę z źle działającym systemem. Trochę się na tym znasz, więc nie będziesz miał z tym problemów. Jak chcesz Archa to rzuć okiem w stronę Manjaro - zbiera teraz najwięcej achów i ochów. Skoro na Mincie działało ci pięknie to może przypasuje ci LMDE.
« Ostatnia zmiana: Styczeń 16, 2016, 04:16:58 pm wysłana przez Albedo 0.64 »
Linux Mint Debian
Linux registered user 556565

Offline Piejanto

  • Jr. Member
  • **
  • Wiadomości: 60
Odp: jasność ekranu
« Odpowiedź #11 dnia: Styczeń 16, 2016, 09:42:01 pm »
Może to i racja. Spróbuję LMDE. Dzięki

Offline Piejanto

  • Jr. Member
  • **
  • Wiadomości: 60
Odp: jasność ekranu
« Odpowiedź #12 dnia: Styczeń 24, 2016, 03:49:27 pm »
Za Chiny Ludowe nie udaje mi się zrobić bootowalnego pendrive z Debianem. Zainstalowałem na partycji linuxowej Ubuntu, ale było to samo. Wrzuciłem Antergosa XFCE 64 jeszcze raz i jest to samo, czyli
  pod Fn+strzałki góra-dół jest działająca ikona regulacji jasności, ale fizycznie obraz się nie rozjaśnia ani nie przyciemnia, choć wskazania ikony pokazują co innego
(dodatkowo mam złe wskazanie godziny wg czasu letniego jak po pierwszej instalacji, ale to mogę przeżyć).
  Antergos jest całkiem OK, a z jasnością już miałem kłopoty na Mint'cie i zawsze jakoś się udawało z tego wybrnąć z pomocą Linuxiarzy.pl.  Jeszcze raz proszę o pomoc.

Offline Piejanto

  • Jr. Member
  • **
  • Wiadomości: 60
Odp: jasność ekranu
« Odpowiedź #13 dnia: Styczeń 26, 2016, 12:10:32 pm »
W Sieci, pod adresem :
https://wiki.manjaro.org/index.php?title=Naprawa_ustawie%C5%84_jasno%C5%9Bci_monitora_w_laptopach 

znalazłem następująca poradę: 
Naprawa ustawień jasności monitora w laptopach
Niektórzy użytkownicy, szczególnie korzystający z komputerów przenośnych, być może zauważyli problem związany z jasnością ekranu, zwłaszcza w porównaniu z jego ustawieniem w systemach Microsoft Windows. Dzieje się tak z uwagi na to, że niektórzy producenci wprowadzili do BIOSu kod, powodujący wyłączenie podświetlania ekranu LCD, automatycznie jeśli system Windows nie zostaje wykryty. Na szczęście istnieje proste polecenie, które usunie tę niedogodność.
W tym celu, GRUB winien zostać poinformowany o konieczności włączenia podświetlania ekranu. Zrobisz to wpisując w terminalu (konsoli) następujące polecenie:

sudo sed "s/\(GRUB_CMDLINE_LINUX=\)\"\"/\1\"acpi_osi=Linux acpi_backlight=vendor\"/" /etc/default/grub -i

Po jego wykonaniu, konieczne będzie jeszcze zaktualizowanie ustawień GRUB, co uczynisz wpisując w terminalu (konsoli) polecenie:

sudo update-grub

Po restarcie komputera, dokonane zmiany zostaną wprowadzone na stałe.
W materiałach Youtube znajdziecie mały filmik obrazujący te zmiany, który dostępny jest tutaj.

Wykonałem tę poradę, ale po w wpisaniu komendy

sudo update-grub

otrzymałem odpowiedź, że nie ma takiego polecenia,  pliku ani katalogu. Wszedłem do Midnight Commandera i zalogowawszy sie jako su kazałem zachować zmiany.

Poprzednio pierwsze linie gruba wyglądały tak (chodzi o piątą linię.):

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Antergos"

GRUB_CMDLINE_LINUX_DEFAULT="quiet "

GRUB_CMDLINE_LINUX=""

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable Hidden Menu, and optionally hide the timeout count
#GRUB_HIDDEN_TIMEOUT=5

(...)
Teraz mój grub wygląda następująco (zmiana w piątej linijce):

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Antergos"

GRUB_CMDLINE_LINUX_DEFAULT="quiet "

GRUB_CMDLINE_LINUX="acpi_osi=Linux acpi_backlight=vendor"

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable Hidden Menu, and optionally hide the timeout count
#GRUB_HIDDEN_TIMEOUT=5
#GRUB_HIDDEN_TIMEOUT_QUIET=true

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
#GRUB_COLOR_NORMAL="light-blue/black"
#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/path/to/wallpaper"
GRUB_THEME="/boot/grub/themes/Antergos-Default/theme.txt"


# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

#GRUB_SAVEDEFAULT="true"



Niestety.... W działaniu pozostaje bez zmiany i w dalszym ciągu wypala mi oczy. Proszę o pomoc.





Offline Albedo 0.64

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 589
Odp: jasność ekranu
« Odpowiedź #14 dnia: Styczeń 26, 2016, 06:19:48 pm »
Witaj.  Trochę zagmatwałeś sytuację i już nie kumam o co tu chodzi. Jeśli działało dobrze na Ubuntu/Mint to przyczyna tkwi w sterownikach a nie w GRUB-ie. Dlaczego nie możesz utworzyć live usb? Na windzie masz UNetbootin lub LiLi USB Creator które robią to bez problemu. Nie znam Antegrosa ale przecież to Arch więc na pewno jest dostępny UNetbootin. Zajrzyj tu:
https://www.archlinux.org/packages/community/i686/unetbootin/
 Możesz zrobić to również przy pomocy systemu live a w ostateczności jest jeszcze opcja nagrania iso na CD/DVD. Do edycji GRUB-a używam GRUB Customizer, w zakładce "Ustawienia ogólne" jest linijka "ustawienia kernela"  - czyli twoja 5-ta linijka w pliku konfiguracyjnym. I aktualizacja GRUB-a dziala bez pudła. Weź też pod uwagę, że porady dla Manjaro nie muszą być skuteczne w Antegrosie.
Linux Mint Debian
Linux registered user 556565