Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: Problem z uruchomieniem modemu Dell Wireless 5570 HSPA+  (Przeczytany 1371 razy)

Offline drukowaniew3d

  • Newbie
  • *
  • Wiadomości: 4
Problem z uruchomieniem modemu Dell Wireless 5570 HSPA+
« dnia: Październik 25, 2015, 06:55:02 pm »
Witam,

Od dłuższego czasu próbuję podłączyć modem 3g "Dell Wireless 5570 HSPA+ (42Mbps) Mobile Broadband Card" pod Ubuntu 12.04LTS.
Problem w tym, że po wydaniu poleceń
sudo modprobe usbserial vendor=0x413c product=0x81a3
oraz

echo "413c 81a3" > /sys/bus/usb-serial/drivers/option1/new_id
nie tworzy mi się plik /dev/ttyUSB* i dlatego nie mogę go uruchmić pod ModemManagerem.
Wzoruję się na poradniku:
https://wiki.ubuntu.com/NetworkManager/Hardware/3G/Probing


dmesg:
Bus 003 Device 003: ID 413c:81a3 Dell Computer Corp.
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0
  bDeviceProtocol         0
  bMaxPacketSize0        64
  idVendor           0x413c Dell Computer Corp.
  idProduct          0x81a3
  bcdDevice            0.06
  iManufacturer           1 Sierra Wireless, Incorporated
  iProduct                2 Dell Wireless 5570 HSPA+ (42Mbps) Mobile Broadband Card
  iSerial                 3
  bNumConfigurations      2
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength          204
    bNumInterfaces          4
    bConfigurationValue     1
    iConfiguration          0
    bmAttributes         0xe0
      Self Powered
      Remote Wakeup
    MaxPower              500mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        2
      bAlternateSetting       0
      bNumEndpoints           3
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass      0
      bInterfaceProtocol      0
      iInterface              0
      ** UNRECOGNIZED:  05 24 00 10 01
      ** UNRECOGNIZED:  05 24 01 00 00
      ** UNRECOGNIZED:  04 24 02 02
      ** UNRECOGNIZED:  05 24 06 00 00
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x82  EP 2 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x000c  1x 12 bytes
        bInterval               9


lsusb:
Bus 001 Device 002: ID 8087:8008 Intel Corp.
Bus 002 Device 002: ID 8087:8000 Intel Corp.
Bus 003 Device 002: ID 045e:0745 Microsoft Corp. Nano Transceiver v1.0 for Bluetooth
Bus 004 Device 002: ID 0951:168e Kingston Technology
Bus 003 Device 003: ID 413c:81a3 Dell Computer Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 0c45:649d Microdia
Bus 002 Device 003: ID 8087:07dc Intel Corp.
Bus 002 Device 004: ID 0a5c:5801 Broadcom Corp. BCM5880 Secure Applications Processor with fingerprint swipe sensor

ls /dev/ttyUSB*:
ls: nie ma dostępu do /dev/ttyUSB*: Nie ma takiego pliku ani katalogu
Proszę o jakąś podpowiedź bo walczę już od kilku tygodni....

Offline Maromann

  • Jr. Member
  • **
  • Wiadomości: 59
Odp: Problem z uruchomieniem modemu Dell Wireless 5570 HSPA+
« Odpowiedź #1 dnia: Październik 26, 2015, 02:09:55 pm »
googlując znalazłem
http://unix.stackexchange.com/questions/152019/problems-with-dell-wireless-5570-hspa-mobile-broadband-card
w odpowiedzi jest przekierowanie do następnej strony, na której jest jakieś rozwiązanie.

widać, że ten modem, to jakiś wynalazek.

Offline Albedo 0.64

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 589
Odp: Problem z uruchomieniem modemu Dell Wireless 5570 HSPA+
« Odpowiedź #2 dnia: Październik 26, 2015, 06:56:06 pm »
Podziwiam twoją cierpliwość i upór skoro przez kilka tygodni męczysz się z przestarzałą wersją Ubuntu. Masz jakiś bardzo szczególny powód by się przy tym upierać? Być może aktualny LTS 14.04 ma już sterowniki do tego modemu. Ja bym spróbował Mint 17.3 który bazuje na 14.04 i ma najnowsze pakiety z backportów. Niestety, producent nie udostępnia sterowników na inne systemy poza windows (sprawdziłem). Użytkownicy Linuksa często muszą szukać alternatywnych rozwiązań w takich przypadkach. Ja dawno już przestałem walczyć z systemem by uruchomić jakieś urządzenie bez wsparcia i sterowników. Od kiedy posiadam smartfona sprzedałem modemy mobilne (miałem trzy Huaweii i wszystkie jakoś działały) a telefon robi za modem USB lub router WiFi w zależności od potrzeb ponieważ posiada obie te funkcje i obie działają znakomicie. Radzę ci używać najnowszej aktualnej wersji wybranego systemu i kompatybilnych urządzeń zamiast pchać się pod prąd. Pozdrawiam.
Linux Mint Debian
Linux registered user 556565

Offline drukowaniew3d

  • Newbie
  • *
  • Wiadomości: 4
Odp: Problem z uruchomieniem modemu Dell Wireless 5570 HSPA+
« Odpowiedź #3 dnia: Październik 28, 2015, 09:11:28 pm »
Posłuchałem się i zainstalowałem Ubuntu 15.10. Faktycznie karta się odnalazła w ModemManagerze, ale wyskakuje komunikat który znowu pochłonął mi dużo czasu już...

Offline Albedo 0.64

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 589
Odp: Problem z uruchomieniem modemu Dell Wireless 5570 HSPA+
« Odpowiedź #4 dnia: Październik 29, 2015, 07:27:14 pm »
Wygląda na to, że zadziałało. Jedna uwaga (właściwie dwie): po pierwsze po instalacji sterowników sieciowych dobrze jest zrobić restart komputera, po drugie na panelu widać, że jest włączone wifi. Nie mogą być uruchomione dwa połączenia sieciowe na raz, rozłącz wifi zanim skonfigurujesz i uruchomisz modem komórkowy.
Linux Mint Debian
Linux registered user 556565

Offline drukowaniew3d

  • Newbie
  • *
  • Wiadomości: 4
Odp: Problem z uruchomieniem modemu Dell Wireless 5570 HSPA+
« Odpowiedź #5 dnia: Październik 30, 2015, 09:48:38 am »
Restart był, wyłączyłem również WiFi... nie pomogło. Poniżej przedstawiam próby uruchomienia za pomocą terminala:

sudo wvdial cellular:
--> WvDial: Internet dialer version 1.61
--> Cannot open /dev/ttyACM0: No such file or directory
--> Cannot open /dev/ttyACM0: No such file or directory
--> Cannot open /dev/ttyACM0: No such file or directory

Dalej nie ma plików określających sprzęt....

Offline drukowaniew3d

  • Newbie
  • *
  • Wiadomości: 4
Odp: Problem z uruchomieniem modemu Dell Wireless 5570 HSPA+
« Odpowiedź #6 dnia: Listopad 03, 2015, 06:19:08 pm »
Pomoże mi ktoś w rozwiązaniu problemu? Zależy mi na uruchomieniu karty w laptopie, a nie na zewnętrznym rozwiązaniu. Przeglądam internet w poszukiwaniu rozwiązania i nic nie mogę dopasować żeby działało...

Offline Albedo 0.64

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 589
Odp: Problem z uruchomieniem modemu Dell Wireless 5570 HSPA+
« Odpowiedź #7 dnia: Listopad 04, 2015, 06:53:24 pm »
Najpierw kombinowałeś z network managerem a teraz dodałeś wvdial, nie jestem przekonany czy oba te programy mogą funkcjonować jednocześnie. Być może powinieneś odinstalować NM jeśli go nie używasz. Komunikat "Cannot open /dev/ttyACM0: No such file or directory" oznacza, że nie ma takiego pliku lub katalogu, czyli coś poszło nie tak podczas konfiguracji. Możliwą przyczyną może być brak praw dostępu. Sprawdź, czy jako użytkownik jesteś w grupie dialout (menu-administracja-użytkownicy i grupy). Zajrzyj pod ten adres : http://www.nibyblog.pl/wvdial-konfiguracja-dla-polaczen-z-play-online-1753.html jest tu trochę informacji na temat wvdial. Sam nigdy nie używałem wvdial bo NM działał dobrze a do modemów Huawei producent udostępnił sterowniki. Jak pisałem wcześniej, obecnie używam telefonu do połączeń komórkowych bo nie lubię komplikacji. W związku z powyższym trudno jest mi wywróżyć jak poprawnie uruchomić wynalazek Della, napisz może do pomocy technicznej Della. Pozdrawiam.
Linux Mint Debian
Linux registered user 556565