Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja-> Przywitaj się. Wątki z problemami zamieszczone w dziale "Przywitaj się" będą usuwane.

Autor Wątek: LILO  (Przeczytany 5449 razy)

Offline Max Vanach

  • Jr. Member
  • **
  • Wiadomości: 51
LILO
« dnia: Październik 19, 2015, 10:00:19 pm »
Czy wie ktos jak skonfigurowac LILO ?
Gdyz mam maly problemik, a mianowicie
problemik polega na tym, ze mam zainstalowane 3 systemy:

- Slackware
- Sparky
- Windows 7

no i Slackware i Windows 7 uruchamiaja sie bez problemowo natomiast  Sparky juz nie,
dochodzi do okienka logowania i stoi zero kontaktu nie reaguje na klawiature ani mysz,
po trzech sekundach zawiesza sie calkowicie przez 3 sekundy miga kursor w okienku do wpisania hasla
a po tych trzech sekundach calkowita zawicha, kursor sataje no i nie pozostaje mi nic innego jak
twardo wylaczyc lapka, naszczescie na powera jeszcze reaguje i wylacza mi lapka tak bym
pewnie zostal zmuszony do gwaltownego wyjecia baterii w lapku...

Ok ponizej zawartosc lilo.conf:

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
lba32 # Allow booting past 1024th cylinder with a recent BIOS
boot = /dev/sda

#compact # faster, but won't work on all systems.

# Append any additional kernel parameters:
append="Bhaal vt.default_utf8=0"
prompt
#timeout = 300
# Normal VGA console
vga = normal
# Ask for video mode at boot (time out to normal in 30s)
#vga = ask
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# ramdisk = 0 # paranoia setting
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/sda4
label = Slackware
read-only # Partitions should be mounted read-only for checking
# Linux bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/sda2
label = Sparky
read-only # Partitions should be mounted read-only for checking
# Linux bootable partition config ends
# Windows bootable partition config begins
other = /dev/sda3
label = Windows
# map-drive = 0x80
# to = 0x81
# map-drive = 0x81
# to = 0x80
table = /dev/sda
# Windows bootable partition config ends

Kolejnosc instalowania systemow:

numer 1 oczywiscie Sparky ;)
numer 2 niestety Windows 7 "przykra koniecznosc, nie znalazlem kompilatora Delphi na linuksa"
numer 3 Slackware moje najnowesze odkrycie po 2 latach szukania idealnego systemu dla siebie wkoncu go znalazlem ;)

prosze nie pisac, ze mam usunac Sparky'ego czy zainstalowac ponownie, przed instalacja Slackware i Lilo dzialal idealnie,
no i mam na nim zbyt wiele aplikacji zarowno zainstalowane jak i napisane (wlasnego autorstwa) no i bardzo lubie z niego
korzystac do zwyklych codziennych glupot i nie tylko ;)

Z gory bardzo bardzo dzieki za pomoc ;)
« Ostatnia zmiana: Październik 19, 2015, 10:23:55 pm wysłana przez Max Vanach »

Offline Maromann

  • Jr. Member
  • **
  • Wiadomości: 59
Odp: LILO
« Odpowiedź #1 dnia: Październik 20, 2015, 02:56:52 pm »
przecież zamiast lilo możesz zainstalować gruba czy to ze Slackwere'a, czy to z Debiana. ja mam podobnie, przy czym zamiast Slackware'a mam SalixOS. odinstalowałem lilo, zainstalowałem gruba.

Offline Max Vanach

  • Jr. Member
  • **
  • Wiadomości: 51
Odp: LILO
« Odpowiedź #2 dnia: Październik 20, 2015, 08:01:04 pm »
No wlasnie wolalbym LILO ale jak nie bedzie sposobu na moj problemik to trudno powrot do gruba ;(
« Ostatnia zmiana: Październik 20, 2015, 08:02:39 pm wysłana przez Max Vanach »

Offline Max Vanach

  • Jr. Member
  • **
  • Wiadomości: 51
Odp: LILO
« Odpowiedź #3 dnia: Październik 21, 2015, 08:13:49 am »
Wrocilem do Grub'a i podobna sytuacja tyle, że teraz w stosunku do Slackware.
Zamiast Slackware laduje sie to samo okienko logowania co w LILO dla Sparky czyli okienko logowania Sparky'ego i wystepuje ta sama zawiecha czy jest jakis sposob zebym mial na LILO lub GRUB'ie i Sparky'ego i Slackware ?

Wyprzedzam pytanie: Tak Slackware wogole się nie laduje mimo, ze Grub go wykryl zamiast Slackware laduje mi się Sparky i zawiesza się na okienku logowania...

Offline Albedo 0.64

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 589
Odp: LILO
« Odpowiedź #4 dnia: Październik 21, 2015, 07:40:50 pm »
W tym przypadku może pomóc specjalne narzędzie takie jak Super Grub2 http://linuxiarze.pl/distro-supergrub2disk/
czy Rescatux http://linuxiarze.pl/distro-rescatux/
Według mnie problem polega na tym, że Sparky i wszystkie nowe dystrybucje używają już programu inicjującego systemd a tradycyjny Slack wciąż używa przestarzałych LiLo i sysvinit.
« Ostatnia zmiana: Październik 21, 2015, 07:42:41 pm wysłana przez Albedo 0.64 »
Linux Mint Debian
Linux registered user 556565

Offline Max Vanach

  • Jr. Member
  • **
  • Wiadomości: 51
Odp: LILO
« Odpowiedź #5 dnia: Październik 21, 2015, 09:55:49 pm »
z GRUB'em juz sobie poradzilem, musialem powprowadzac pare zmian w grub.cfg i teraz jest ok, ale jak ktokolwiek wie jak skonfgurowac poprawnie lilo, bylo by swietnie bo jednak llilo bardziej mi pasuje niz grub, a moze sam w koncu dojde do rozwiazania to opisze jak to mowia dla potomnych ;) Dzieki Wszystkim...

Offline Maromann

  • Jr. Member
  • **
  • Wiadomości: 59
Odp: LILO
« Odpowiedź #6 dnia: Październik 22, 2015, 01:33:44 pm »
Według mnie problem polega na tym, że Sparky i wszystkie nowe dystrybucje używają już programu inicjującego systemd a tradycyjny Slack wciąż używa przestarzałych LiLo i sysvinit.
ciekawe stwierdzenie, jakkolwiek nie wydaje mi się prawdziwe. od dłuższego czasu na jednym z komputerów mam cztery systemy na dwóch dyskach. mam zainstalowane dwa gruby - jeden z semplice linuxa, drugi z salixos. czasami startuję z jednego, czasami z drugiego dysku. z żadnym z grubów nie miałem takich efektów, jak opisywane tutaj. może jednak problem tkwi w niedostatecznej znajomości oprogramowania? w przypadku gruba nie ma problemów z dokumentacją. jest oficjalna, ale i wiele porad i manuali. na stronie projektu LILO jest trochę dokumentacji. może lekko starawej, ale chyba aktualnej. ale np tutaj http://www.tldp.org/HOWTO/LILO.html jest podręcznik z 2010.